Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Как вставить драйвер wifi из старого ядра ubuntu 18.04 в более новое ядро ubunt  (Прочитано 5815 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sergey5259

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Здравствуйте!
WiFi адаптер на чипе mt7610u работет в Ubuntu 18.04 с ядром 4.19, но не работает в Ubuntu 20.04 с ядрами 5.4 и выше до 5.13, дальше не проверял.

Проблема, как мне кажется, в версии драйвера. В ядре 18.04 используется драйвер mt76x0 1-9:1.0   160,8 kB (160 753 bytes), а в ядрах Ubuntu 20.04 начиная с 5.4 используется драйвер mt76x0u 2-3:1.0   24,7 kB (24 657 bytes).

В наборе драйверов mediatek Ubuntu 20.04, драйвера mt76x0 вообще нет.

Вопрос: как вставить драйвер mt76x0 в ядро 5.4 или более новое?

Погуглил, но ничего толкового не нашёл пока.
Помогите, плиз!
« Последнее редактирование: 02 Февраля 2022, 20:49:48 от Sergey5259 »

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 3046
    • Просмотр профиля
Наверное, найти этот драйвер в Ubuntu-18.04, перенести в 20.04, скомпилировать и установить.
Хотя, конечно, правильнее будет купить адаптер поновее.
Пётр.

Оффлайн F12

  • Администратор
  • Старожил
  • *
  • Сообщений: 4691
    • Просмотр профиля
Sergey5259, а собрать из исходников не пробовал?

Оффлайн Sergey5259

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Цитировать
а собрать из исходников не пробовал?
Пробовал, в компиляции я не силён, точнее вообще ни бум-бум
make -C tools
make[1]: Entering directory '/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory '/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/tools'
/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/tools/bin2h
chipset = mt7650u
chipset = mt7630u
chipset = mt7610u
cp -f os/linux/Makefile.6 /home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux/Makefile
make -C /lib/modules/5.9.16-050916-generic/build SUBDIRS=/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux modules
make[1]: Entering directory '/usr/src/linux-headers-5.9.16-050916-generic'
  LEX     scripts/kconfig/lexer.lex.c
/bin/sh: 1: flex: not found
make[3]: *** [scripts/Makefile.host:9: scripts/kconfig/lexer.lex.c] Error 127
make[2]: *** [Makefile:606: syncconfig] Error 2
make[1]: *** [Makefile:711: include/config/auto.conf.cmd] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.9.16-050916-generic'
make: *** [Makefile:394: LINUX] Error 2

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5611
  • Все по палатам!
    • Просмотр профиля
Извините, я все еще учусь

Оффлайн Sergey5259

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Цитировать
sudo apt install flex
Поставил flex ребутнул, получил:
make -C tools
make[1]: Entering directory '/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory '/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/tools'
/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/tools/bin2h
chipset = mt7650u
chipset = mt7630u
chipset = mt7610u
cp -f os/linux/Makefile.6 /home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux/Makefile
make -C /lib/modules/5.9.16-050916-generic/build SUBDIRS=/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux modules
make[1]: Entering directory '/usr/src/linux-headers-5.9.16-050916-generic'
  LEX     scripts/kconfig/lexer.lex.c
  YACC    scripts/kconfig/parser.tab.[ch]
/bin/sh: 1: bison: not found
make[3]: *** [scripts/Makefile.host:17: scripts/kconfig/parser.tab.h] Error 127
make[3]: *** [scripts/kconfig/parser.tab.h] Deleting file 'scripts/kconfig/parser.tab.c'
make[2]: *** [Makefile:606: syncconfig] Error 2
make[1]: *** [Makefile:711: include/config/auto.conf.cmd] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.9.16-050916-generic'
make: *** [Makefile:394: LINUX] Error 2

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5611
  • Все по палатам!
    • Просмотр профиля
Sergey5259, в гугле поиск - "/bin/sh: 1: bison: not found"
типа https://github.com/drtyhlpr/rpi23-gen-image/issues/194
где написано
sudo apt install bison
и т.д и т.п.
Извините, я все еще учусь

Оффлайн Sergey5259

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Бизон поставил, получил:make -C tools
make[1]: Entering directory '/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory '/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/tools'
/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/tools/bin2h
chipset = mt7650u
chipset = mt7630u
chipset = mt7610u
cp -f os/linux/Makefile.6 /home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux/Makefile
make -C /lib/modules/5.9.16-050916-generic/build SUBDIRS=/home/one/Documents/wifi7610/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux modules
make[1]: Entering directory '/usr/src/linux-headers-5.9.16-050916-generic'
make[2]: *** No rule to make target 'arch/x86/tools/relocs_32.c', needed by 'arch/x86/tools/relocs_32.o'.  Stop.
make[1]: *** [arch/x86/Makefile:213: archscripts] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.9.16-050916-generic'
make: *** [Makefile:394: LINUX] Error 2

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5611
  • Все по палатам!
    • Просмотр профиля
*** No rule to make target 'arch/x86/tools/relocs_32.c', needed by 'arch/x86/tools/relocs_32.o'.  Stop
- это в гугл.
будет типа https://askubuntu.com/questions/232840/my-makefile-results-in-no-rule-to-make-target-arch-x86-tools-relocs-c-needed
Там читай...

Извините, я все еще учусь

Оффлайн Onlininer

  • Активист
  • *
  • Сообщений: 926
    • Просмотр профиля
"Никогда такого не было... и вот -опять!"

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5611
  • Все по палатам!
    • Просмотр профиля
readme читал?
Ну зачем же так сразу... надо по шагам, не спеша... к Новому году и соберет.;)
Извините, я все еще учусь

Оффлайн Onlininer

  • Активист
  • *
  • Сообщений: 926
    • Просмотр профиля
readme читал?
Ну зачем же так сразу... надо по шагам, не спеша... к Новому году и соберет.;)
>:( Не, я о том, что там ограничения... по старым ядрам...
"Никогда такого не было... и вот -опять!"

Оффлайн F12

  • Администратор
  • Старожил
  • *
  • Сообщений: 4691
    • Просмотр профиля
Sergey5259, а собрать из исходников не пробовал?
:idiot2: readme читал?
- ты б у меня еще спросил, пробовал ли я сам собирать этот драйвер?.. нет, и не читал, и собирать не пробовал, ибо не мне это нужно... просто увидел о каком чипе речь, заглянул на офсайт и увидел, что там предлагается вариант для Linux...
А читать, или приступать к сборке не читая весь readme, это уже дело сугубо личное, для того кто это делает ::)

Оффлайн Sergey5259

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Цитировать
будет типа https://askubuntu.com/questions/232840/my-makefile-results-in-no-rule-to-make-target-arch-x86-tools-relocs-c-needed
Там читай...
Не работают эти опрерации, выдают ошибки:
sudo apt-get install linux-headers-5.9.16-050916:i386
[sudo] password for one:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-5.9.16-050916:i386
E: Couldn't find any package by glob 'linux-headers-5.9.16-050916'
E: Couldn't find any package by regex 'linux-headers-5.9.16-050916'
one@~$sudo apt-get install linux-headers-$(uname -r | sed 's/\(.*\)-[a-z]*/\1/'):i38
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-5.9.16-050916:i38
E: Couldn't find any package by glob 'linux-headers-5.9.16-050916'
E: Couldn't find any package by regex 'linux-headers-5.9.16-050916'
one@~$sudo apt-get install linux-headers-$5.9.16-050916 | sed 's/\(.*\)-[a-z]*/\1/'):i38
bash: syntax error near unexpected token `)'

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14037
  • Xubuntu 18.04
    • Просмотр профиля
Не работают эти опрерации, выдают ошибки:
У вас ядро нестандартное стоит. В этом и проблема. Команды для стандартного ядра. Вообще этот драйвер совсем и не надо собирать. На стандатрном ядре из коробки всё работать должно.
Короче ерундой занимаетесь.
Я в личке не консультирую. Вопросы задавайте на форуме.

 

Страница сгенерирована за 0.058 секунд. Запросов: 25.