Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Gimp не получается установить  (Прочитано 1953 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн elenka

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Gimp не получается установить
« : 11 Марта 2022, 19:51:16 »
Через снап не хочу ставить, а через репозиторий не получается(((

насчет flatpak, что это такое не второй снап?

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 11 Марта 2022, 20:05:14 от elenka »

Оффлайн andytux

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 7150
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #1 : 12 Марта 2022, 04:37:43 »
Цитировать
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты
"Сломанные пакеты", "неудовлетворенные зависимости " - второй "самый популярный вопрос". Добрая половина форума исписана.
По этому поводу, вспоминается одна показательная тема.
« Последнее редактирование: 12 Марта 2022, 05:34:03 от andytux »

Оффлайн AlexDem

  • Активист
  • *
  • Сообщений: 696
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #2 : 12 Марта 2022, 15:08:06 »
Через снап не хочу ставить
С чего это вдруг? Как сказал товарищ Сухов: "Лучше, конечно, помучиться"?

Оффлайн jurganov

  • Старожил
  • *
  • Сообщений: 1544
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #3 : 12 Марта 2022, 16:06:47 »
С чего это вдруг? Как сказал товарищ Сухов: "Лучше, конечно, помучиться"?
а что, лучше ОС снапами загаживать?

Пользователь добавил сообщение 12 Марта 2022, 16:12:13:
0) вообще то откуда нам знать на какую ОС ты ставишь. укажи версию Ubuntu и версию ядра.
1) открываешь синаптик
в поиск вводишь libgimp2.0
и глядишь - можно устанвить нужную версию или не можно? Если можно - устанавливаешь
и так каждую неразрешенную зависимость
2) иногда можно в репозиториях подкючить другие, если неподключены
3) ломать пакетную базу не советую.
4) если совсем уж никак, и твоя ОС устаревшая, попробуй накатить ядро посвежее
« Последнее редактирование: 12 Марта 2022, 16:12:13 от jurganov »

Оффлайн elenka

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #4 : 12 Марта 2022, 20:13:57 »
вообще то откуда нам знать на какую ОС ты ставишь. укажи версию Ubuntu и версию ядра.
1) открываешь синаптик
в поиск вводишь libgimp2.0

Ubuntu 20,04, ядро самое свежее


в синаптике вышел пакет libgimp2.0, но установить его не получается, пишет "исправте сперва ошибке в библеотеке".


Пользователь добавил сообщение 12 Марта 2022, 20:19:54:
По этому поводу, вспоминается одна показательная тема.

почитав...не совсем понятно как лечить
« Последнее редактирование: 12 Марта 2022, 20:19:54 от elenka »

Оффлайн KJOI

  • Активист
  • *
  • Сообщений: 286
  • ALT Linux
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #5 : 12 Марта 2022, 21:06:34 »
почитав...не совсем понятно как лечить
>= 2.10.18
Еще в ошибках написано что не найден модуль qtsql.
Если вы не меняли стандартные репозитории то попробуйте просто обновить кэш пакетов и повторить установку. Если меняли верните как было.
« Последнее редактирование: 12 Марта 2022, 21:11:44 от KJOI »
Русский Линукс: https://www.basealt.ru/products/simplylinux/
Мой проект git «Kernel Manager» linux: https://github.com/Koi-foo/kernel-manager/

Оффлайн elenka

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #6 : 12 Марта 2022, 22:28:29 »
просто обновить кэш пакетов

как это делается?

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 3046
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #7 : 12 Марта 2022, 23:05:08 »
Попробуйте ввести как root
apt-get update
Пётр.

Оффлайн jurganov

  • Старожил
  • *
  • Сообщений: 1544
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #8 : 13 Марта 2022, 05:51:18 »
в синаптике вышел пакет libgimp2.0, но установить его не получается, пишет "исправте сперва ошибке в библеотеке".

Приведите точную цитату

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 3046
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #9 : 13 Марта 2022, 16:22:48 »
Попробуйте ещё ввести как root
apt-get -f install
Пётр.

Оффлайн elenka

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #10 : 13 Марта 2022, 18:03:01 »
Попробуйте ещё ввести как root
apt-get -f install

Перед этим ввела команду apt-get update

(Нажмите, чтобы показать/скрыть)

Пользователь добавил сообщение 13 Марта 2022, 18:05:41:
Приведите точную цитату
Не удалось выполнить изменения!
Сначала необходимо исправить ошибки в пакетах.


(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 13 Марта 2022, 18:05:41 от elenka »

Оффлайн jurganov

  • Старожил
  • *
  • Сообщений: 1544
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #11 : 13 Марта 2022, 19:08:01 »
Не удалось выполнить изменения! Сначала необходимо исправить ошибки в пакетах.

в синаптике вышел пакет libgimp2.0, но установить его не получается, пишет "исправте сперва ошибке в библеотеке".
Согласись - есть разница ))
Копируешь текст ошибки и гуглишь в яндексе. Примерно так
https://yandex.ru/search/?clid=2186623&text=%D0%9D%D0%B5+%D1%83%D0%B4%D0%B0%D0%BB%D0%BE%D1%81%D1%8C+%D0%B2%D1%8B%D0%BF%D0%BE%D0%BB%D0%BD%D0%B8%D1%82%D1%8C+%D0%B8%D0%B7%D0%BC%D0%B5%D0%BD%D0%B5%D0%BD%D0%B8%D1%8F!+%D0%A1%D0%BD%D0%B0%D1%87%D0%B0%D0%BB%D0%B0+%D0%BD%D0%B5%D0%BE%D0%B1%D1%85%D0%BE%D0%B4%D0%B8%D0%BC%D0%BE+%D0%B8%D1%81%D0%BF%D1%80%D0%B0%D0%B2%D0%B8%D1%82%D1%8C+%D0%BE%D1%88%D0%B8%D0%B1%D0%BA%D0%B8+%D0%B2+%D0%BF%D0%B0%D0%BA%D0%B5%D1%82%D0%B0%D1%85.&lr=65&redircnt=1647187298.1
на сайте росинки привели решение с сайта рунту... http://rosinka.rosix.ru/index.php?topic=222.0
Цитировать
sudo dpkg --configure -a
sudo apt-get update
sudo apt-get install -f
В случае, если после этого проблема не разрешилась, необходимо перезагрузиться и на экране выбора ОС выбрать Режим восстановления (Recovery Mode), затем в появившемся меню выбрать dpkg   Repair broken packages (функцию восстановления поврежденных пакетов), затем снова перезагрузиться.
Попробуй

Оффлайн elenka

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Gimp не получается установить
« Ответ #12 : 13 Марта 2022, 23:31:49 »
Код: [Выделить]
sudo dpkg --configure -a
sudo apt-get update
sudo apt-get install -f
В случае, если после этого проблема не разрешилась, необходимо перезагрузиться и на экране выбора ОС выбрать Режим восстановления (Recovery Mode), затем в появившемся меню выбрать dpkg   Repair broken packages (функцию восстановления поврежденных пакетов), затем снова перезагрузиться.
Попробуй

к сожалению не помогло пока


Пользователь добавил сообщение 14 Марта 2022, 12:21:03:
переустановила Ubuntu и все поставилось.
« Последнее редактирование: 14 Марта 2022, 12:21:03 от elenka »

 

Страница сгенерирована за 0.055 секунд. Запросов: 25.