Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Проблемы с автомонтированием и копированием.  (Прочитано 1080 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн V@

  • Автор темы
  • Активист
  • *
  • Сообщений: 256
    • Просмотр профиля
Ubuntu Mate 20.04
После внезапного отключения питания начались проблемы с автомонтированием и копированием файлов, диск зашифрован, при запуске системы два раза нужно вводить пароль. После входа не монтировались внешние диски, только вручную, теперь проблема с переносом некоторых файлов между внешними дисками( input/output error).

(Нажмите, чтобы показать/скрыть)

Оффлайн Semenov_Game

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Не пробовал систему переустанавливать? Попробуй на других дистрибутивах или на винде. Не получится, говори.

Оффлайн V@

  • Автор темы
  • Активист
  • *
  • Сообщений: 256
    • Просмотр профиля
Классное решение проблемы, а файлы, учетки, настройки софта?

Оффлайн c47

  • Активист
  • *
  • Сообщений: 356
    • Просмотр профиля
Классное решение проблемы, а файлы, учетки, настройки софта?
так никакой конкретики:
какой диск, куда и как монтируется, fstab или mount, вся система зашифрована или только диск который не монтируется, чем зашифрована, также неясно "а нужно ли шифрование вообще?" - если ответ "чтобы было", то переустановка идеальный вариант. чем меньше незнакомых настроек меняешь, тем больше шанс воскресить систему.

Для сохранения настроек советую при установке вынести в отдельный раздел /home (но только если понимаешь что это, как это, для чего нужно, как в случае проблем реанимировать, и как этим воспользоваться в случае переустановки систему). Если для данной операции нужен мануал - то не советую приступать

Оффлайн V@

  • Автор темы
  • Активист
  • *
  • Сообщений: 256
    • Просмотр профиля
Не знаю, что с этим делать, поэтому и написал. Я даже все файлы не могу перенести для того чтобы переустановить, потому что на системе не хватает места, а на внешней диск не копирует все файлы.

/etc/fstab
(Нажмите, чтобы показать/скрыть)

Оффлайн jurganov

  • Старожил
  • *
  • Сообщений: 1477
    • Просмотр профиля
на системе не хватает места,
думаю это и есть причина

Оффлайн c47

  • Активист
  • *
  • Сообщений: 356
    • Просмотр профиля
/dev/mapper/vgubuntu--mate-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/mmcblk0p2 during installation
UUID=374dbe45-e2a6-4d53-ac9e-dbe266ce1f74 /boot           ext4    defaults        0       2
# /boot/efi was on /dev/mmcblk0p1 during installation
UUID=C4B5-C73A  /boot/efi       vfat    umask=0077      0       1
система установлена криво, в разные разделы вынесены /boot и /boot/efi , да ещё и lvm включен не пойми зачем.
кроме fstab что ещё можешь сказать: сколько физических накопителей в системе, стоит ли Windows, собран ли программный/аппаратный raid, убирал/добавлял ли какие-нибудь накопители при этом, все ли они видны в BIOS/UEFI, можешь ли авторизоваться в системе и залогиниться под рутом sudo bashесли можешь - попробуй загуглить "Volume group not found", там есть ребилд/реконфиг volume-group, может поможет, но я сомневаюсь. Также покажи вывод sudo fdisk -l

Оффлайн andytux

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6990
    • Просмотр профиля
Классное решение проблемы, а файлы, учетки, настройки софта?
Будет наукой. Как унтер-офицерская вдова, которая сама себя высекла.

Оффлайн V@

  • Автор темы
  • Активист
  • *
  • Сообщений: 256
    • Просмотр профиля
c47

Да под рутом заходит. Винды нет. Все разделы создавались самой системой, я ничего не менял. Никаких массивов нет, только один диск внутренний.

sudo fdisk -l
(Нажмите, чтобы показать/скрыть)

Мне бы главное перенести файлы на внешний диск(2TB exfat), а систему я просто переустановлю. Внешний диск новый, но что-то даже не все файлы удаляются, input/error.
« Последнее редактирование: 17 Марта 2022, 14:14:23 от V@ »

Оффлайн c47

  • Активист
  • *
  • Сообщений: 356
    • Просмотр профиля
я вижу как минимум 3 диска,
Disk /dev/mmcblk0: 230,64 GiB, 247631708160 bytes, 483655680 sectors
Disk /dev/sda: 1,93 TiB, 2097152000000 bytes, 4096000000 sectors
Disk /dev/sdb: 235,52 GiB, 252874588160 bytes, 493895680 sectors

причём первый - подозреваю, что китайский ssd, собранный из microsd в массиве (могу ошибаться)
есть возможность загрузиться с liveUSB? скопируй свои файлы, отключи ВСЕ накопители, кроме одного - установи систему, смотри чтоб не стояла галочка "включить LVM", выбери автоматическую разметку
(Нажмите, чтобы показать/скрыть)

 

Страница сгенерирована за 0.058 секунд. Запросов: 26.