Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Не работают AppImages в Ubuntu 14.04  (Прочитано 2231 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн swampy_earl

  • Автор темы
  • Активист
  • *
  • Сообщений: 324
    • Просмотр профиля
Не работают AppImages в Ubuntu 14.04
« : 28 Марта 2022, 03:38:06 »
Привет, ребята!

Дайте совет, пожалуйста. Какие пакеты и библиотеки желательно скачать в систему, чтобы там точно, стопроцентно работали контейнеры AppImages? Короче, как создать идеальную програмную среду для их работы?

(Нажмите, чтобы показать/скрыть)

Оффлайн andytux

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 7048
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #1 : 28 Марта 2022, 05:12:18 »
Цитировать
чтобы там точно, стопроцентно работали контейнеры AppImages?
Все просто. Чтобы работал любой AppImage, в него должна входить вся система.
Установка в основную систему того, что не хватает AppImage, несет риск "поломки системы". В этом плане он ничем не отличается от деб-пакета. Разница только в соотношении того, что в самом deb-AppImage, а что в системе.

Оффлайн jurganov

  • Старожил
  • *
  • Сообщений: 1503
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #2 : 28 Марта 2022, 07:39:13 »
ненавижу уродскую юнити. ей испоганили Ubuntu.
вот уже где ностальгия - по gnome2!!!
и что я теперь, должен на Ubuntu 10.04 сидеть?
ставь современную Ubuntu и на неё уже пробуй ставить свой апп.
скорее всего, на твоем старье нету нужных библиотек

Оффлайн просто Евгений

  • Активист
  • *
  • Сообщений: 411
  • Мы уже идем к вам...
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #3 : 28 Марта 2022, 08:29:05 »
Я тоже из-за юнити не стал больше юзать Ubuntu. Гном нравился. Думаю, что смысла в старой системе нет. Найти приемлемый вариант ОС с нужной DE и поставить актуальную версию. 8)
Поговори, хоть ты со мной, гитара, семиструнная...

Оффлайн Aleksandru

  • Администратор
  • Старожил
  • *
  • Сообщений: 3350
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #4 : 28 Марта 2022, 10:12:16 »
swampy_earl, скорее всего эти Appimage собирались в 16.04. Тут уж ничем не помочь.
А у вас Ubuntu 14.04? Она со всеми обновлениями?
Если нет, попробуйте обновить. Последняя вроде бы была 14.04.7 если я не ошибаюсь.
Intel Core i5-6400, GeForce GT 1030, ASUS ROG Strix B250G Gaming, 16GB RAM, KINGSTON SV300S37A240G, Digma Mega S3 DGSM3512GS33T 512ГБ.

Оффлайн swampy_earl

  • Автор темы
  • Активист
  • *
  • Сообщений: 324
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #5 : 29 Марта 2022, 01:55:37 »
Aleksandru - спасибо за дельный совет! В принципе, у меня есть современный "Линукс". Причём не один - много. А "Ubuntu 14.04" это лишь одна из моих систем. Я люблю её такой, как она есть. Просто хочу понять, почему там не работают "АппИмаджи".

Итак, ребята. Если подытожить. "АппИмаджи" работают далеко не на всех "Линуксах", верно? Заявления о полной всеядности - реклама, не более того.

Видел такое объяснение где-то в сети. Допустим, программист при сборке "АппИмиджа" ошибся. Не включил какую-то библиотеку. И тогда весь контейнер "AppImage" не откроется (на системе, где нет этой самой библиотеки). Может, в этом причина?
« Последнее редактирование: 29 Марта 2022, 02:58:53 от swampy_earl »

Оффлайн jurganov

  • Старожил
  • *
  • Сообщений: 1503
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #6 : 29 Марта 2022, 06:06:48 »
не надо бреда. Никто тебе не обещал, что "всё работает на всех линуксе". Какая нафиг "реклама"?
твоя Ubuntu 14.04 уже давно снята с поддержки. Это МЁРТВАЯ система.
и не мёртвой системе никто не обязан ничего поддерживать.
Современные пакеты не работают с устаревшими библиотеками.
Это всё просто вопиющая безграмотщина

Оффлайн Usermaster

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2715
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #7 : 29 Марта 2022, 08:37:37 »
В ubuntu 14.04 только-только появилась начальная поддержка AppImage, если честно я вообще думал что там её ещё не завезли.
Соответственно она там была ещё сырая.
Поправьте если ошибаюсь.
К тому же у некоторых AppImage в зависимостях встречал Glibc, который в системе должен быть не ниже определённой версии.
Обычно в именах таких пакетов сразу присутствует это пояснение.
Могут быть и другие зависимости.
А чего это вы тут делаете, а?

Оффлайн просто Евгений

  • Активист
  • *
  • Сообщений: 411
  • Мы уже идем к вам...
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #8 : 29 Марта 2022, 11:33:58 »
У меня мята 19.3, 64 бита. Скачал на днях пару Апимидж прог:
1. Ultimaker_Cura-4.13.1.AppImage
2. Repetier-Host-x86_64-2.2.4.AppImage
Вторая запускается отлично, а первая не хочет никак. :idiot2:
Только у меня такая фигня? Чо она нее пашет? Может пакет кривой? :-\
Поговори, хоть ты со мной, гитара, семиструнная...

Оффлайн Aleksandru

  • Администратор
  • Старожил
  • *
  • Сообщений: 3350
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #9 : 29 Марта 2022, 12:06:51 »
Только у меня такая фигня? Чо она нее пашет? Может пакет кривой?
Пашет в Linux Mint 20.3 Cinnamon.
Intel Core i5-6400, GeForce GT 1030, ASUS ROG Strix B250G Gaming, 16GB RAM, KINGSTON SV300S37A240G, Digma Mega S3 DGSM3512GS33T 512ГБ.

Оффлайн Usermaster

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2715
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #10 : 29 Марта 2022, 13:22:24 »
Вторая запускается отлично, а первая не хочет никак.
Запусти из консоли, увидишь что она требует Glibc версии 2.28 а у тебя 2.27.

На appimagehub есть постарше версия, она запустится.

https://www.appimagehub.com/p/1238419
А чего это вы тут делаете, а?

Оффлайн просто Евгений

  • Активист
  • *
  • Сообщений: 411
  • Мы уже идем к вам...
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #11 : 29 Марта 2022, 18:03:15 »
На appimagehub есть постарше версия, она запустится.
Спасибо привеликое! :)
Скачал. Заработало.
Поговори, хоть ты со мной, гитара, семиструнная...

Оффлайн jurganov

  • Старожил
  • *
  • Сообщений: 1503
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #12 : 30 Марта 2022, 08:29:14 »
Запусти из консоли,
так может и топикстартеру запустить из терминала и поглядеть, что надо для запуска?

Оффлайн Usermaster

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2715
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #13 : 30 Марта 2022, 08:52:15 »
Я пробовал на такой же системе и уже пояснил что программа требует наличие Glibc 2.28.
Он увидит то же самое.
А чего это вы тут делаете, а?

Оффлайн swampy_earl

  • Автор темы
  • Активист
  • *
  • Сообщений: 324
    • Просмотр профиля
Re: Не работают AppImages в Ubuntu 14.04
« Ответ #14 : 02 Апреля 2022, 03:11:50 »
Спасибо огромное всем за помощь!  :)

Попробую проапгрейдить эту самую библиотеку Glibc на Ubuntu 14.04.

Да, скорее всего проблема была именно в этом. Большинство "АппИмаджей" собирают на современных системах. И поэтому они не приспособлены к работе на относительно "устаревших".

Кстати, на официальном обсуждении проекта AppImage, вроде бы порицают такую вот "лень" разработчиков. И рекомендуют собирать такие модули на максимально "древней" системе =))

https://discourse.appimage.org/t/specify-required-glibc-version-in-appimage/2413/6

 

Страница сгенерирована за 0.043 секунд. Запросов: 25.