Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: [Решено] WINE требует winedos.dll  (Прочитано 1002 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
[Решено] WINE требует winedos.dll
« : 10 Июль 2008, 23:49:12 »
Добрый день!

Почему-то при установке некоторых программ (а точнее - "Герои 3", "Хроники героев", старый "Diablo" и эпсоновский монитор уровня чернил для "Stylus Photo R300") возникает одна и та же проблема: инсталлятор не запускается, а если попытаться запустить его через эмулятор терминала, то в консоли появляются следующие сообщения об ошибках:
mmm@antosha:~$ cd /media/cdrom
mmm@antosha:/media/cdrom$ wine setup.exe
preloader: Warning: failed to reserve range 00000000-60000000
preloader: Warning: failed to reserve range 00000000-60000000
err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space, please report
preloader: Warning: failed to reserve range 00000000-60000000
preloader: Warning: failed to reserve range 00000000-60000000
err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space, please report
err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space, please report
preloader: Warning: failed to reserve range 00000000-60000000
err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space, please report
err:dosmem:load_winedos Could not load winedos.dll, DOS subsystem unavailable
winevdm: unable to exec '--app-name': 16-bit support missing
mmm@antosha:/media/cdrom$
Не сталкивался ли кто-нибудь с чем-то подобным? Что это за компонент, которого не хватает WINE? Больше всего смущает, что "Герои 3" не устанавливаются. Они же, вроде бы, хорошо относятся к спиртному ;-) да и у меня в своё время вполне себе работали, причём в гораздо более ранней версии WINE... Очень было бы интересно послушать мнение сообщества, скучновато бывает без любимых игрушек ;-)

Использую "Kubuntu 8.04" с последними обновлениями, WINE 0.9.59.

Спасибо

Помогло обновление WINE до версии 1.1.0 с официального сайта, как и советовал tremor. Всех проблем, к сожалению, не решило, но "Герои" заработали, поэтому всё остальное меня уже не удивляет ;-)
« Последнее редактирование: 11 Июль 2008, 20:12:57 от Михаил Минц »

Оффлайн dmay

  • Старожил
  • *
  • Сообщений: 1084
  • man google, кому сказал!
    • Просмотр профиля
Re: WINE требует winedos.dll
« Ответ #1 : 11 Июль 2008, 08:35:04 »
герои3, если что, есть нативные. на пиратбее раздавали.
Ты попал в мою коллекцию криворуких тупых нубов!

Оффлайн tremor

  • Участник
  • *
  • Сообщений: 212
  • Промышляю локальными сетями
    • Просмотр профиля
    • Компьютерные сети в Екатеринбурге
Re: WINE требует winedos.dll
« Ответ #2 : 11 Июль 2008, 08:38:58 »
Да, у меня было такое с разными прогами и разные длл ки требовал вайн. для установки директ икса 2 виндовые дллкитребуются, это все знают. Дак вот все работает нормально когда в каталог system32 или еще куда, кидаешь эти самые дллки, а берешь их тупо в винде. А вот ВАНДОС, название явно не виндовое, значит надо найти пакеты и поставить эту штуку. Возможно просто надо добавить вот эти репозитарии: http://www.winehq.org/site/download-deb. Авообще старый дбябло же досовский, а для доса нужен досбокс, я так варкрафт запускал. Кстати советую стратагус потыкать если интересен варкрафт 2 ))

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Re: [Решено] WINE требует winedos.dll
« Ответ #3 : 11 Июль 2008, 20:16:19 »
Авообще старый дбябло же досовский, а для доса нужен досбокс, я так варкрафт запускал. Кстати советую стратагус потыкать если интересен варкрафт 2 ))
Нет, "Дьявол" - форточная программа, в "DOSBox" не запускается. Инсталлятор сработал после обновления WINE до версии 1.1.0, но сама игра выдаёт только заставку и виснет :-( Придётся ждать следующих обновлений WINE :-)

 

Страница сгенерирована за 0.054 секунд. Запросов: 23.