Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Не могу установить Xmind на Kubuntu  (Прочитано 648 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн wsmiskander

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Не могу установить Xmind на Kubuntu
« : 27 Апреля 2022, 11:47:39 »
Здравствуйте. Три дня в линуксе) нужно установить программу  xmind.
Скачал архив.
запустил консоль
указал sudo /home/paleteosar/Downloads/xmind-8-update9-linux/XMind_amd64/XMind
получил результат

[sudo] password for paleteosar:
[setup] Installing dependencies....
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package libwebkitgtk-1.0-0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libgtk2.0-0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package openjdk-8-jre
E: Package 'libgtk2.0-0' has no installation candidate
E: Package 'libwebkitgtk-1.0-0' has no installation candidate

я так понимаю программа не установилась. Буду благодарен за помощь!
« Последнее редактирование: 27 Апреля 2022, 12:01:01 от Aleksandru »

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6199
    • Просмотр профиля
Re: Не могу установить Xmind на Kubuntu
« Ответ #1 : 27 Апреля 2022, 11:58:13 »
Какая версия дистрибутива? Что за архив и откуда скачали? На оф.сайте есть deb-пакет - его пробовали установить?
https://www.xmind.net/zen/download/linux_deb/

Оффлайн wsmiskander

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Не могу установить Xmind на Kubuntu
« Ответ #2 : 27 Апреля 2022, 13:45:00 »
Версия Kubuntu самая свежая, вчера установил, ЛТС
Указанная Вами ссылка на другую версию программы, она мне не подходит. Исключительно Xmind 8

Скачивал отсюда https://www.xmind.net/download/xmind8/

Какая версия дистрибутива? Что за архив и откуда скачали? На оф.сайте есть deb-пакет - его пробовали установить?
https://www.xmind.net/zen/download/linux_deb/


Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6199
    • Просмотр профиля
Re: Не могу установить Xmind на Kubuntu
« Ответ #3 : 27 Апреля 2022, 13:52:26 »
Версия Kubuntu самая свежая, вчера установил, ЛТС
В 22.04 нет пакета libwebkitgtk-1.0-0 в штатном репозитории. Ставьте 18.04 или пробуйте установить этот пакет руками, если не возникнет проблем с зависимостями.

Оффлайн wsmiskander

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Не могу установить Xmind на Kubuntu
« Ответ #4 : 27 Апреля 2022, 14:01:22 »
подскажите как установить руками?)
И как узнать возникают ли проблемы с зависимостями?
Версия Kubuntu самая свежая, вчера установил, ЛТС
В 22.04 нет пакета libwebkitgtk-1.0-0 в штатном репозитории. Ставьте 18.04 или пробуйте установить этот пакет руками, если не возникнет проблем с зависимостями.

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6199
    • Просмотр профиля
Re: Не могу установить Xmind на Kubuntu
« Ответ #5 : 27 Апреля 2022, 14:13:32 »
wsmiskander, не нужно цитировать предыдущие сообщения.  Для акцента можно вставить фразы, несущие смысловую нагрузку.

Для установки руками качаете пакет из репозитория через браузер, открываете в этом каталоге терминал и выполняетеsudo gdebi файл_пакета.debЕсли возникнут ошибки, APT об этом сообщит.

E: Unable to locate package openjdk-8-jre
E: Package 'libgtk2.0-0' has no installation candidate
Эти пакеты в репозитории есть, но он у вас похоже не подключен. Проверьте в источниках программ.
Перед тем, как что-то делать с системой, прочитайте справку.

Оффлайн wsmiskander

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Не могу установить Xmind на Kubuntu
« Ответ #6 : 27 Апреля 2022, 14:18:08 »
Благодарю. Понял на счет цитирования.

Пользователь добавил сообщение 27 Апреля 2022, 14:22:27:
sudo gdebi libwebkitgtk-1.0-0_2.4.11-3ubuntu3_amd64.deb

sudo: gdebi: command not found
я что-то пропустил?
« Последнее редактирование: 27 Апреля 2022, 14:22:27 от wsmiskander »

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6199
    • Просмотр профиля
Re: Не могу установить Xmind на Kubuntu
« Ответ #7 : 27 Апреля 2022, 14:26:11 »
sudo: gdebi: command not found
Установите пакет:sudo apt install gdebi-core

 

Страница сгенерирована за 0.031 секунд. Запросов: 25.