Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Поднимите мне брови! netplan ... не получается добавить bond интерфейс  (Прочитано 67731 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Elias292

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
Конфиг такой:


root@ubuntu:/etc/netplan# cat 00-installer-config.yaml
(Нажмите, чтобы показать/скрыть)

Пытаюсь применить:
root@ubuntu:/etc/netplan# netplan try --state /etc/netplan
/etc/netplan/00-installer-config.yaml:28:9: Error in network definition: unknown key 'bond0'
        bond0:
        ^

An error occurred: the configuration could not be generated

Вот что за фигня ?

Что-то типа такого должно быть.
« Последнее редактирование: 02 Мая 2022, 16:09:37 от Morisson »

Morisson

  • Гость
Оформите свое сообщение согласно правил форума. В противном случае оно будет удалено.
Спасибо за понимание.

Оффлайн Elias292

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
Оформите свое сообщение согласно правил форума. В противном случае оно будет удалено.
Спасибо за понимание.

Что не так в моем сообщении ?

Morisson

  • Гость
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов
(Нажмите, чтобы показать/скрыть)
или ..., либо прикреплять к сообщению в виде отдельного файла. Длинные гиперссылки следует оформлять при помощи тега ....

https://forum.ubuntu.ru/index.php?action=rules

Оффлайн ALiEN

  • Администратор
  • Старожил
  • *
  • Сообщений: 6829
  • 20% Cooler
    • Просмотр профиля
Вот что за фигня ?
Пробелы в начале строк правильно посчитаны? Для YAML это очень важно.
🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн Elias292

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
В общем...

Конфиг щас такой
(Нажмите, чтобы показать/скрыть)



Когда даю комманду:

root@ubuntu:/etc# netplan try --state /etc/netplan

bond0: reverting custom parameters for bridges and bonds is not supported

Please carefully review the configuration and use 'netplan apply' directly.


Командой netplan apply
все применяется...
Но сервисы почему то вешаются на ipv6

root@ubuntu:/var/log/munin# !netst
netstat -nlp | grep 4949
tcp6       0      0 :::4949                 :::*                    LISTEN      355919/perl

netplan - отстой!

Пользователь добавил сообщение 02 Мая 2022, 17:43:56:
Вот что за фигня ?
Пробелы в начале строк правильно посчитаны? Для YAML это очень важно.

Где б еще узнать как оно "правильно".
« Последнее редактирование: 02 Мая 2022, 17:43:56 от Elias292 »

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1764
    • Просмотр профиля

Оффлайн Elias292

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
Поднимите мне брови!

netplan

Ничего полезного я тут не нашел.
Это заклинания какие-то, без объяснения что и зачем тут написано.

Оффлайн Toshykan

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Поднимите мне брови!

netplan

Ничего полезного я тут не нашел.
Это заклинания какие-то, без объяснения что и зачем тут написано.

В начале - бесило. потом покурил форумы, проверил на на онлайн-чекере. Да, надо внимательно смотреть количество пробелов перед текстом.

 

Страница сгенерирована за 0.057 секунд. Запросов: 25.