Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Не работает микрофон  (Прочитано 3254 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lalafa

  • Автор темы
  • Любитель
  • *
  • Сообщений: 85
    • Просмотр профиля
Не работает микрофон
« : 07 Сентября 2022, 14:01:21 »
pactl list sources

Source #0
        State: IDLE
        Name: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
        Description: Monitor of Built-in Audio Analog Stereo
        Driver: module-alsa-card.c
        Sample Specification: s16le 2ch 44100Hz
        Channel Map: front-left,front-right
        Owner Module: 8
        Mute: no
        Volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
                balance 0,00
        Base Volume: 65536 / 100% / 0,00 dB
        Monitor of Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
        Latency: 0 usec, configured 2000000 usec
        Flags: DECIBEL_VOLUME LATENCY
        Properties:
                device.description = "Monitor of Built-in Audio Analog Stereo"
                device.class = "monitor"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xdf620000 irq 138"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "a171"
                device.product.name = "CM238 HD Audio Controller"
                device.form_factor = "internal"
                device.string = "0"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        Formats:
                pcm

Source #4
        State: RUNNING
        Name: alsa_input.pci-0000_00_1f.3.analog-stereo
        Description: Built-in Audio Analog Stereo
        Driver: module-alsa-card.c
        Sample Specification: s16le 2ch 44100Hz
        Channel Map: front-left,front-right
        Owner Module: 8
        Mute: no
        Volume: front-left: 74056 / 113% / 3,18 dB,   front-right: 74056 / 113% / 3,18 dB
                balance 0,00
        Base Volume: 20724 /  32% / -30,00 dB
        Monitor of Sink: n/a
        Latency: 1567 usec, configured 10000 usec
        Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY
        Properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "ALC898 Analog"
                alsa.id = "ALC898 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xdf620000 irq 138"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "a171"
                device.product.name = "CM238 HD Audio Controller"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        Ports:
                analog-input-internal-mic: Internal Microphone (type: Mic, priority: 8900, availability unknown)
                analog-input-mic: Microphone (type: Mic, priority: 8700, not available)
        Active Port: analog-input-internal-mic
        Formats:
                pcm

в павуконтроле и алсамиксере все включено. Периодически щелкает, но запись не идет.

вот еще что есть

Пользователь добавил сообщение 07 Сентября 2022, 14:09:40:
inxi -Fxz
System:
  Kernel: 5.15.0-43-generic x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: LXQt 0.17.1 Distro: Ubuntu 22.04.1 LTS (Jammy Jellyfish)
Machine:
  Type: Laptop System: Micro-Star product: GE62MVR 7RG v: REV:1.0
    serial: <superuser required>
  Mobo: Micro-Star model: MS-16JC v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends v: E16JCIMS.305 date: 04/19/2017
Battery:
  ID-1: BAT1 charge: 43.4 Wh (98.2%) condition: 44.2/53.4 Wh (82.7%)
    volts: 12.2 min: 10.9 model: MSI Corp. MS-16JC status: N/A
CPU:
  Info: quad core model: Intel Core i7-7700HQ bits: 64 type: MT MCP
    arch: Kaby Lake rev: 9 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 900 min/max: 800/3800 cores: 1: 900 2: 900 3: 900
    4: 900 5: 900 6: 900 7: 900 8: 900 bogomips: 44798
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: i915
    v: kernel bus-ID: 00:02.0
  Device-2: NVIDIA GP104M [GeForce GTX 1070 Mobile] vendor: Micro-Star MSI
    driver: nouveau v: kernel bus-ID: 01:00.0
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: modesetting
    unloaded: fbdev,vesa gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 22.0.5
    direct render: Yes
Audio:
  Device-1: Intel CM238 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3
  Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.15.0-43-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Rivet Networks driver: ath10k_pci v: kernel bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet
    vendor: Micro-Star MSI driver: alx v: kernel port: d000 bus-ID: 03:00.0
  IF: enp3s0 state: down mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb
    v: 0.8 bus-ID: 1-10:4
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter>
    bt-v: 2.1 lmp-v: 4.2
Drives:
  Local Storage: total: 931.51 GiB used: 612.86 GiB (65.8%)
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630
    size: 931.51 GiB
Partition:
  ID-1: / size: 47.76 GiB used: 34.67 GiB (72.6%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 196.9 MiB used: 6 MiB (3.0%) fs: vfat
    dev: /dev/sda1
Swap:
  ID-1: swap-1 type: file size: 512 MiB used: 44.3 MiB (8.7%) file: /swapfile
Sensors:
  System Temperatures: cpu: 56.0 C pch: 63.5 C mobo: 27.8 C gpu: nouveau
    temp: 51.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 266 Uptime: 2h 32m Memory: 15.52 GiB used: 11.53 GiB (74.3%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.0 Packages: 1890 Shell: Bash
  v: 5.1.16 inxi: 3.3.13
« Последнее редактирование: 07 Сентября 2022, 14:09:40 от lalafa »

Оффлайн mahinist

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3907
  • Ubuntu-20.04, Archlinux, Blackarchlinux, Gentoo
    • Просмотр профиля
Re: Не работает микрофон
« Ответ #1 : 07 Сентября 2022, 18:07:53 »
алсамиксере все включено
Выложи скрины после запуска alsamixer, и после нажатия F4 при запущенном alsamixer .
31-регион

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 3046
    • Просмотр профиля
Re: Не работает микрофон
« Ответ #2 : 07 Сентября 2022, 21:03:18 »
А что всё включено? У меня когда-то давно требовалось, чтобы были в alsamixer включены Capture и Booster,
правда, насчёт Booster уже не уверен.
Пётр.

Оффлайн lalafa

  • Автор темы
  • Любитель
  • *
  • Сообщений: 85
    • Просмотр профиля
Re: Не работает микрофон
« Ответ #3 : 09 Сентября 2022, 16:27:51 »
Выложи скрины после запуска alsamixer, и после нажатия F4 при запущенном alsamixer .


Пользователь добавил сообщение 09 Сентября 2022, 16:30:59:
А что всё включено?
вот вроде все включено(((
« Последнее редактирование: 09 Сентября 2022, 16:31:00 от lalafa »

Оффлайн mahinist

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3907
  • Ubuntu-20.04, Archlinux, Blackarchlinux, Gentoo
    • Просмотр профиля
Re: Не работает микрофон
« Ответ #4 : 09 Сентября 2022, 19:13:21 »
lalafa, Если всё включено и выбран нужный профиль, попробуйте активировать колонку Loopback нажав клавишу с англицкой Q, должно быть Enabled, чтобы выключить жми X.
31-регион

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 3046
    • Просмотр профиля
Re: Не работает микрофон
« Ответ #5 : 09 Сентября 2022, 21:07:28 »
mahinist, как мне помнится, нам недавно потребовалось выключить Loopback, потому что мешал.
М.б., в качестве Source надо выбрать микрофон.
« Последнее редактирование: 09 Сентября 2022, 21:11:03 от Peter_I »
Пётр.

Оффлайн mahinist

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3907
  • Ubuntu-20.04, Archlinux, Blackarchlinux, Gentoo
    • Просмотр профиля
Re: Не работает микрофон
« Ответ #6 : 09 Сентября 2022, 21:59:34 »
Source
Для выбора разъёма на передней или задней панели , к примеру у меня без активации Loopback микрофон не работает.
(Нажмите, чтобы показать/скрыть)

« Последнее редактирование: 09 Сентября 2022, 22:09:19 от mahinist »
31-регион

Оффлайн lalafa

  • Автор темы
  • Любитель
  • *
  • Сообщений: 85
    • Просмотр профиля
Re: Не работает микрофон
« Ответ #7 : 28 Сентября 2022, 12:46:09 »
lalafa, Если всё включено и выбран нужный профиль, попробуйте активировать колонку Loopback нажав клавишу с англицкой Q, должно быть Enabled, чтобы выключить жми X.

не помогло((

Пользователь добавил сообщение 28 Сентября 2022, 12:48:43:
короче надоел он мне... купила дешевую камеру с микрофоном и внешняя работает.
« Последнее редактирование: 28 Сентября 2022, 12:48:43 от lalafa »

 

Страница сгенерирована за 0.039 секунд. Запросов: 24.