Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: цифровые адреса пингуются и открываются, а символьные - нет.  (Прочитано 920 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jurganov

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1544
    • Просмотр профиля
сеть настраивал через NetworkManager. Больше нигде ничего не трогал. и не задумывался.
Все работало.
Стали появляться моменты, когда цифровые адреса пингуются и открываются, а символьные - нет.
и вот окончательно.
Ну и браузер открывает страницу по цифровому IP-адресу
На других машинах рядом всё работает, загрзился с диска - всё работает, значит причина не в DNSсерваке, а в системе. Сравнил /etc/resolv.conf с диска и в системе - одинаковые.
Причем у нас две сети. Универовская и ТТК - на обоих интерфейсах одинаково.
Что ещё глядеть? в чем может быть причина??
Не так давно установил protonvpn - грешу на него. Но что он мог поменть?
iptables?
хотя и после sudo iptables -F и перезагрузки без изменений...
apt тоже не работает, если чё ))

Вот параметры


ifconfig
(Нажмите, чтобы показать/скрыть)

/etc/network/interfaces
(Нажмите, чтобы показать/скрыть)


NetworkManager --print-config
(Нажмите, чтобы показать/скрыть)


nmcli -f NAME,DEVICE,FILENAME connection show
(Нажмите, чтобы показать/скрыть)
   

/etc/NetworkManager/system-connections/Проводное соединение 1.nmconnection

(Нажмите, чтобы показать/скрыть)

/etc/NetworkManager/system-connections/ттк.nmconnection
(Нажмите, чтобы показать/скрыть)

/etc/resolv.conf
(Нажмите, чтобы показать/скрыть)


ls /etc/resolvconf/update-libc.d

avahi-daemon

resolvectl status
(Нажмите, чтобы показать/скрыть)

netplan - единственный файл /etc/netplan/01-network-manager-all.yaml...

(Нажмите, чтобы показать/скрыть)



Пользователь добавил сообщение 04 Октября 2022, 10:24:59:
чё то не нравится про 80й порт... или я ошибаюсь?

sudo lsof -i -P
(Нажмите, чтобы показать/скрыть)

ip a
(Нажмите, чтобы показать/скрыть)

 ip r
(Нажмите, чтобы показать/скрыть)

sudo iptables-save
(Нажмите, чтобы показать/скрыть)


« Последнее редактирование: 04 Октября 2022, 10:27:42 от jurganov »

Оффлайн jurganov

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1544
    • Просмотр профиля
Решено внесением в файл
параметров
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
net.ipv6.conf.enp7s0.disable_ipv6 = 1


После применения их через  sudo sysctl -p  все заработало

Проблема была в том, что 80 порт был открыт для tcp6, удалил tcp6 порт стал открыт для 4й версии, то есть для обычной сети

Тему можно закрывать

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5611
  • Все по палатам!
    • Просмотр профиля
jurganov, а в NM ipv6 поставить в disable не получилось?
ЗЫ
У тебя в /etc/NetworkManager/system-connections/Проводное соединение 1.nmconnection
(и в другом):
[ipv6]
....
method=auto
Извините, я все еще учусь

Оффлайн jurganov

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1544
    • Просмотр профиля
после перезагрузки все вернулось.
Отрубил ipv6 в GRUBe. Пока работает

 

Страница сгенерирована за 0.092 секунд. Запросов: 25.