Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Помогите. Пожалуйста помогите с python  (Прочитано 34888 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kanibals

  • Автор темы
  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Добры люди помогите. В linux я не то чтобы новичок, с повседневными задачами справляюсь, но всегда есть но. Есть такая программа m4baker которая устанавливается из командной строки (python setup.py install --optimize=1), однако данная программа создавалась на python 2.7, а моя текущая версия в Linux Mint 21.1 - python 3.2 и вот возникает проблема с установкой. Если указать python3 в аргументах установки то иконки в меню создаются, но приложение не запускается.

Пожалуйста помогите разобраться с данной проблемой

Оффлайн Skif_off

  • Участник
  • *
  • Сообщений: 119
    • Просмотр профиля
Re: Помогите. Пожалуйста помогите с python
« Ответ #1 : 27 Декабря 2022, 21:37:03 »
Отсюда ставите? Оттуда вот так просто не получится, бо Linux Mint 21 строится на основе Ubuntu 22.04: Python2 поставить можно, но в зависимостях ещё PyQt4, а это уже проблема.
Как вариант: установить пакет python2, библиотеки Qt4, а вот PyQt4 придётся вытащить из Ubuntu 18.04 как есть или попробовать пересобрать.
Вероятно, ещё понадобится создать симлинк /usr/bin/python на файл "python2.7".

Посмотрите на GitHub форки, может быть, кто-то портировал на Python3/PyQt5 или собрал AppImage, например.
Или можно попробовать собрать AppImage самостоятельно.

В общем, если нет форков, проще, наверное, найти альтернативу :)

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6123
    • Просмотр профиля
Re: Помогите. Пожалуйста помогите с python
« Ответ #2 : 28 Декабря 2022, 00:47:33 »
моя текущая версия в Linux Mint 21.1

Цитировать
Правила форума
2. На форуме ЗАПРЕЩЕНО
2.17. Обсуждение вопросов, напрямую не связанных с использованием дистрибутивов, входящих в официальное семейство Ubuntu. Другие дистрибутивы GNU/Linux и прочие операционные системы следует обсуждать на иных, специализированных ресурсах. Исключением является раздел "Разговоры обо всем".
Закрыто.

 

Страница сгенерирована за 0.041 секунд. Запросов: 25.