Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Mikrotik+ubuntu=one_love  (Прочитано 38273 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zavglebz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Mikrotik+ubuntu=one_love
« : 07 Февраля 2023, 14:22:35 »
Коллеги всем добрейший денечек из темы понятно что я хочу подружить, но расскажу какую я себе задачу поставил (сам себе руководитель) нужно как для опыта, так и для работы, и так поехали рассказываю:
Имеем mikrotik 7.7 на нем wireguard-server
Имеем linux ubuntu На нем wireguard-client
Соответственно что куда подключается рассказывать смысла нет, тут в основном джедаи :), ну я пока падаван.
Оба оборудования mikrotik и linux ubuntu друг друга видят, пингуются от mikrotik к ubuntu и наоборот.
Вместе с Linux ubuntu (там же куда физически вторнут шнурок) есть локальная сеть (предположим) 192.168.1.0/24 из заданного диапазона машине, под ОС Linux ubuntu выдан ip адрес 192.168.1.120.
Mikrotik в свою очередь выдает Ip адреса из Address list (предположим) 65.65.65.0/24
linux ubuntu сетевая карта одна, повторюсь Ip адрес 192.168.1.120
Задача следующая:
как через машину wireguard-client на Linux ubuntu попасть в сеть 192.168.1.0/24
Ниже скидываю wg0.conf
_______________________________________________________________________________
[Interface]

PrivateKey = bla_bla_bla

Address = 65.65.65.3/32

#PostUp = iptables -A FORWARD -i wg0 -j ACCEPT; iptables -t nat -A POSTROUTING -o enp0s3 -j MASQUERADE

#PostDown = iptables -D FORWARD -i wg0 -j ACCEPT; iptables -t nat -D POSTROUTING -o enp0s3 -j MASQUERADE

ListenPort = 13231

[Peer]

PublicKey = Bla_bla_bla

Endpoint = ip_внешний:13231

AllowedIPs =  65.65.65.0/24, 192.168.1.0/24
__________________________________________________
Простите если что-то забыл, но посыл понятен, если на пальцах: Хочу что бы машина Linux ubuntu wireguard которая подключилась к моему Mikrotik wireguard-server, дала доступ к сети 192.168.1.0/24
« Последнее редактирование: 07 Февраля 2023, 16:57:03 от ALiEN175 »
Тело в стадии строительства....

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1764
    • Просмотр профиля
Re: Mikrotik+ubuntu=one_love
« Ответ #1 : 07 Февраля 2023, 19:22:08 »
wireguard-client:
# /etc/sysctl.conf
net.ipv4.ip_forward = 1

wireguard-server:
/ip route
add dst-address=192.168.1.0/24 gateway=65.65.65.3

Оффлайн zavglebz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Mikrotik+ubuntu=one_love
« Ответ #2 : 08 Февраля 2023, 08:57:12 »
# /etc/sysctl.conf
net.ipv4.ip_forward = 1
wireguard-client:
Код: [Выделить]
# /etc/sysctl.conf
net.ipv4.ip_forward = 1

wireguard-server:
Код: [Выделить]
/ip route
add dst-address=192.168.1.0/24 gateway=65.65.65.3

Я не совсем "с бронепоезда", это сделал в первую очередь
« Последнее редактирование: 08 Февраля 2023, 18:23:27 от Onlininer »
Тело в стадии строительства....

Оффлайн articc

  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Mikrotik+ubuntu=one_love
« Ответ #3 : 10 Февраля 2023, 17:50:52 »
А почему маскарад закоминчен?
Причем маскарадить нужно в обе стороны.
Если хотите форвард, то на роутерере в локалке нужен маршрут до сети wg через сервер.
« Последнее редактирование: 10 Февраля 2023, 18:00:29 от articc »

 

Страница сгенерирована за 0.047 секунд. Запросов: 25.