Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Сломанные пакеты при установке build-essential на Lubuntu 16.04  (Прочитано 23369 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн baron_P

  • Автор темы
  • Новичок
  • *
  • Сообщений: 36
  • We do what we must because we can
    • Просмотр профиля
Доброго дня.
На старом нетбуке спокойно доживает свой век Lubuntu 16.04. Понадобилось установить утилиту из исходников, для чего и попробовал установить пакет build-essential. Система выдала вот такое:
$ sudo apt install build-essential
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 build-essential : Зависит: gcc (>= 4:5.2) но он не будет установлен
                   Зависит: g++ (>= 4:5.2) но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
Репозитории стоят такие:
$ grep -rvE '^(#|$)' /etc/apt/sources.list{,.d}
/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ xenial main restricted
/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ xenial universe
/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ xenial multiverse
/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu xenial partner
Эти команды поблемы не решают, выводят сообщения, что в системе все ок:
sudo apt update --fix-missing
sudo apt install -f
sudo apt clean
sudo apt autoremove
sudo dpkg --configure -a
Подскажите, пожалуйста, что можно с этим сделать?
OS: Ubuntu Mate 20.04, Lubuntu 16.04

Оффлайн andytux

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6901
    • Просмотр профиля
"...каждый год 31 декабря мы с друзьями ходим в баню. Это у нас такая традиция."

Так ты уже не первый раз буилдишь с таким успехом...
Сколько еще раз тебе подсказывать. А вообще, про "сломанные пакеты" исписана добрая половина форума.

Оффлайн Onlininer

  • Активист
  • *
  • Сообщений: 875
    • Просмотр профиля
baron_P, Возможно Вам поможет, т.к у меня Ubuntu 16.04 и всё работает. Ниже я скину свой вывод, понятно, что репы телеграмма может Вам и не надо.
(Нажмите, чтобы показать/скрыть)

И, в дополнение система подписана на обновления ESM и PRO (если будете делать подписку, то, там пожалуйста зарегистрируйтесь со своим Сanonical ID)
« Последнее редактирование: 23 Февраля 2023, 18:12:37 от Onlininer »
"Никогда такого не было... и вот -опять!"

Оффлайн baron_P

  • Автор темы
  • Новичок
  • *
  • Сообщений: 36
  • We do what we must because we can
    • Просмотр профиля
"...каждый год 31 декабря мы с друзьями ходим в баню. Это у нас такая традиция."

Так ты уже не первый раз буилдишь с таким успехом...
Сколько еще раз тебе подсказывать. А вообще, про "сломанные пакеты" исписана добрая половина форума.
Честно говоря, я уже забыть успел про прошлый поход в баню ;D
Но там проблема выглядела совсем по другому - хотел странного, оттого и получил проблем. А вот как умудрился поломаться build-essential, с которым у меня никогда проблем не было, мне совсем непонятно. Конфликтов нет, пакет этот вообще не установлен.

baron_P, Возможно Вам поможет, т.к у меня Ubuntu 16.04 и всё работает. Ниже я скину свой вывод, понятно, что репы телеграмма может Вам и не надо.
Спасибо, мне хватило первых пяти строчек ваших реп для решения проблемы.
« Последнее редактирование: 24 Февраля 2023, 10:38:30 от baron_P »
OS: Ubuntu Mate 20.04, Lubuntu 16.04

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6164
    • Просмотр профиля
мне хватило первых пяти строчек ваших реп для решения проблемы.
У вас не был подключен репозиторий security.

Оффлайн baron_P

  • Автор темы
  • Новичок
  • *
  • Сообщений: 36
  • We do what we must because we can
    • Просмотр профиля
У вас не был подключен репозиторий security.
Да, наверно в том и было дело, но теперь уж проверять мне лень. Пакет установился и том спасибо 8)
OS: Ubuntu Mate 20.04, Lubuntu 16.04

 

Страница сгенерирована за 0.062 секунд. Запросов: 25.