Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Проблемы с установкой ПО из исходников  (Прочитано 686 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн staccato

  • Автор темы
  • Любитель
  • *
  • Сообщений: 65
  • ♪+♪=♫
    • Просмотр профиля
Всем привет. Помогите, пожалуйста, с моей проблемой. Не могу установить ПО из исходников. :( Все делаю по инструкции из README. Захожу в директорию, запускаю ./configure происходят некоторые ошибки.

configure: error:
** Couldn't find a GIMP-2.0 installation. If you want to skip this check and
** install the help files to the configured prefix, use the --without-gimp
** configure option. Note that GIMP will then only find the help files if it
** is installed in the same prefix. See the file 'INSTALL' for more help.

пишу make. На что мне ответ:
make: *** Не заданы цели и не найден make-файл.  Останов.
далее sudo make install]
make: *** Нет правила для сборки цели `install'.  Останов.
Вот такая вот фигня...
Ubuntu 9.04 x64
Windows 7 x64

Оффлайн Otetz

  • Активист
  • *
  • Сообщений: 455
    • Просмотр профиля
Re: Проблемы с установкой ПО из исходников
« Ответ #1 : 17 Июль 2008, 19:53:39 »
А что за программу собираешь? Наверное, она Gimp требует. Поставь его sudo apt-get install gimp. Или сделай, как он просит:

./configure --without-gimp
Anything, that MAY go wrong, WILL go wrong...

Оффлайн staccato

  • Автор темы
  • Любитель
  • *
  • Сообщений: 65
  • ♪+♪=♫
    • Просмотр профиля
Re: Проблемы с установкой ПО из исходников
« Ответ #2 : 17 Июль 2008, 20:01:06 »
немного прошло, а на make ответ:
Making all in quickreference
make[1]: Вход в каталог `/home/dan/Packages/gimp-help-2.4.1/quickreference'
/bin/mkdir -p xml
/usr/bin/xml2po -p po/de.po ./gimp-keys.xml > xml/gimp-keys-de.xml
sh: msgfmt: not found
make[1]: *** [xml/gimp-keys-de.xml] Ошибка 7
make[1]: *** Удаляется файл `xml/gimp-keys-de.xml'
make[1]: Выход из каталога `/home/dan/Packages/gimp-help-2.4.1/quickreference'
make: *** [all-recursive] Ошибка 1
на sudo make install выдает:
Making all in quickreference
make[1]: Вход в каталог `/home/dan/Packages/gimp-help-2.4.1/quickreference'
/bin/mkdir -p xml
/usr/bin/xml2po -p po/de.po ./gimp-keys.xml > xml/gimp-keys-de.xml
sh: msgfmt: not found
make[1]: *** [xml/gimp-keys-de.xml] Ошибка 7
make[1]: *** Удаляется файл `xml/gimp-keys-de.xml'
make[1]: Выход из каталога `/home/dan/Packages/gimp-help-2.4.1/quickreference'
make: *** [all-recursive] Ошибка 1
Ubuntu 9.04 x64
Windows 7 x64

Оффлайн staccato

  • Автор темы
  • Любитель
  • *
  • Сообщений: 65
  • ♪+♪=♫
    • Просмотр профиля
Re: Проблемы с установкой ПО из исходников
« Ответ #3 : 17 Июль 2008, 20:01:52 »
А Gimp стоит уже
Ubuntu 9.04 x64
Windows 7 x64

Оффлайн staccato

  • Автор темы
  • Любитель
  • *
  • Сообщений: 65
  • ♪+♪=♫
    • Просмотр профиля
Re: Проблемы с установкой ПО из исходников
« Ответ #4 : 17 Июль 2008, 20:05:48 »
Дело в том что проблема не только этой прогой, а с установкой из исходников вцелом. Эту прогу использую как пример.
Ubuntu 9.04 x64
Windows 7 x64

Оффлайн gantellus

  • Старожил
  • *
  • Сообщений: 1276
    • Просмотр профиля
Re: Проблемы с установкой ПО из исходников
« Ответ #5 : 17 Июль 2008, 20:13:57 »
что ставишь-то?
кстати, если ./configure выдает ошибки, то выполнять дальнейшие команды бессмыссленно

проги нету в репах? зачем из исходников?

Цитировать
See the file 'INSTALL' for more help
смотрел? может там какие зависимости есть
« Последнее редактирование: 17 Июль 2008, 20:15:57 от gantellus »
Придумайте ещё более дружественный интерфейс, и мир породит ещё более тупого юзера (с)
С2Duo 2.4 Ghz, Geforce 8800, Maya 44 PCI

Оффлайн Otetz

  • Активист
  • *
  • Сообщений: 455
    • Просмотр профиля
Re: Проблемы с установкой ПО из исходников
« Ответ #6 : 17 Июль 2008, 20:39:30 »
Может быть, попробуй перед сборкой делать sudo -i а потом всё пиши без sudo. Может, прав не хватает. Хз его... А с sudo -i ты как бы получаешь root консоль.
И да, всё- таки скажи, что пытаешься собрать :)
Anything, that MAY go wrong, WILL go wrong...

Оффлайн staccato

  • Автор темы
  • Любитель
  • *
  • Сообщений: 65
  • ♪+♪=♫
    • Просмотр профиля
Re: Проблемы с установкой ПО из исходников
« Ответ #7 : 21 Июль 2008, 12:31:52 »
Собрать я пытаюсь Хелпер для гимпа с всплывающими подсказками, если в процессе работы возникает вопрос, вбиваешь чё нада, и он тебе в ответ чё нада сделать. Раньше нормально ставилась на ubuntu 8.04, поставил себе Linux-Mint и нихера тепереча не работает.:(
Ubuntu 9.04 x64
Windows 7 x64

Оффлайн staccato

  • Автор темы
  • Любитель
  • *
  • Сообщений: 65
  • ♪+♪=♫
    • Просмотр профиля
Re: Проблемы с установкой ПО из исходников
« Ответ #8 : 21 Июль 2008, 12:37:30 »
Переставлю обратно Ubuntu может заработает:)
Ubuntu 9.04 x64
Windows 7 x64

 

Страница сгенерирована за 0.059 секунд. Запросов: 22.