Форум русскоязычного сообщества Ubuntu


Автор Тема: Как включить английский из терминала  (Прочитано 2180 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дмитрий Бо

  • Автор темы
  • Погонщик серверов
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3539
  • Я не техподдержка, я за порядком слежу
    • Просмотр профиля
    • LinkedIn
В результате каких-то махинаций с настройками клавиатуры в качестве основного установился русский язык. Тот факт, что английский отключился вообще, был замечен после перезагрузки при вводе логина. Один русский, выбор языка из списка "Язык" не помогает.
Соответственно, в систему войти не могу, только команднас строка. Как из командной строки обратно включить английский?
Ситуация прямо по Ильфу и Петрову, но невесоло чего-то.  :(
Не опускай рук, а то пропустишь в бороду

Оффлайн afon

  • Старожил
  • *
  • Сообщений: 1110
  • Drink Different!
    • Просмотр профиля
Re: Как включить английский из терминала
« Ответ #1 : 12 Июль 2006, 18:19:47 »
А в командной строке английский хоть?

Короче нашел такой файлик
.gconf/desktop/gnome/peripherals/keyboard/kbd.sysbackup/%gconf.xml

Цитировать
<?xml version="1.0"?>
<gconf>
        <entry name="options" mtime="1152699644" type="list" ltype="string">
                <li type="string">
                        <stringvalue>grp        grp:rwin_toggle</stringvalue>
                </li>
        </entry>
        <entry name="model" mtime="1152699644" type="string">
                <stringvalue>pc105</stringvalue>
        </entry>
        <entry name="layouts" mtime="1152699644" type="list" ltype="string">
                <li type="string">
                        <stringvalue>us</stringvalue>
                </li>
                <li type="string">
                        <stringvalue>ru winkeys</stringvalue>
                </li>
        </entry>
</gconf>

Веростно у тебс немного другой, и дефолтовый язык - русский, и переключалка клавы свно не на rwin (как у менс). Ну, мне так какжется. Попрпобуй его поменсть.
Drink Different, Understand Computer.
Bye.

Оффлайн Not eXist

  • Активист
  • *
  • Сообщений: 916
    • Просмотр профиля
Re: Как включить английский из терминала
« Ответ #2 : 28 Декабрь 2007, 13:57:41 »
анологичная проблема..Подскажите,что делать??

Оффлайн shms

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Как включить английский из терминала
« Ответ #3 : 30 Декабрь 2007, 14:32:04 »
the same

ставил - ставил, последнее вроде было активация nvidia glx, перезагрузился и в окне инициализации пропал английский.
Что делать - не могу войти в систему.

Оффлайн Densakh

  • Участник
  • *
  • Сообщений: 125
    • Просмотр профиля
Re: Как включить английский из терминала
« Ответ #4 : 31 Декабрь 2007, 04:10:23 »
В результате каких-то махинаций с настройками клавиатуры в качестве основного установился русский язык. Тот факт, что английский отключился вообще, был замечен после перезагрузки при вводе логина. Один русский, выбор языка из списка "Язык" не помогает.
Соответственно, в систему войти не могу, только команднас строка. Как из командной строки обратно включить английский?
Ситуация прямо по Ильфу и Петрову, но невесоло чего-то.  :(
Мне кажется - редактируй xorg.conf.
Загрузись с LiveCD и редактируй.
Можно попробовать удалить вообще этот файл или переименовать, а после - переконфигурить.
Подобные приколы встречал - при установленном крыжике "Использовать индивидуальные настройки языка для окон".
Может я и не прав - но что знаю, то и советую..
Ubuntu 8.04, Win Vista.

Оффлайн chain

  • Старожил
  • *
  • Сообщений: 1263
    • Просмотр профиля
Re: Как включить английский из терминала
« Ответ #5 : 31 Декабрь 2007, 10:47:28 »
Densakh прав, проблема в /etc/X11/xorg.conf
залогинься в терминале, поставь mc, если не стоит, чтобы проще было и посмотри, что у тебя в конфиге хорга в настройках клавиатуры, должно быть что-то в этом роде
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us,ru"
   Option      "XkbVariant"   ",winkeys"
   Option      "XkbOptions"   "grp:alt_shift_toggle,grp_led:scroll"
EndSection

это мой вариант с дефолтной латиницей, вторым языком ввода русским, переключением ввода по alt+shift и индикацией смены раскладки в scrollLock
-вечный чайник-

Оффлайн Teiti

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Как включить английский из терминала
« Ответ #6 : 30 Январь 2008, 13:08:31 »
Такая же проблема возникла буквально только что:
Установил Nvidia-glx, после перезагрузки пропала возможность переключаться и русский стал по умолчанию.
Перегрузился в режиме восстановления (когда grub грузится нажал Esc и выбрал вторую строчку)
Залогинился и сделал следующие вещи:

sudo nano /etc/X11/xorg.conf
Область : буквально десятая строчка от начала

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us,ru" (стоит "ru")
   Option      "XkbVariant"   ",winkeys" (нет строчки)
   Option      "XkbOptions"   "grp:alt_shift_toggle,grp_led:scroll" (нет строчки)
EndSection
Ctrl+O Enter
Ctrl+X
sudo su
reboot

Очевидно конфиг у GLX какой то странный.
Но проблема решается так просто.

Оффлайн shOOrOOp-ss

  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Как включить английский из терминала
« Ответ #7 : 19 Февраль 2008, 23:13:06 »
Аналогичная проблема. Только ко всему ещё в консоле некоторые руские буквы неправельно отображаються гдето 30% алфавита, только вот карточка встроеная и помойму не ДжиФорс. Кстате ситуация очень непонравилась, так как обьяснить немогу, перезагрузился и на тебе такая засада

Оффлайн Roman-GA

  • Участник
  • *
  • Сообщений: 102
  • Новичёк!
    • Просмотр профиля
Re: Как включить английский из терминала
« Ответ #8 : 28 Февраль 2008, 04:04:59 »
Такая же проблема возникла буквально только что:
Установил Nvidia-glx, после перезагрузки пропала возможность переключаться и русский стал по умолчанию.
Перегрузился в режиме восстановления (когда grub грузится нажал Esc и выбрал вторую строчку)
Залогинился и сделал следующие вещи:

sudo nano /etc/X11/xorg.conf
Область : буквально десятая строчка от начала

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us,ru" (стоит "ru")
   Option      "XkbVariant"   ",winkeys" (нет строчки)
   Option      "XkbOptions"   "grp:alt_shift_toggle,grp_led:scroll" (нет строчки)
EndSection
Ctrl+O Enter
Ctrl+X
sudo su
reboot

Очевидно конфиг у GLX какой то странный.
Но проблема решается так просто.
Хм, залез я в данную настройку. Почти все было как ты указал - то есть править ни чего не пришлось. Указаны были два языка - английский и русский. Хотя я устанавливал немецкий и русский.

При попытке войти в системы обычным путем - опять только русская раскладка клавиатуры.

Попробовал в консоле удалить русский и оставить только английский - без изменений - при попытке войти только русские буквы.

Что это может быть и как войти в систему?
Проблема НЕПОНИМАНИЯ заключается не в НЕПОНИМАНИИ, а в ОТСУТСТВИИ СМЫСЛА!

Оффлайн Дмитрий Бо

  • Автор темы
  • Погонщик серверов
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3539
  • Я не техподдержка, я за порядком слежу
    • Просмотр профиля
    • LinkedIn
Re: Как включить английский из терминала
« Ответ #9 : 28 Февраль 2008, 12:14:05 »
Это настройки иксов, они на Gnome не влияют. Было такое кроме меня ещё с одним моим знакомым, он с русским паролем в гном не мог залогиниться, а в иксы - нормально.
Посмотри второй пост, там про gconf.xml.
Не опускай рук, а то пропустишь в бороду

Оффлайн hims

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Как включить английский из терминала
« Ответ #10 : 15 Май 2008, 22:52:18 »
Сегодня получил тоже "русский расклад" пытаясь настроить в убунте параллельный вывод на два монитора.Войти без буржуйского не могу и всё.... :2funny:Порыл гугл-попал сюда-почитал и после загрузки,в режиме восстановления(2-я строка после ESC),взял да и глянул а чё там ещё в /etc/X11/ лежит...;-)Ну а там кроме xorg.conf были xorg.conf.1/2/3.Взял я из этих "с цифрами" тот,что раньше по времени и заменил им xorg.conf и порядок 8)!Думаю эти "цифровые"создаются автоматом при сбое ОС.Если вы ставили Midnight Commander то вообще всё просто через (sudo mc)ну а без него через старые добрые cd и dir.ВСЕМ УДАЧИ!

 

Страница сгенерирована за 0.059 секунд. Запросов: 23.