Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: apt-get upgrade и security updates  (Прочитано 1329 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zeroed

  • Автор темы
  • Активист
  • *
  • Сообщений: 264
    • Просмотр профиля
apt-get upgrade и security updates
« : 23 Август 2008, 17:18:45 »
Обновил список репозиториев, запустил apt-get update && apt-get upgrade, все обновилось.

Но!

В трее остался висеть менеджер апдейтов, который предлагал обновить 5 пакетов (security updates). Как я не пытался установить их с помощью команды выше - ничего не вышло. Установил через гую.

Почему?

Оффлайн Stiff

  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Re: apt-get upgrade и security updates
« Ответ #1 : 23 Август 2008, 17:45:34 »
попробуйте apt-get dist-upgrade

Оффлайн zeroed

  • Автор темы
  • Активист
  • *
  • Сообщений: 264
    • Просмотр профиля
Re: apt-get upgrade и security updates
« Ответ #2 : 23 Август 2008, 17:46:53 »
попробуйте apt-get dist-upgrade

я думал это обновление вида 7.10 - 8.04...

я ошибался? :)

негде уже пробовать, обновился.

Оффлайн Stiff

  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Re: apt-get upgrade и security updates
« Ответ #3 : 24 Август 2008, 01:15:49 »
Есди не менять sources.list, то dist-upgrade не обновит к примеру версию 7.10 до 8.04.
к примеру, на моём компьютере эти команды скачивают немного разные пакеты:
# apt-get upgrade
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
Пакеты, которые будут оставлены в неизменном виде:
  linux-image-server linux-server ntfs-3g openssh-client openssh-server ssl-cert
Пакеты, которые будут обновлены:
  bind9-host dnsutils libapache2-mod-php5 libbind9-30 libdns32 libgnutls13 libisc32 libisccc30 libisccfg30 liblwres30 libpcre3 libpq5 libssl-dev libssl0.9.8
  linux-libc-dev linux-ubuntu-modules-2.6.22-14-server openssl php5 php5-common php5-mysql python2.5 python2.5-minimal samba samba-common tzdata
обновлено 25, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 6 пакетов не обновлено.
Необходимо скачать 25,3MБ архивов.
После распаковки объем занятого дискового пространства возрастёт на 147kB.
Хотите продолжить [Д/н]? n
Аварийное завершение.
# apt-get dist-upgrade
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
Расчёт обновлений... Готово
НОВЫЕ пакеты, которые будут установлены:
  libntfs-3g16 linux-image-2.6.22-15-server linux-ubuntu-modules-2.6.22-15-server openssh-blacklist openssl-blacklist
Пакеты, которые будут обновлены:
  bind9-host dnsutils libapache2-mod-php5 libbind9-30 libdns32 libgnutls13 libisc32 libisccc30 libisccfg30 liblwres30 libpcre3 libpq5 libssl-dev libssl0.9.8
  linux-image-server linux-libc-dev linux-server linux-ubuntu-modules-2.6.22-14-server ntfs-3g openssh-client openssh-server openssl php5 php5-common
  php5-mysql python2.5 python2.5-minimal samba samba-common ssl-cert tzdata
обновлено 31, установлено 5 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 56,4MB/56,6MB архивов.
После распаковки объем занятого дискового пространства возрастёт на 91,1MB.
Хотите продолжить [Д/н]?

 

Страница сгенерирована за 0.139 секунд. Запросов: 22.