Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Дрова под версию ядра 2.6.24-16 возможно заюзать на последнем ядре?  (Прочитано 646 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Cisco 100%

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Скачал дрова на сетевуху, при установке говорит требуются пакеты linux-modules-2.6.24-16. Пересобрал пакет дров, убрав строчку зависимостей из control. Попытался запустить через modprobe - сказало что неверный формат модуля .ko
Можно ли заставить работать дрова на последней версии ядра(-19 вроде) не имея при этом исходников?

Оффлайн Otetz

  • Активист
  • *
  • Сообщений: 455
    • Просмотр профиля
Нет. Более того, скажу, что это очень чувствительный момент. Очень важно собирать драйвер не только по исходникам текущего ядра. Но даже конфигурация исходников ядра не должна отличаться от конфигурации запущенного. Должны совпадать не только версии ядер и их конфигурация. Даже, если ядро компиллировалось одной версией gcc а драйвер компилился другой версией- тоже работать не будет. В общем, совпадать должно всё абсолютно.

Если только производитель драйвера предвидел такую возможность и что-то сделал. Что за драйвер? Какая железка? Где скачивал? :)
« Последнее редактирование: 22 Сентябрь 2008, 21:05:34 от Otetz »
Anything, that MAY go wrong, WILL go wrong...

Оффлайн Cisco 100%

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Нет. Более того, скажу, что это очень чувствительный момент. Очень важно собирать драйвер не только по исходникам текущего ядра. Но даже конфигурация исходников ядра не должна отличаться от конфигурации запущенного. Должны совпадать не только версии ядер и их конфигурация. Даже, если ядро компиллировалось одной версией gcc а драйвер компилился другой версией- тоже работать не будет. В общем, совпадать должно всё абсолютно.

Если только производитель драйвера предвидел такую возможность и что-то сделал. Что за драйвер? Какая железка? Где скачивал? :)
Дрова на вафлЮ wibrain, скачано с офф.сайта производителя..

Оффлайн Cisco 100%

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
А реально както скачать дистриб убунты именно с этой версией ядра?

Оффлайн Otetz

  • Активист
  • *
  • Сообщений: 455
    • Просмотр профиля
Глянь тут:

http://code.google.com/p/wibrain-b1l/downloads/list

Насколько я понял, желаемый дистр- Ubuntu 8.04 с дефолтным ядром.
« Последнее редактирование: 23 Сентябрь 2008, 01:20:24 от Otetz »
Anything, that MAY go wrong, WILL go wrong...

Оффлайн Cisco 100%

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Насколько я понял, желаемый дистр- Ubuntu 8.04 с дефолтным ядром.
А где достать такой дистриб с дефолтным ядром?

 

Страница сгенерирована за 0.084 секунд. Запросов: 22.