Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Проблема с приемом факса.  (Прочитано 1802 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн wishmaster2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Проблема с приемом факса.
« : 02 Октябрь 2008, 12:36:48 »
Установил модем  U.S. Robotics 56K FAX EXT Rev. 11.16.39U.S. Robotics 56K для приема/отправки факса, использую для этого efax. Однако даже при незапущеном efax сразу после первого гудка модем "снимает трубку" и начинает соединяться. Если запускаю efax и включаю автоприем (после 5 гудков) - все нормально, отвечает когда нужно.

Подскажите пожалуйста, кто знает, какая прога "снимает трубку" и как это отключить, ибо мне нужно сделать прием факса только по команде пользователя.

Спасибо.

Edit:

Прошу прощения: система Ubuntu 8.0.4 "из коробки".
« Последнее редактирование: 04 Октябрь 2008, 16:51:23 от wishmaster2 »

Оффлайн yuristep

  • Участник
  • *
  • Сообщений: 248
    • Просмотр профиля
Re: Отключить автоответ у модема
« Ответ #1 : 02 Октябрь 2008, 15:12:07 »
Есть такое старое-старое словосочетание AT-команды модема ...
Осторожно! - Злой админ!

Оффлайн wishmaster2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Отключить автоответ у модема
« Ответ #2 : 02 Октябрь 2008, 16:47:06 »
Есть такое старое-старое словосочетание AT-команды модема ...
это не новость. Если бы я знал что и куда писать - не задавал бы вопрос. Подскажите пожалуйста, в какой конфиг что вписать.

Оффлайн wishmaster2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Отключить автоответ у модема
« Ответ #3 : 02 Октябрь 2008, 17:20:00 »
В гипер терминале запиши в модем:

1.  ATS0=0
2. AT+W0

Все, если снова нужен будет автоответ: ATS0=1 (1 - количество гудков до поднятия трубки)
Не припомню гипертерминала в убунте, тем более, efax это значение перебивает, а юзвери каждый раз не станут чем-то подобным занимацо. Нужно надежное решение из разряда "сделал и забыл"

Оффлайн yuristep

  • Участник
  • *
  • Сообщений: 248
    • Просмотр профиля
Re: Отключить автоответ у модема
« Ответ #4 : 02 Октябрь 2008, 23:11:38 »
... efax это значение перебивает...Нужно надежное решение из разряда "сделал и забыл" ...
а строки инициализации зачем придуманы ?
Осторожно! - Злой админ!

Оффлайн wishmaster2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Отключить автоответ у модема
« Ответ #5 : 03 Октябрь 2008, 00:12:28 »

Прошу прощения: система Ubuntu 8.0.4 "из коробки".

Раз система из коробки, значит проблема в винде... Отсюда и hyper terminal. :-)
Неужели я просил кого-то угадать с какой ОС у меня проблемы?!

... efax это значение перебивает...Нужно надежное решение из разряда "сделал и забыл" ...
а строки инициализации зачем придуманы ?

Строки инициализации конечно хорошо, но МНЕ НУЖНО, ЧТОБЫ МОДЕМ МОЛЧАЛ И ТОГДА, КОГДА EFAX НЕ ЗАПУЩЕН!. Имхо внятно объясню. Строку инициализации редактировать пробовал - добавлял &ATS0=0 в конец - ничего не изменилось.

Так же, как и нет изменений после
echo "Z  &ATS0=0  &AT+W0" > /dev/ttyS0
Модем продолжает снимать трубку после первого гудка.

Оффлайн yuristep

  • Участник
  • *
  • Сообщений: 248
    • Просмотр профиля
Re: Отключить автоответ у модема
« Ответ #6 : 03 Октябрь 2008, 03:28:19 »
мда.... клиника!
1 - ставим пакет Minicom
2 - подключаемся с его помощью к модему
3 - даем последовательность команд:
          ATZ
          ATS=0
4 - не выходя! из  Minicom звоним на модем.

... поднимает трубку? - думаю что "нет",  Записываем это в качестве профиля по умолчанию. РОЕМ СТРОКИ ИНИЦИАЛИЗАЦИИ модема в efax, одна должна отвечать за инициализацию модема при запуске, вторая за инициализацию/сброс при выходе. Добавляем в них S=0
... поднимает трубку? - "да" - выбрасываем на... !   модем - не совместим с Heys-стандартом, нам такой не нужен...

Осторожно! - Злой админ!

Оффлайн wishmaster2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Отключить автоответ у модема
« Ответ #7 : 03 Октябрь 2008, 09:24:07 »
yuristep

Спасибо! Нечто подобное я и хотел услышать! Буду пробовать. =)

ЗЫ.: В настройках efax-gtk  я нашел лишь одну строку инициализации :( Поищу конфиг.....


Оффлайн wishmaster2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Отключить автоответ у модема
« Ответ #8 : 03 Октябрь 2008, 15:11:22 »
yuristep, спасибо огромное, заработало!

Теперь новая проблема другого характера:

При попытке принять факс видим следующее:

Сокет запущен на порту 9900
efax-0.9a: 14:54:39 открыли /dev/ttyS0
efax-0.9a: 14:54:42 используйте U.S. Robotics 56K FAX EXT Rev. 11.16.39U.S. Robotics 56K FAXOKOK in класс 2.0
efax-0.9a: 14:54:42 Внимание: неожиданный ответ "RING"
efax-0.9a: 14:55:00 fax call answered
efax-0.9a: 14:55:48 Внимание: 864 ошибки приёма
efax-0.9a: 14:56:04 Ошибка: таймаут после ожидания
efax-0.9a: 14:55:00 remote ID -> " ++++++++++++       "
efax-0.9a: 14:55:00 session  98lpi  9600bps 8.5"/215mm  any   1D    -     -  20ms
efax-0.9a: 14:55:48 принято 864 строк с 864 ошибками
efax-0.9a: 14:56:05 завершили - Модем не отвечает

При этом на отправляющей стороне факс клянется, что все ОК, хотя страница проходит не до конца - часть остается в аппарате, а должна падать на стол (так и происходит обычно).

Отправляется факс с компа без проблем в высоком разрешении.... %)

Оффлайн wishmaster2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Отключить автоответ у модема
« Ответ #9 : 04 Октябрь 2008, 16:50:22 »
Up!

Попробовал отправить с другого факса - тот сознался, что была ошибка при передаче... ничего не понимаю....

Оффлайн wishmaster2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Проблема с приемом факса.
« Ответ #10 : 07 Октябрь 2008, 18:12:00 »
Ап! Тема актуальна!

Оффлайн chmx

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Проблема с приемом факса.
« Ответ #11 : 29 Октябрь 2008, 13:53:21 »
У меня zyxel omni 56k smart. Факс принимает нормально, но на передающем пишет "ошибка передачи". строка инициализации по умолчанию. пишет вот что:

efax-0.9a: 12:16:31 открыли /dev/ttyS0
efax-0.9a: 12:16:32 используйте ZyXEL V.90 ROMV1.08ZyDASZD1061ROMV1.08 in класс 2.0
efax-0.9a: 12:16:32 Внимание: неверный ответ после команды: +FIP
efax-0.9a: 12:16:33 ожидание активности
efax-0.9a: 12:16:54 активность обнаружена
efax-0.9a: 12:17:10 fax call answered
efax-0.9a: 12:19:06 Внимание: ошибки приёма
efax-0.9a: 12:17:10 remote ID -> "     0000000000"
efax-0.9a: 12:17:10 session  98lpi  4800bps 8.5"/215mm  any   1D    -     -  0ms
efax-0.9a: 12:17:15 session  98lpi  4800bps 8.5"/215mm  any   1D    -     -  0ms
efax-0.9a: 12:19:04 принято 1166 строк с 0 ошибками
efax-0.9a: 12:19:09 завершили - завершено успешно
efax-0.9a: 12:19:09 открыли /dev/ttyS0
efax-0.9a: 12:19:11 используйте ZyXEL V.90 ROMV1.08ZyDASZD1061ROMV1.08 in класс 2.0
efax-0.9a: 12:19:11 Внимание: неверный ответ после команды: +FIP
efax-0.9a: 12:19:11 ожидание активности

По-моему, нужно что-то в строке инициализации менять.

Оффлайн I_raduga

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Проблема с приемом факса.
« Ответ #12 : 05 Ноябрь 2008, 14:39:20 »
Та же хрень. Насколько я поняла +FIP - это команда инициализации модема - Установить заводские значения модема...

 

Страница сгенерирована за 0.103 секунд. Запросов: 22.