Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не могу разобраться с apt-get  (Прочитано 781 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sergeantpepper

  • Автор темы
  • Новичок
  • *
  • Сообщений: 32
    • Просмотр профиля
Не могу разобраться с apt-get
« : 23 Октябрь 2008, 13:38:33 »
Добрый день? скажу сразу я новичок, возможно вопрос будет простым...

Я пытаюсь настроить ЛАМП сервер на Kubuntu, для этого мне нужно скачать php5, apache2, mysql6

Только что настроил прокси:
http_proxy=http://логин:пароль@proxy.ksu.ru:8080

После чего sudo apt-get update выдает мне:
E: Не удалось получить доступ к файлу блокировки /var/lib/apt/lists/lock - open (11 Resource temporarily unavailable)
E: Невозможно заблокировать каталог со списками пакетов


Не подскажете что делать? ???

Оффлайн gantellus

  • Старожил
  • *
  • Сообщений: 1276
    • Просмотр профиля
Re: Не могу разобраться с apt-get
« Ответ #1 : 23 Октябрь 2008, 13:53:47 »
синаптик или что-нить типа менеджера обновлений случайно не открыто?
Придумайте ещё более дружественный интерфейс, и мир породит ещё более тупого юзера (с)
С2Duo 2.4 Ghz, Geforce 8800, Maya 44 PCI

Оффлайн sergeantpepper

  • Автор темы
  • Новичок
  • *
  • Сообщений: 32
    • Просмотр профиля
Re: Не могу разобраться с apt-get
« Ответ #2 : 23 Октябрь 2008, 13:59:35 »
Synaptic у меня нету.
Есть какой-то Adept-Manager из KDE...

Но как в нем закачивать новые приложения я честно говоря так и не понял, да и вообще хотелось бы сделать это дело через Консоль

Оффлайн gantellus

  • Старожил
  • *
  • Сообщений: 1276
    • Просмотр профиля
Re: Не могу разобраться с apt-get
« Ответ #3 : 23 Октябрь 2008, 14:10:40 »
ну вот adept тоже не должен быть запущен, когда ты что-то пытаешься установить из консоли

залезь в настройки адепта, выставь там прокси
ищещь нужный пакет, отмечаешь его для установки, нажимаешь применить

если из консоли - закрываешь ВСЕ приложения, которые могут работать с пакетами - адепт, менеджер обновлений, хз что там ещё - только после этого работаешь
Придумайте ещё более дружественный интерфейс, и мир породит ещё более тупого юзера (с)
С2Duo 2.4 Ghz, Geforce 8800, Maya 44 PCI

Оффлайн skyther

  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Не могу разобраться с apt-get
« Ответ #4 : 23 Октябрь 2008, 14:15:06 »
sudo не пишешь?

Оффлайн sergeantpepper

  • Автор темы
  • Новичок
  • *
  • Сообщений: 32
    • Просмотр профиля
Re: Не могу разобраться с apt-get
« Ответ #5 : 23 Октябрь 2008, 15:44:44 »
Благодарю за помощь!

Все-таки получилось сделать apt-get update && apt-get install через консоль

Оттуда закачал пхп и апач, а вот с Мускл скорее всего так не получится - он весит намного больше, а у меня на шлюзе стоит ограничение на размер закачиваемых файлов :(

Так что придется все-таки добивать команду make :)

 

Страница сгенерирована за 0.081 секунд. Запросов: 22.