Форум русскоязычного сообщества Ubuntu


Автор Тема: apt-get dist-upgrade - а версия старая...  (Прочитано 5957 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн l1nker

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
  • I love Linux)
    • Просмотр профиля
apt-get dist-upgrade - а версия старая...
« : 03 Ноябрь 2008, 01:14:51 »
Здравствутйте. На сервере стоит 8.04.1 Server Edition.
После выхода 8.10, сделал apt-get dist-upgrade, все вроде обновилось, перезапуск, по-прежнему пишет 8.04.1, и версия ядра по прежнему старая 2.6.24.21, а в 8.10 помойму уже 2.6.27 внесли... Короче нифига не обновилось, почему?

Оффлайн Kill[HPF]

  • Активист
  • *
  • Сообщений: 412
  • Kill
    • Просмотр профиля
    • Все о тяжелой и неформальной музыке. Биографии, дискографии, тексты, песни, клипы, туры
Re: apt-get dist-upgrade - а версия старая...
« Ответ #1 : 03 Ноябрь 2008, 01:56:32 »
У меня начала обновлятся.
Ядро вроде на половину обновилось.
Но я прервал и вот что у меня получилось :(
так что у меня вроде на половину обновилась :)
https://forum.ubuntu.ru/index.php?topic=39453.0

Оффлайн medvan

  • Любитель
  • *
  • Сообщений: 64
    • Просмотр профиля
Re: apt-get dist-upgrade - а версия старая...
« Ответ #2 : 03 Ноябрь 2008, 02:33:02 »
возможно при установки было выбрано "не изменять menu.lst" ?
теперь труспособом  -- руками править
HP Pavilion g6

Оффлайн l1nker

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
  • I love Linux)
    • Просмотр профиля
Re: apt-get dist-upgrade - а версия старая...
« Ответ #3 : 03 Ноябрь 2008, 09:59:57 »
Так все-таки я не понял, что мне сейчас то делать? Как обновить до конца?

Оффлайн Nick F0x

  • Активист
  • *
  • Сообщений: 317
  • Или ты имеешь мир, или наоборот, третьего не дано.
    • Просмотр профиля
    • f0x.ru
Re: apt-get dist-upgrade - а версия старая...
« Ответ #4 : 03 Ноябрь 2008, 10:03:16 »
репы подправить и обычное обновление, если заново не обновляется до версии

Оффлайн l1nker

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
  • I love Linux)
    • Просмотр профиля
Re: apt-get dist-upgrade - а версия старая...
« Ответ #5 : 03 Ноябрь 2008, 17:59:47 »
Я незнаю на что править репы, поскольку мне все говорили, что обнволение до новой версии дистрибутива должно происходите по apt-get dist-upgrade, и все. По обычному обновлению apt-get update && apt-get upgrade - тишина... 0

Оффлайн Kill[HPF]

  • Активист
  • *
  • Сообщений: 412
  • Kill
    • Просмотр профиля
    • Все о тяжелой и неформальной музыке. Биографии, дискографии, тексты, песни, клипы, туры
Re: apt-get dist-upgrade - а версия старая...
« Ответ #6 : 03 Ноябрь 2008, 18:19:26 »
Попробуй сменить сервера :)
но допустим с озер или еще чего на русские или  с русских на какиенибудь другие.
у меня помогло когда вайн обновлял:)
ну или добавь еще другие репы :)

Оффлайн l1nker

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
  • I love Linux)
    • Просмотр профиля
Re: apt-get dist-upgrade - а версия старая...
« Ответ #7 : 03 Ноябрь 2008, 22:16:19 »
так блин, легко сказать, попробуй сменить, добавь другие?!

Какие, и откуда мне их взять? И не ужели надо что-то пробовать чтобы обновить дистрибутив, это же обновление Ubuntu, а ни какой-то мелкой проги...

Оффлайн l1nker

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
  • I love Linux)
    • Просмотр профиля
Re: apt-get dist-upgrade - а версия старая...
« Ответ #8 : 04 Ноябрь 2008, 20:57:04 »
Ау! Поможете обновитьСЯ?!

Оффлайн fuss

  • Старожил
  • *
  • Сообщений: 2073
    • Просмотр профиля
    • Screenshoter
Re: apt-get dist-upgrade - а версия старая...
« Ответ #9 : 04 Ноябрь 2008, 21:21:40 »
Цитировать
Network Upgrade for Ubuntu Servers (Recommended)

   1. Open the Run Command dialog by pressing Alt+F2. Type kdesu "adept_manager --dist-upgrade-devel" in the command box and press the OK button.

      Install update-manager-core if it is not already installed:

      sudo apt-get install update-manager-core

   2. Edit /etc/update-manager/release-upgrades and set:

      Edit /etc/update-manager/release-upgrades and set:

      Prompt=normal

   3. Launch the upgrade tool:

      Launch the upgrade tool:

      sudo do-release-upgrade

   4. Follow the on-screen instructions.

http://www.ubuntu.com/getubuntu/upgrading

Оффлайн l1nker

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
  • I love Linux)
    • Просмотр профиля
Re: apt-get dist-upgrade - а версия старая...
« Ответ #10 : 04 Ноябрь 2008, 23:13:02 »
Обновил по инструкции...
Вот часть лога
Цитировать

Настраивается пакет libcompress-raw-zlib-perl (2.011-2build1) ...
Настраивается пакет libterm-readkey-perl (2.30-3ubuntu2) ...
Настраивается пакет libdbd-mysql-perl (4.007-1build1) ...
Настраивается пакет libauthen-pam-perl (0.16-1.1) ...
Настраивается пакет libcurses-perl (1.23-1) ...
Настраивается пакет libsnmp-perl (5.4.1~dfsg-7.1ubuntu6) ...
Настраивается пакет libnet-ssleay-perl (1.35-1ubuntu1) ...
Настраивается пакет libhtml-parser-perl (3.56-1ubuntu2) ...
Настраивается пакет libsnmp-dev (5.4.1~dfsg-7.1ubuntu6) ...
Настраивается пакет libwww-perl (5.812-1) ...
Обрабатываются триггеры для libc6 ...
ldconfig deferred processing now taking place
Обрабатываются триггеры для python-support ...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.24-21-server
При обработке следующих пакетов произошли ошибки:
 base-files
/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)

Обновление завершено

Процесс обновления завершен с
ошибками.


Не удалось установить обновления

Обновление аварийно завершено.
Система может быть в нерабочем
состоянии. Сейчас будет запущена
процедура восстановления (dpkg --configure
-a).

Please report this bug against the 'update-manager' package and
include the files in /var/log/dist-upgrade/ in the bugreport.
installArchives() failed

Настраивается пакет base-files (4.0.4ubuntu2.2) ...
/var/lib/dpkg/info/base-files.postinst: line 97: /var/log/lastlog: Is a directory
dpkg: не удалось обработать параметр base-files (--configure):
 подпроцесс post-installation script возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 base-files
/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)

Обновление завершено

Процесс обновления завершен с
ошибками.

Боюсь перезагружаться... что делать  :-[

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: apt-get dist-upgrade - а версия старая...
« Ответ #11 : 05 Ноябрь 2008, 10:59:55 »
Боюсь перезагружаться... что делать  :-[
sudo aptitude -f reinstall base-filesreinstall поменять на install при необходимости.

Оффлайн l1nker

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
  • I love Linux)
    • Просмотр профиля
Re: apt-get dist-upgrade - а версия старая...
« Ответ #12 : 06 Ноябрь 2008, 11:30:34 »
Цитировать
root@centerlocal:~# aptitude -f reinstall base-files
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
Reading extended state information
Initializing package states... Готово
Writing extended state information... Готово
Building tag database... Готово
The following packages have been automatically kept back:
  apache2-utils apache2.2-common apparmor apparmor-profiles automake1.4 comerr-dev cpp-4.1 cron db4.6-util defoma dpkg-dev
  fontconfig fontconfig-config g++-4.2 gcc-4.1 gcc-4.1-base gcc-4.2 gettext gsfonts libapache2-mod-bt libaprutil1 libaspell15
  libatk1.0-0 libbttracker0 libbtutil0 libcairo2 libck-connector0 libcroco3 libcurl3 libcurses-ui-perl libdatrie0 libdbus-glib-1-2
  libexif-dev libexif12 libexpat1 libfontconfig1 libfreetype6 libgcrypt11-dev libgd2-xpm libgnutls-dev libgomp1 libgphoto2-2
  libgphoto2-2-dev libgphoto2-port0 libgraphviz4 libgsf-1-114 libgsf-1-common libgtk2.0-0 libgtk2.0-common libhal1 libieee1284-3
  libieee1284-3-dev libio-compress-base-perl libio-compress-zlib-perl libjasper1 libkadm55 libkrb5-dev liblcms1 liblockfile1
  liblzo2-dev libmagic1 libmagick10 libmcrypt4 libming0 libpango1.0-0 libpango1.0-common libpixman-1-0 libpng12-0 librecode0
  librsvg2-2 libruby1.8 libsane libsm6 libstdc++6-4.2-dev libt1-5 libtasn1-3-dev libthai-data libthai0 libtiff4 libtiff4-dev
  libtiffxx0c2 libx11-6 libx11-data libxau6 libxcb-xlib0 libxcb1 libxcomposite1 libxdamage1 libxdmcp6 libxext6 libxft2 libxi6
  libxinerama1 libxrandr2 libxrender1 libxslt1.1 logrotate mailx mlock mysql-client-5.0 mysql-server-5.0 openssh-blacklist
  openssh-server openssl-blacklist patch php5-cli php5-common po-debconf python-imaging samba-common sane-utils shtool x11-common
  xauth xdg-utils
The following packages have been kept back:
  apache2 apache2-doc apache2-mpm-prefork apt apt-utils aptitude at autoconf autotools-dev bash bash-completion belocs-locales-bin
  binutils bittornado bsdutils build-essential command-not-found command-not-found-data console-cyrillic console-setup
  console-terminus console-tools cpp cpp-4.2 curl dash dbconfig-common dhcp3-client dhcp3-common dnsutils dosfstools e2fslibs
  e2fsprogs eject ethtool fakeroot fdutils file flex friendly-recovery ftp fuse-utils g++ gcc gcc-4.2-base gettext-base gnupg gpgv
  grep groff-base grub gzip hdparm hostname initscripts installation-report ipmasq iproute iptables kernel-package klogd
  laptop-detect libacl1 libapache2-mod-php5 libapr1 libatm1 libattr1 libblkid1 libcomerr2 libcompress-zlib-perl libconsole
  libcupsys2 libcupsys2-dev libcurl3-gnutls libcwidget3 libdbus-1-3 libdbus-1-dev libdevmapper1.02.1 libedit2 libelfg0 libfuse2
  libgcrypt11 libidn11 libkeyutils1 libkrb53 libldap-2.4-2 liblzo2-2 libmysqlclient15-dev libnewt0.52 libpcap0.8 libphp-adodb
  libpopt-dev libpopt0 libpq5 libsane-dev libsasl2-2 libsasl2-modules libsepol1 libsigc++-2.0-0c2a libslang2 libss2 libstdc++6
  libtasn1-3 libtool libusb-0.1-4 libusb-dev libxml2 linux-image-server linux-server locales login lsb-release lshw lsof ltrace
  lynx lzma m4 make man-db manpages mc memtest86+ mktemp mlocate mount mtr-tiny mysql-client mysql-server nano netcat
  netcat-traditional nmap ntfs-3g openssh-client openssl parted pciutils php-pear php5 php5-apache2-mod-bt php5-curl php5-dev
  php5-gd php5-idn php5-imagick php5-imap php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-pspell php5-recode
  php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl phpmyadmin popularity-contest ppp pppconfig pppoeconf python-apt
  python-central python-dbus python-gdbm python-reportlab rar rsync samba samba-doc sasl2-bin screen ssh ssl-cert startup-tasks
  strace sudo sysklogd system-services sysv-rc sysvutils tar tasksel tasksel-data tcpd tcpdump time torrentflux traceroute tzdata
  ufw unzip update-inetd update-manager-core upstart upstart-compat-sysv upstart-logd usbutils util-linux util-linux-locales
  vim-common vim-tiny vsftpd w3m wget whiptail whois wpasupplicant xkb-data
The following packages will be REINSTALLED:
  base-files
0 packages upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 327 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Готово
Настраивается пакет base-files (4.0.4ubuntu2.2) ...
/var/lib/dpkg/info/base-files.postinst: line 97: /var/log/lastlog: Is a directory
dpkg: не удалось обработать параметр base-files (--configure):
 подпроцесс post-installation script возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 base-files
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Настраивается пакет base-files (4.0.4ubuntu2.2) ...
/var/lib/dpkg/info/base-files.postinst: line 97: /var/log/lastlog: Is a directory
dpkg: не удалось обработать параметр base-files (--configure):
 подпроцесс post-installation script возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 base-files
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
Reading extended state information
Initializing package states... Готово
Building tag database... Готово

root@centerlocal:~# aptitude -f install base-files
Чтение списков пакетов... Готово
Построение дерева зависимостей... 50%
Построение дерева зависимостей
Reading state information... Готово
Reading extended state information
Initializing package states... Готово
Building tag database... Готово
The following packages have been automatically kept back:
  apache2-utils apache2.2-common apparmor apparmor-profiles automake1.4 comerr-dev cpp-4.1 cron db4.6-util defoma dpkg-dev
  fontconfig fontconfig-config g++-4.2 gcc-4.1 gcc-4.1-base gcc-4.2 gettext gsfonts libapache2-mod-bt libaprutil1 libaspell15
  libatk1.0-0 libbttracker0 libbtutil0 libcairo2 libck-connector0 libcroco3 libcurl3 libcurses-ui-perl libdatrie0 libdbus-glib-1-2
  libexif-dev libexif12 libexpat1 libfontconfig1 libfreetype6 libgcrypt11-dev libgd2-xpm libgnutls-dev libgomp1 libgphoto2-2
  libgphoto2-2-dev libgphoto2-port0 libgraphviz4 libgsf-1-114 libgsf-1-common libgtk2.0-0 libgtk2.0-common libhal1 libieee1284-3
  libieee1284-3-dev libio-compress-base-perl libio-compress-zlib-perl libjasper1 libkadm55 libkrb5-dev liblcms1 liblockfile1
  liblzo2-dev libmagic1 libmagick10 libmcrypt4 libming0 libpango1.0-0 libpango1.0-common libpixman-1-0 libpng12-0 librecode0
  librsvg2-2 libruby1.8 libsane libsm6 libstdc++6-4.2-dev libt1-5 libtasn1-3-dev libthai-data libthai0 libtiff4 libtiff4-dev
  libtiffxx0c2 libx11-6 libx11-data libxau6 libxcb-xlib0 libxcb1 libxcomposite1 libxdamage1 libxdmcp6 libxext6 libxft2 libxi6
  libxinerama1 libxrandr2 libxrender1 libxslt1.1 logrotate mailx mlock mysql-client-5.0 mysql-server-5.0 openssh-blacklist
  openssh-server openssl-blacklist patch php5-cli php5-common po-debconf python-imaging samba-common sane-utils shtool x11-common
  xauth xdg-utils
The following packages have been kept back:
  apache2 apache2-doc apache2-mpm-prefork apt apt-utils aptitude at autoconf autotools-dev bash bash-completion belocs-locales-bin
  binutils bittornado bsdutils build-essential command-not-found command-not-found-data console-cyrillic console-setup
  console-terminus console-tools cpp cpp-4.2 curl dash dbconfig-common dhcp3-client dhcp3-common dnsutils dosfstools e2fslibs
  e2fsprogs eject ethtool fakeroot fdutils file flex friendly-recovery ftp fuse-utils g++ gcc gcc-4.2-base gettext-base gnupg gpgv
  grep groff-base grub gzip hdparm hostname initscripts installation-report ipmasq iproute iptables kernel-package klogd
  laptop-detect libacl1 libapache2-mod-php5 libapr1 libatm1 libattr1 libblkid1 libcomerr2 libcompress-zlib-perl libconsole
  libcupsys2 libcupsys2-dev libcurl3-gnutls libcwidget3 libdbus-1-3 libdbus-1-dev libdevmapper1.02.1 libedit2 libelfg0 libfuse2
  libgcrypt11 libidn11 libkeyutils1 libkrb53 libldap-2.4-2 liblzo2-2 libmysqlclient15-dev libnewt0.52 libpcap0.8 libphp-adodb
  libpopt-dev libpopt0 libpq5 libsane-dev libsasl2-2 libsasl2-modules libsepol1 libsigc++-2.0-0c2a libslang2 libss2 libstdc++6
  libtasn1-3 libtool libusb-0.1-4 libusb-dev libxml2 linux-image-server linux-server locales login lsb-release lshw lsof ltrace
  lynx lzma m4 make man-db manpages mc memtest86+ mktemp mlocate mount mtr-tiny mysql-client mysql-server nano netcat
  netcat-traditional nmap ntfs-3g openssh-client openssl parted pciutils php-pear php5 php5-apache2-mod-bt php5-curl php5-dev
  php5-gd php5-idn php5-imagick php5-imap php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-pspell php5-recode
  php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl phpmyadmin popularity-contest ppp pppconfig pppoeconf python-apt
  python-central python-dbus python-gdbm python-reportlab rar rsync samba samba-doc sasl2-bin screen ssh ssl-cert startup-tasks
  strace sudo sysklogd system-services sysv-rc sysvutils tar tasksel tasksel-data tcpd tcpdump time torrentflux traceroute tzdata
  ufw unzip update-inetd update-manager-core upstart upstart-compat-sysv upstart-logd usbutils util-linux util-linux-locales
  vim-common vim-tiny vsftpd w3m wget whiptail whois wpasupplicant xkb-data
The following partially installed packages will be configured:
  base-files
0 packages upgraded, 0 newly installed, 0 to remove and 327 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Готово
Настраивается пакет base-files (4.0.4ubuntu2.2) ...
/var/lib/dpkg/info/base-files.postinst: line 97: /var/log/lastlog: Is a directory
dpkg: не удалось обработать параметр base-files (--configure):
 подпроцесс post-installation script возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 base-files
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Настраивается пакет base-files (4.0.4ubuntu2.2) ...
/var/lib/dpkg/info/base-files.postinst: line 97: /var/log/lastlog: Is a directory
dpkg: не удалось обработать параметр base-files (--configure):
 подпроцесс post-installation script возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 base-files
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
Reading extended state information
Initializing package states... Готово
Building tag database... Готово

Оффлайн l1nker

  • Автор темы
  • Любитель
  • *
  • Сообщений: 64
  • I love Linux)
    • Просмотр профиля
Re: apt-get dist-upgrade - а версия старая...
« Ответ #13 : 06 Ноябрь 2008, 11:39:50 »
Пробовал еще сделать apt-get update && apt-get upgrade -
Цитировать
root@centerlocal:~# apt-get upgrade
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
Пакеты, которые будут оставлены в неизменном виде:
  apparmor apt apt-utils aptitude build-essential cpp dnsutils g++ gcc initscripts libcairo2 libcupsys2 libcupsys2-dev libcurl3
  libcurl3-gnutls libgnutls-dev libgphoto2-2 libgphoto2-2-dev libgphoto2-port0 libgraphviz4 libgtk2.0-0 libldap-2.4-2 libmagick10
  libpango1.0-0 librsvg2-2 linux-image-server linux-server ltrace mailx mc ntfs-3g parted pciutils php5-imap php5-mcrypt python-apt
  samba samba-common sysvutils update-manager-core upstart upstart-compat-sysv upstart-logd w3m wpasupplicant
Пакеты, которые будут обновлены:
  apache2 apache2-doc apache2-mpm-prefork apache2-utils apache2.2-common apparmor-profiles at autoconf automake1.4 autotools-dev bash
  bash-completion belocs-locales-bin binutils bittornado bsdutils comerr-dev command-not-found command-not-found-data console-cyrillic
  console-setup console-terminus console-tools cpp-4.1 cpp-4.2 cron curl dash db4.6-util dbconfig-common defoma dhcp3-client
  dhcp3-common dosfstools dpkg-dev e2fslibs e2fsprogs eject ethtool fakeroot fdutils file flex fontconfig fontconfig-config
  friendly-recovery ftp fuse-utils g++-4.2 gcc-4.1 gcc-4.1-base gcc-4.2 gcc-4.2-base gettext gettext-base gnupg gpgv grep groff-base
  grub gsfonts gzip hdparm hostname installation-report ipmasq iproute iptables kernel-package klogd laptop-detect libacl1
  libapache2-mod-bt libapache2-mod-php5 libapr1 libaprutil1 libaspell15 libatk1.0-0 libatm1 libattr1 libblkid1 libbttracker0
  libbtutil0 libck-connector0 libcomerr2 libcompress-zlib-perl libconsole libcroco3 libcurses-ui-perl libcwidget3 libdatrie0
  libdbus-1-3 libdbus-1-dev libdbus-glib-1-2 libdevmapper1.02.1 libedit2 libelfg0 libexif-dev libexif12 libexpat1 libfontconfig1
  libfreetype6 libfuse2 libgcrypt11 libgcrypt11-dev libgd2-xpm libgomp1 libgsf-1-114 libgsf-1-common libgtk2.0-common libhal1 libidn11
  libieee1284-3 libieee1284-3-dev libio-compress-base-perl libio-compress-zlib-perl libjasper1 libkadm55 libkeyutils1 libkrb5-dev
  libkrb53 liblcms1 liblockfile1 liblzo2-2 liblzo2-dev libmagic1 libmcrypt4 libming0 libmysqlclient15-dev libnewt0.52
  libpango1.0-common libpcap0.8 libphp-adodb libpixman-1-0 libpng12-0 libpopt-dev libpopt0 libpq5 librecode0 libruby1.8 libsane
  libsane-dev libsasl2-2 libsasl2-modules libsepol1 libsigc++-2.0-0c2a libslang2 libsm6 libss2 libstdc++6 libstdc++6-4.2-dev libt1-5
  libtasn1-3 libtasn1-3-dev libthai-data libthai0 libtiff4 libtiff4-dev libtiffxx0c2 libtool libusb-0.1-4 libusb-dev libx11-6
  libx11-data libxau6 libxcb-xlib0 libxcb1 libxcomposite1 libxdamage1 libxdmcp6 libxext6 libxft2 libxi6 libxinerama1 libxml2
  libxrandr2 libxrender1 libxslt1.1 linux-libc-dev locales login logrotate lsb-release lshw lsof lynx lzma m4 make man-db manpages
  memtest86+ mktemp mlocate mlock mount mtr-tiny mysql-client mysql-client-5.0 mysql-server mysql-server-5.0 nano netcat
  netcat-traditional nmap openssh-blacklist openssh-client openssh-server openssl openssl-blacklist patch php-pear php5
  php5-apache2-mod-bt php5-cli php5-common php5-curl php5-dev php5-gd php5-idn php5-imagick php5-memcache php5-mhash php5-ming
  php5-mysql php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl phpmyadmin po-debconf popularity-contest ppp
  pppconfig pppoeconf python-central python-dbus python-gdbm python-imaging python-reportlab rar rsync samba-doc sane-utils sasl2-bin
  screen shtool ssh ssl-cert startup-tasks strace sudo sysklogd system-services sysv-rc tar tasksel tasksel-data tcpd tcpdump time
  torrentflux traceroute tzdata ufw unzip update-inetd usbutils util-linux util-linux-locales vim-common vim-tiny vsftpd wget whiptail
  whois x11-common xauth xdg-utils xkb-data
обновлено 283, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 45 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 653kB/143MB архивов.
After this operation, 12,6MB of additional disk space will be used.
Хотите продолжить [Д/н]? y
Получено:1 http://ru.archive.ubuntu.com intrepid-updates/main linux-libc-dev 2.6.27-7.16 [653kB]
Получено 653kB за 0s (903kB/c)
Извлечение шаблонов из пакетов: 100%
Предварительная настройка пакетов ...
Настраивается пакет base-files (4.0.4ubuntu2.2) ...
/var/lib/dpkg/info/base-files.postinst: line 97: /var/log/lastlog: Is a directory
dpkg: не удалось обработать параметр base-files (--configure):
 подпроцесс post-installation script возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 base-files
E: Sub-process /usr/bin/dpkg returned an error code (1)

Мля, тока не говорите что я запорол систему :((( Че деллать, хелп!

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: apt-get dist-upgrade - а версия старая...
« Ответ #14 : 06 Ноябрь 2008, 12:45:42 »
l1nker,
sudo aptitude -f safe-upgrade base-files:
sudo aptitude -f full-upgrade base-files:
sudo aptitude -f safe-upgrade
sudo aptitude -f full-upgrade

 

Страница сгенерирована за 0.1 секунд. Запросов: 22.