Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Настройка framebuffer  (Прочитано 2335 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн maze

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Настройка framebuffer
« : 07 Ноябрь 2008, 05:47:06 »
При добавлении в опции загрузки ядра 'vga=788', ядро автоматически подгружает модуль vesafb и переходит в графический режим.
Для моей видяхи существует модуль radeonfb.ko.
Вопрос - как его использовать вместо vesafb?

Опция "video=radeonfb:1024x768-16,mtrr,ywrap" не помогает.
Ядро стандартное (8.10). Как я посмотрел, в конфиге ядра забита поддержка обоих драйверов как <M> (те модулями).

Оффлайн maze

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #1 : 08 Ноябрь 2008, 08:44:47 »
Неужели никто не пользует framebuffer?  :-\

Оффлайн int1k

  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #2 : 17 Октябрь 2009, 11:59:31 »
А в модулях если убрать vesafb и поставить radeonfb?

Оффлайн Geo

  • Активист
  • *
  • Сообщений: 265
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #3 : 17 Октябрь 2009, 12:55:27 »
 Очень хотелось бы увидеть на форуме грамотный FAQ по настройке фреймбуфера в Ubuntu 9.04 и во вновь выпускаемом
Ubuntu 9.10.
В дистрибутивах происходят существенные изменения, в результате ранее применявшиеся методы (как то vga=xxx)
уже не срабатывают или срабатывают неверно.
У меня, например, стал невозможным переход в консоль по ctrl+alt+F2...F6 (черный экран).
Lenovo S10, UNR 10.04, gnome, COMPAQ Presario, Mint13, mate
Desktop AthlonXP, 1Gb, Mint11, gnome
Desktop Core2Duo, 6Gb, Mint12(PAE), gnome

Оффлайн int1k

  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #4 : 17 Октябрь 2009, 15:37:24 »
Вот кстати да, там помоему просто vga режимы сменились.
И самое интересное когда набираешься hwinfo --framebuffer выводятся все режимы, но если любой поставить в граб2 на загрузку  -вылетает сообщение об ошибке.

Оффлайн athost

  • Старожил
  • *
  • Сообщений: 1897
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #5 : 17 Октябрь 2009, 15:49:34 »
9.10 Фреймбуффер работает

Используйте поиск

Оффлайн Geo

  • Активист
  • *
  • Сообщений: 265
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #6 : 17 Октябрь 2009, 15:57:54 »
  athost, что значит работает? Вы его настроили - так напишите HOWTO.
Или вы его не используете?
Lenovo S10, UNR 10.04, gnome, COMPAQ Presario, Mint13, mate
Desktop AthlonXP, 1Gb, Mint11, gnome
Desktop Core2Duo, 6Gb, Mint12(PAE), gnome

Оффлайн фирэфохэ

  • Старожил
  • *
  • Сообщений: 2169
  • straightedge
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #7 : 17 Октябрь 2009, 16:00:08 »
И самое интересное когда набираешься hwinfo --framebuffer выводятся все режимы, но если любой поставить в граб2 на загрузку  -вылетает сообщение об ошибке.
и в 9.04 с grub2 тоже все работает.
http://i18.ЗАПРЕЩЁННЫЙ РЕСУРС/big/2011/0325/6d/19eaa72dd24048a6fb0587832c4b096d.gif КДЕ - УГ. Дебиан - недоось.

Оффлайн int1k

  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #8 : 17 Октябрь 2009, 22:25:04 »
сам fb работает. Бесит ошибка.

Оффлайн фирэфохэ

  • Старожил
  • *
  • Сообщений: 2169
  • straightedge
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #9 : 17 Октябрь 2009, 23:26:16 »
Что за ошибка?
http://i18.ЗАПРЕЩЁННЫЙ РЕСУРС/big/2011/0325/6d/19eaa72dd24048a6fb0587832c4b096d.gif КДЕ - УГ. Дебиан - недоось.

Оффлайн Geo

  • Активист
  • *
  • Сообщений: 265
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #10 : 18 Октябрь 2009, 14:10:12 »
 persona_non_grata смотри выше - при переключении в консоль - черный экран без признаков жизни.
Lenovo S10, UNR 10.04, gnome, COMPAQ Presario, Mint13, mate
Desktop AthlonXP, 1Gb, Mint11, gnome
Desktop Core2Duo, 6Gb, Mint12(PAE), gnome

Оффлайн Institor

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #11 : 27 Декабрь 2009, 08:52:18 »
а у меня ничего не работает )))
нет даже /dev/fb0

все перепробовал - запустить его не могу, разрешение в консоли 640*480 и больше ничего.
Везде дают разные совершенно рекомендации, единого мнения ни у кого нет.

Оффлайн rchrd

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Настройка framebuffer
« Ответ #12 : 27 Декабрь 2009, 13:10:48 »
Я думаю в топике имеется ввиду u9.10.
Для меня тоже актуальный вопрос, так как после настройки :
1. sudo vim /etc/modprobe.d/blacklist-framebuffer.conf
закомментировал строку blacklist vesafb
2. sudo vim /etc/initramfs-tools/modules
добавить строчки:
fbcon
vesafb
3. Пересобрал initramfs image: sudo update-initramfs -u
4. sudo vim /etc/default/grub В опции ядра добавил параметр vga:
GRUB_GFXMODE=640x480 или
GRUB_CMDLINE_LINUX_DEFAULT="quiet nosplash vga=0x312" В разных комбинациях перепробовал.
5. Обновил grub: sudo update-grub
6. sudo reboot.
при воспроизведении видео есть только звук.
Карточка - ATI Technologies Inc RS482 [Radeon Xpress 200M]
та же проблема на нетбуке, видео - интел

 

Страница сгенерирована за 0.059 секунд. Запросов: 22.