Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)  (Прочитано 1956 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн NECTOP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« : 07 Ноябрь 2008, 21:18:55 »
Приветствую!
После открытия Apple Mac решил попробовать Ubuntu и был очень приятно удивлен! Все работает прекрасно, под мои задачи полностью подходит, но вот стокнулся с проблемой, не могу по Bluetooth подцепить ни одного устройства! Пробежав по форуму описания моей проблемы не нашел. Имеем Лаптоп Sony TZ3RMN/N Bluuetooth на базе (Вроде Toshiba). Судя по системным сообщениям и отсутствию ошибок, делаю вывод что с устройством все хорошо, но Bluetooth через Setup new device или через inqure из терминала НЕ ВИДИТ НИ ОДНО устройство! Хочется подцепить Bluetooth Mouse + Bluetooth GPRS телефон, в будущем планирую взять ExpressCard 3G или CDMA модем, будет ли он жить?

Оффлайн leomuz

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #1 : 07 Ноябрь 2008, 22:01:05 »
Будет жить, если научитесь пользоваться поиском по форуму. >:(
LMDE

Оффлайн NECTOP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #2 : 07 Ноябрь 2008, 22:25:01 »
Будет жить, если научитесь пользоваться поиском по форуму. >:(

Это замечательно, но это был второстепенный вопрос! Да и по нему я ничего в форме не нашел а конкретно про модель AnyData APE-540A (Express Card) вообще тишина! Ну это так, будет проблема, буду решать! Сейчас же что с Bluetooth сделать? Пробовал по мануалу https://wiki.ubuntu.com/LaptopTestingTeam/FAQ#Bluetooth эффекту 0-ль! Еще мысли от "ГУРУ"?

Оффлайн leomuz

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #3 : 07 Ноябрь 2008, 22:40:27 »
Это был ответ на все ваши вопросы!!!!!!!!!!
LMDE

Оффлайн NECTOP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #4 : 07 Ноябрь 2008, 22:54:14 »
Это был ответ на все ваши вопросы!!!!!!!!!!

Вероятно Вы плохо прочли, я прочел по слову Bluetooth практически все топики и они сводились к подключению модему а именно установку пакеджей! Проделал я это в частности: http://ubuntuforums.org/showthread.php?t=786848 тут проблему решить не смогли на схожем железе! https://forum.ubuntu.ru/index.php?action=printpage;topic=23706.0 - тоже опробовано!

Оффлайн leomuz

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #5 : 07 Ноябрь 2008, 23:02:34 »
В руководствах по подключению тел. как модема как раз первая часть относится к тому что вы называете "увидеть телефон", проверяйте все необходимые пакеты , установлены ли, если все сделаете правильно должно работать. Если нет ставьте другой менеджер Bluetooth blueman.
LMDE

Оффлайн NECTOP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #6 : 08 Ноябрь 2008, 00:26:48 »
В руководствах по подключению тел. как модема как раз первая часть относится к тому что вы называете "увидеть телефон", проверяйте все необходимые пакеты , установлены ли, если все сделаете правильно должно работать. Если нет ставьте другой менеджер Bluetooth blueman.

Прочел еще раз! Выполнил все снова! Ничего не вышло! В логих вот то:

Nov  8 00:14:07 NECTOP-NOTE bluetoothd[9184]: bridge pan0 removed
Nov  8 00:14:07 NECTOP-NOTE bluetoothd[9184]: Stopping SDP server
Nov  8 00:14:07 NECTOP-NOTE bluetoothd[9184]: Exit
Nov  8 00:14:07 NECTOP-NOTE bluetoothd[10051]: Bluetooth daemon
Nov  8 00:14:07 NECTOP-NOTE bluetoothd[10051]: Starting SDP server
Nov  8 00:14:07 NECTOP-NOTE bluetoothd[10051]: Starting experimental netlink support
Nov  8 00:14:07 NECTOP-NOTE bluetoothd[10051]: Failed to find Bluetooth netlink family
Nov  8 00:14:07 NECTOP-NOTE bluetoothd[10051]: Can't init plugin /usr/lib/bluetooth/plugins/netlink.so
Nov  8 00:14:07 NECTOP-NOTE bluetoothd[10051]: bridge pan0 created
Nov  8 00:14:07 NECTOP-NOTE bluetoothd[10051]: HCI dev 0 registered
Nov  8 00:14:07 NECTOP-NOTE bluetoothd[10051]: HCI dev 0 already up
Nov  8 00:14:08 NECTOP-NOTE bluetoothd[10051]: Registered interface org.bluez.SerialProxyManager on path /org/bluez/hci0
Nov  8 00:14:08 NECTOP-NOTE bluetoothd[10051]: Registered interface org.bluez.Service on path /org/bluez/hci0
Nov  8 00:14:08 NECTOP-NOTE bluetoothd[10051]: Registered interface org.bluez.NetworkPeer on path /org/bluez/hci0
Nov  8 00:14:08 NECTOP-NOTE bluetoothd[10051]: Registered interface org.bluez.NetworkHub on path /org/bluez/hci0
Nov  8 00:14:08 NECTOP-NOTE bluetoothd[10051]: Registered interface org.bluez.NetworkRouter on path /org/bluez/hci0
Nov  8 00:14:08 NECTOP-NOTE bluetoothd[10051]: Adapter /org/bluez/hci0 has been enabled
Nov  8 00:14:08 NECTOP-NOTE bluetoothd[10051]: Starting security manager 0
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10051]: bridge pan0 removed
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10051]: Stopping SDP server
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10051]: Exit
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Bluetooth daemon
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Starting SDP server
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Starting experimental netlink support
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Failed to find Bluetooth netlink family
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Can't init plugin /usr/lib/bluetooth/plugins/netlink.so
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: bridge pan0 created
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: HCI dev 0 registered
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: HCI dev 0 already up
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Registered interface org.bluez.SerialProxyManager on path /org/bluez/hci0
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Registered interface org.bluez.Service on path /org/bluez/hci0
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Registered interface org.bluez.NetworkPeer on path /org/bluez/hci0
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Registered interface org.bluez.NetworkHub on path /org/bluez/hci0
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Registered interface org.bluez.NetworkRouter on path /org/bluez/hci0
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Adapter /org/bluez/hci0 has been enabled
Nov  8 00:19:00 NECTOP-NOTE bluetoothd[10438]: Starting security manager 0



Нашел еще вот это! Схожая проблема! Точнее баг! https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/288613 может кто прокоментирует?
« Последнее редактирование: 08 Ноябрь 2008, 00:35:22 от NECTOP »

Оффлайн leomuz

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #7 : 08 Ноябрь 2008, 08:20:53 »
hcitool scan телефон видит?
LMDE

Оффлайн NECTOP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #8 : 08 Ноябрь 2008, 08:39:39 »
hcitool scan телефон видит?

Нет не телефон ни мышь ничего!!

Оффлайн leomuz

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #9 : 08 Ноябрь 2008, 08:48:17 »
Какие у вас вообще стоят пакеты bluez может чего то не хватает, если все стоит пробуйте переустановить пакет. Вот тут http://tuxmobil.org/sony.html очень много решений по ноутам ищите подобный вашему возможно там есть.
LMDE

Оффлайн leomuz

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #10 : 08 Ноябрь 2008, 09:22:24 »
Попробуйте добавить в  /etc/rc.local  следующее

hciconfig hci0 inqmode 0

и еще раз просканировать.
LMDE

Оффлайн NECTOP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #11 : 08 Ноябрь 2008, 14:12:39 »
Попробуйте добавить в  /etc/rc.local  следующее

hciconfig hci0 inqmode 0

и еще раз просканировать.

Пакеты стоят как в статьях указано все. А после прописывания в rc.local :

nectop@NECTOP-NOTE:~$ hcitool scan
Scanning ...
nectop@NECTOP-NOTE:~$

Короче говоря, без изменений!


Появилась тут у меня мысль! А подскажите пожалуйста, с какого репозитария можно скачать самые свежие версии пакетов BlueZ?




Скачал с Bluez.org свежие версии улитит и библиотек собрал утановил! Без изминений! Собрал HCI DUMP вот что он пишет когда происходит поиск устройств

nectop@NECTOP-NOTE:~$ sudo hcidump
[sudo] password for nectop:
HCI sniffer - Bluetooth packet analyzer ver 1.42
device: hci0 snap_len: 1028 filter: 0xffffffff
< HCI Command: Periodic Inquiry Mode (0x01|0x0003) plen 9
> HCI Event: Command Complete (0x0e) plen 4
> HCI Event: Inquiry Complete (0x01) plen 1
< HCI Command: Exit Periodic Inquiry Mode (0x01|0x0004) plen 0
> HCI Event: Command Complete (0x0e) plen 4


Попробовал Диск Ubuntu 8.10 DVD на нотике жены (Другая SONY SZ) у нее прямо загрузившись с DVD все сразу заработало! Ну и что же я не так делаю?



Продолжая решение проблемы сделал что-то, теперь после команды sudo hciconfig hci0 reset команда sudo hcitool scan или sudo hcitool inq выдает список устройств! И в графическом интрефейсе они тоже появляются я даже подцепил мышку, но после ребута она отвалилась! Снова к ней подцепится не удается даже прописав вот так

sudo nano /etc/default/bluetooth

HIDD_ENABLED=1


HIDD_OPTIONS=”--connect aa:bb:cc:dd:ee:ff --server”


на команду sudo hidd --search если устройство (в данный момент это мышка) в режиме "спаривания" то он к ней цепляется и она работает до цона сеанса.


Пока как решить не понял! 

сделал еще вот так

  sudo cp /etc/default/bluetooth /etc/default/bluetooth_backup
  sudo nano /etc/default/bluetooth
  HIDD_ENABLED=1
  HIDD_OPTIONS="--connect aa:bb:cc:dd:ee:ff --master  --server"

  echo hidp | sudo tee -a /etc/modules
Может кто подскажет? Начинает устройство работать только после команды sudo hciconfig hci0 reset  после ребута поднять не получается!


« Последнее редактирование: 08 Ноябрь 2008, 20:16:41 от NECTOP »

Оффлайн Stiff

  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #12 : 09 Ноябрь 2008, 12:53:30 »
У меня проблема другая: hcitool устройства видит, но при попытке просканировать службы или соединиться выдаёт connection timeout.
В 8.04 всё работало, в 8.10 явно что-то поломали

Оффлайн NECTOP

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #13 : 09 Ноябрь 2008, 15:58:37 »
Все! Решил проблему.
в /etc/rc.local
добавил sudo hciconfig hci0 reset
После перезагрузки все видит и целпяется!

Теперь следующая проблема это SD/MS Card Reader и WEB Камера не работают.С кард ридером пока не разбирался а вот для Web камеры нашел но не могу собрать!

Оффлайн Colix

  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Sony TZ3RMN Ubuntu 8.10 (Bluetooth Problems)
« Ответ #14 : 13 Январь 2009, 14:21:58 »
А с AnyData APE-540A (Express Card) придумал что делать? В гугле сюда ссылка приводит =)

 

Страница сгенерирована за 0.055 секунд. Запросов: 22.