Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Ubuntu 8.10 - GeForce 8600GT SLI Mode  (Прочитано 1630 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lipis

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
  • Shinigami-sama
    • Просмотр профиля
Ubuntu 8.10 - GeForce 8600GT SLI Mode
« : 16 Ноябрь 2008, 00:37:50 »
Доброго времени суток, у меня проблема, может быть кто нибудь сталкивался.

После установки драйвера nvidia 177 и перезагрузки не запускаются иксы.
Проблема в использовании SLI, c 1 карточкой все работает отлично.

Система: Ubuntu 8.10-i368

Помогите пожалуйста решить проблему.
« Последнее редактирование: 16 Ноябрь 2008, 00:44:49 от lipis »

Оффлайн lipis

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
  • Shinigami-sama
    • Просмотр профиля
Re: Ubuntu 8.10 - GeForce 8600GT SLI Mode
« Ответ #1 : 17 Ноябрь 2008, 18:11:49 »
может быть есть какой то дополнительный драйвер для SLI режима... гугл молчит. Хотя бы вы не молчите.

Оффлайн fatalist

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Ubuntu 8.10 - GeForce 8600GT SLI Mode
« Ответ #2 : 17 Ноябрь 2008, 19:38:03 »
Та же проблема только с 6600 GT - решения не нашел, пока одну карту вывернул.

На 8.04 SLI работало нормально.

В свежей бете 180.06 - тоже не полечили, ждем'c

Оффлайн kyxap

  • Участник
  • *
  • Сообщений: 225
  • 2.6.30-ARCH + openbox
    • Просмотр профиля
Re: Ubuntu 8.10 - GeForce 8600GT SLI Mode
« Ответ #3 : 17 Ноябрь 2008, 22:06:32 »
извините меня дорогие, а зачем вам 2 карты на убунте???
во что играть собрались ?
вы с вистой не перепутали ? )
asus m2n-e sli
asus GF8600GT silent ~512mb
DDR2 Kingston 800 2gb Proview AI2237W

Оффлайн lipis

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
  • Shinigami-sama
    • Просмотр профиля
Re: Ubuntu 8.10 - GeForce 8600GT SLI Mode
« Ответ #4 : 18 Ноябрь 2008, 00:03:15 »
Ну я например в Fallout 3 играю сейчас. :D

Оффлайн lipis

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
  • Shinigami-sama
    • Просмотр профиля
Re: Ubuntu 8.10 - GeForce 8600GT SLI Mode
« Ответ #5 : 18 Ноябрь 2008, 02:09:21 »
Победил!

Решение:
В xorg.conf надо указать BusId видеокарты.

Для этого нужно:

 1) Установить драйвер nVidia 177 или аналогичный для вашей видеокарты.
 2) Узнать BusId видеокарт: в терминале ввыодим lspci | grep -i vga. он выдаст BusId:
Пример:
user@ubuntu:~$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
02:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
 3) Из под root'a (sudo -s -H) редактируем xorg.conf например редактором nano: nano /etc/X11/xorg.conf
В Section "Device" пишем наш BusId первой видеокарты:
Пример:
Section "Device"
    Identifier     "Configured Video Device"
    BusId          "01:00:00"
    Driver         "nvidia"
EndSection
 - Сохраняем файл (Ctrl+C) и выходим из редактора (Ctrl+X).
 4) Теперь нужно проверить работают ли X'ы в такой конфигурации.
-Жмем Ctrl-Alt+Backspace. если после перезапуска X'ы и видео драйвер работают, смело перезагружаемся.
-Если  Х не работает, пробуем BusId второй видеокарты.

Итого: эффект достигнут, ваша система работает в режиме SLI.

Оффлайн fatalist

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Ubuntu 8.10 - GeForce 8600GT SLI Mode
« Ответ #6 : 02 Декабрь 2008, 13:55:08 »
Спасибо - помогло.

Только не понял почему в BusId  нужно писать "01:00:00",
хотя lspci | grep -i vga выдает "01:00.0"?


Оффлайн afon

  • Старожил
  • *
  • Сообщений: 1110
  • Drink Different!
    • Просмотр профиля
Re: Ubuntu 8.10 - GeForce 8600GT SLI Mode
« Ответ #7 : 02 Декабрь 2008, 14:40:45 »
Подскажите пожалуйста, почему, прописывая ОДИН busId, работают обе карточки? Или просто иксы/драйвер видит их как одну?
Drink Different, Understand Computer.
Bye.

 

Страница сгенерирована за 0.141 секунд. Запросов: 22.