Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: via UniChrome Pro  (Прочитано 3085 раз)

0 Пользователей и 1 Гость просматривают эту тему.

mithrusc

  • Автор темы
  • Гость
via UniChrome Pro
« : 18 Ноябрь 2008, 01:10:55 »
здравствуйте.
Испытываю некоторые проблемы со встроенным видео ноутбука, а именно нет подходящего драйвера к этой видео карточке, пробовал ставить Kubuntu 8.04.1 по умолчанию она заводится с vesa но все глючит так что работать просто невозможно, поставил openchrome пакет...вродебы установился драйвер и подхватил карточку, прописал в xorg.conf 'via' в секции драйвера все бестолку одни и те же глюки, родной драйвер ругается матом мол подавай мне Ubuntu 7.10 и ядро 2.6.22-14
Что самое интересное Mandriva2009 (free даже не power pack) установила драйвер к этой видяхе, видео не тормозлюкало и не глючило и работал direct render, какой там драйвер она ставила я непонял, сейчас уже снес её и не посмотришь ничего
Ubuntu 8.10 у меня зависает при первой загрузки после установки

(VIA VN800 основа ноута)

Оффлайн ende_neu

  • Старожил
  • *
  • Сообщений: 2473
    • Просмотр профиля
Re: via UniChrome Pro
« Ответ #1 : 18 Ноябрь 2008, 01:49:51 »

mithrusc

  • Автор темы
  • Гость
Re: via UniChrome Pro
« Ответ #2 : 18 Ноябрь 2008, 01:56:03 »
нету, я же написал VN800, его там нету среди поддерживаемых, и потом где то вычитал что в интерпиде OpenChrome больше работать не будет мол ставьте родные виашные дрова, вот как их ставить если они требуют наличия старого ядра хз
Цитировать
http://unichrome.sourceforge.net
ну а что я там должен увидеть? куда проще скачать deb пакет. ну а про него выше ((
« Последнее редактирование: 18 Ноябрь 2008, 01:58:35 от mithrusc »

mithrusc

  • Автор темы
  • Гость
Re: via UniChrome Pro
« Ответ #3 : 24 Ноябрь 2008, 23:07:48 »
нет никаких идей? а то mandriva совсем не то после Ubuntu((

Оффлайн metallcorn

  • Новичок
  • *
  • Сообщений: 47
  • Ubuntu 14.04
    • Просмотр профиля
    • Мой уютненький бложик..
Re: via UniChrome Pro
« Ответ #4 : 27 Декабрь 2008, 20:02:33 »
ну я скачал в общем дрова с сайта производителя...которые 2Д...(там 2 версии...2д и 3д..)..
чтобы в консоли не париться...загрузился с Live CD 8.04 с параметром xforcevesa
с флехи скинул на комп скаченные дрова
открыл через консоль sudo nautilus
распокавал архив... в нем фаил readme.txt
по первым пунктам выполнил
скопировал via_drv.so  в /usr/lib/xorg/modules/drivers/.
потом sudo gedit /etc/X11/xorg.conf
в           Section "Device"
вписал       Driver     "via"
и                Option "Center"
для LCD монитора...в моем случае экран ноута


после всего этого....перезагружаюсь...и Ubuntu норм грузит НО!!!!!
изобрадение не широкоформатное!!!!!
то есть справа и слева 2 черные полосы без изображения...
а само издображдение норм...хорошо работает...
кто подскажет мне далее!?!? ))) заранее спасибо )

Оффлайн metallcorn

  • Новичок
  • *
  • Сообщений: 47
  • Ubuntu 14.04
    • Просмотр профиля
    • Мой уютненький бложик..
Re: via UniChrome Pro
« Ответ #5 : 28 Декабрь 2008, 10:55:50 »
ну неужто никто не может подсказать??
проблема то не большую половину решена
ну так!?

Aneyrin

  • Автор темы
  • Гость
Re: via UniChrome Pro
« Ответ #6 : 23 Октябрь 2009, 14:45:42 »
ну неужто никто не может подсказать??
проблема то не большую половину решена
ну так!?

Надобно править xorg. Делайте так:

sudo gedit /etc/X11/xorg.conf
В разделе  Section "Screen" выбирайте родное разрешение для вашего дисплея.


Section "Screen"

        Identifier     "Default Screen"

        Monitor        "Configured Monitor"

        Device         "Configured Video Device"

        SubSection "Display"

              [b] Modes "1280x800"[/b]

        EndSubSection

Оффлайн metallcorn

  • Новичок
  • *
  • Сообщений: 47
  • Ubuntu 14.04
    • Просмотр профиля
    • Мой уютненький бложик..
Re: via UniChrome Pro
« Ответ #7 : 27 Октябрь 2009, 17:55:21 »
ну на самом деле это на сколько помню не особо помогало...
зато опотом норм дрова на сате производителя появились....
а потом вышла 9.04 и она по стандарту ОК работает... )))
так что в принципе вопрос уже не актуален

Оффлайн kimeriec

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: via UniChrome Pro
« Ответ #8 : 05 Январь 2010, 21:41:59 »
Доброго времени суток!!!!!!
Имеем ubuntu 9.04, via cn700 (roverbook w500l partner).
НЕ получается устновить драйвера на встроеную видио карту.
Перечитал весь форум и что выдаёт гугл.
Испробованные варианты:
help.ubuntu.com/community/openchrome
описание установки драйвера..
ТАкие же драйвера , только  другой версии с viaarena.com тоже не устанавливаются.
Все остальные советы сводились  к этому же...
Единственное что помогало до перезагрузки- это править файл компиза: sudo gedit /usr/bin/compiz
далее найти строку WHITELIST="nvidia intel ati radeon i810 fglrx" и исправить её WHITELIST="nvidia intel ati radeon i810 via"
После этого запускается компиз  и всё работает до  перезагрузки.
После чего приходим к тму,  с чего  и начали:
EE:
fail to load module "viavideo" (modul does not exist)
via (0) unkown EDID version
via (0) no valid initional configuration found
skreen found,but none have usable configuration

Что  совсем этим делать?
Подскажите плз .. А то  6 дней сражней плох отражаются на здоровье:(

mithrusc

  • Автор темы
  • Гость
Re: via UniChrome Pro
« Ответ #9 : 07 Январь 2010, 21:21:21 »
kimeriec
попробуйте 2д драйвер с сайта VIA для Ubuntu, ставьте по readme, потом проверьте подгрузился ли драйвер командой lsmod
Я поставил на debian / ubuntu, но качество драйверов оставляет желать лучшего

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.