Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Bluetooth в 8.10 не работает  (Прочитано 9815 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Robbyy

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Bluetooth в 8.10 не работает
« : 20 Ноябрь 2008, 09:09:42 »
Поискал на форуме похожую проблему: ничего!
Все говорят о том что не могут что-то синхронизировать или файлы не передает. А у меня блютуз ваще мертвый!!!

Суть проблемы:
ноутбук Toshiba Sattelite A200 Ubuntu 8.10
блютуз включен аппаратной кнопкой.
Установлены следующие пакеты:
bluetooth
bluez
bluez-alsa
bluez-cups
bluez-gnome
bluez-gstreamer
bluez-utils
btscanner
libbluetooth3
gnome-bluetooth
libbtctl4
libgnomebt0
obex-data-server
obexfs
obexpushd

и ниче не работает! Утилита настройки блютуз из гнома дает понять что блютуз не включен, соответственно все функции неактивны.

может я просто не умею его правильно включать.

Подскажите что поделать в терминале, чтоб узнать состояние bluetooth адаптера.


Оффлайн Robbyy

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #2 : 21 Ноябрь 2008, 13:30:30 »
Yuri!
на ваших ссылках ничего путного не нашел, но там кто-то ссылался на кого-то у кого нашел вот это:
http://ubuntuforums.org/showthread.php?p=6203606#post6203606

По беглому просмотру похоже на толковое руководство, сейчас попробую и расскажу что вышло.

Оффлайн Robbyy

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #3 : 21 Ноябрь 2008, 21:10:05 »
Попробовал HowTo которое нашел (см. выше)
Скачал linux-source и patch как там написано
но при запуске
patch -p0 < toshiba_acpi-dev_toshiba_test5-linux_2.6.26.patch --dry-run
выдает следующее:
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- toshiba_acpi.c.orig 2008-08-30 22:12:50.000000000 -0700
|+++ toshiba_acpi.c 2008-08-31 12:03:07.000000000 -0700
--------------------------
File to patch:


Что это значит? Подскажите...

Оффлайн Yuri77

  • Активист
  • *
  • Сообщений: 271
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #4 : 23 Ноябрь 2008, 17:52:50 »
Дочитайте ваш линк.

Оффлайн Robbyy

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #5 : 24 Ноябрь 2008, 21:08:27 »
Еслиб мне было все четко ясно в этом HowTo
я бы не спрашивал.
Я таких операций раньше не проделывал...

Может у кого-то из опытных пользователей есть время прокомментировать
поподробней..

Оффлайн Yuri77

  • Активист
  • *
  • Сообщений: 271
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #6 : 25 Ноябрь 2008, 18:41:08 »
Post #3:
Цитировать
The only thing that needs to add is, before aplying the patch:
cp toshiba_acpi-dev_toshiba_test5-linux_2.6.26.patch linux-source-2.6.27/drivers/acpi
cd linux-source-2.6.27/drivers/acpi

Оффлайн Robbyy

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #7 : 26 Ноябрь 2008, 09:44:01 »
Спасибо!!!!!!!! :D

Дальше продвинулся, но на последнем шаге
после sudo modprobe toshiba_acpi
у меня выдает вот что:
FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.27-7-generic/kernel/drivers/acpi/toshiba_acpi.ko): Unknown symbol in module, or unknown parameter (see dmesg)
При этом файл toshiba_acpi.ko пропатчился и скопировался куда надо
а в modules.dep я добавил следующую строчку:
/lib/modules/2.6.27-7-generic/kernel/drivers/acpi/toshiba_acpi.ko:
Что у меня не так?

Оффлайн Yuri77

  • Активист
  • *
  • Сообщений: 271
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #8 : 26 Ноябрь 2008, 16:57:28 »
omnibook ставить пробовали (линки, которые давал раньше)?
Конкретнее - howto для Hardy:
http://www.linuxforums.org/forum/ubuntu-help/125492-solved-problem-bluetooth.html#post611407

Оффлайн Robbyy

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #9 : 26 Ноябрь 2008, 17:24:46 »
Страшновато конечно такие штуки мне вытворять....
Это мой рабочий ноут и убивать систему мне никак нельзя, работа встанет

Оффлайн Robbyy

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #10 : 26 Ноябрь 2008, 17:25:32 »
А что может быть с модулем который я сделал?
Почему он не добавляется?

Оффлайн Yuri77

  • Активист
  • *
  • Сообщений: 271
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #11 : 26 Ноябрь 2008, 19:47:44 »
Цитировать
From http://memebeam.org/toys/ToshibaAcpiDriver:

Quote:
Another important note: This driver does not work on all Toshiba laptops, particularly those models which seem to have a BIOS or other firmware which was not developed by Toshiba itself. New reverse engineering work will have to be done on these machines, or Toshiba will have to disclose the necessary details. (For support of machines with Phoenx BIOS, try the [Omnibook driver].)

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #12 : 27 Ноябрь 2008, 12:46:48 »
вообще, в 8.10 есть проблемы с BT. ещё не исследовал, но могу сказать, что соединиться с устройством (средствами апплета gnome-bluetooth) не получается.

Оффлайн Robbyy

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #13 : 27 Ноябрь 2008, 13:06:13 »
Вы хотя-бы пробуете соединиться )))))

Я еще не могу включить bluetooth.....

Оффлайн Robbyy

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: Bluetooth в 8.10 не работает
« Ответ #14 : 27 Ноябрь 2008, 13:11:29 »
Yuri77!!!
По вашему совету пытаюсь поставить omnibook
Использую вот это: http://ubuntuforums.org/showthread.php?t=316358
Загрузил архив с http://sourceforge.net/projects/omnibook

Когда пытаюсь запустить make выдает кучу ошибок.....


 

Страница сгенерирована за 0.058 секунд. Запросов: 22.