Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: VNC в Ubuntu 8.10 подключение только после локального входа  (Прочитано 6346 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн androidoff

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Собственно проблема: Настроил VNC для подключения к удаленному рабочему столу, все работает, но есть одно "НО", только тогда когда какой-нибудь пользователь уже вошел в систему, и работает (либо заблокировал экран, но не окончил сессию). Если висит экран приветствия, подключения нет, идет ошибка Connection refused (10061). Захожу на Ubuntu из под Винды, испльзуя RealVNC viewer 4.1.3. 
В принципе это логично, ведь насколько я понимаю VNC server запускается для каждого юзера из-под его учетной записи, это возможно как-то решить??

P.S. XDCMP из под других никсов работает...
« Последнее редактирование: 16 Декабрь 2008, 18:30:15 от androidoff »

Оффлайн androidoff

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
В общем нашел лечение проблемы, сработало, но наполовину и с точностью до наоборот. Теперь при подключении отображается экран приветствия, нормально идет попытка входа, но как только вход осуществлен - система тебя выбрасывает. Если залогинится локально, и потом попробовать зайти - все отлично, как и в при использовании vino. В общем рассказываю что делал:
Для начала отключаем Desktop Sharing в System -> Preferences -> Remote Desktop. Потом идем в Synaptics и накатываем вместо vino - X11vnc, т.е. удаляем первый и ставим второй.
Теперь открываем консольку и пишем:

sudo x11vnc -storepasswd DER_PAROL /etc/x11vnc.pass где DER_PAROL - ваш пароль запрашиваемый VNC на подключение.

Дальше, добавляем в файлик

sudo gedit /etc/gdm/Init/Default следующие строчки:

/usr/bin/x11vnc -rfbauth /etc/x11vnc.pass -o /tmp/x11vnc.log -forever -bg -rfbport 5900 естественно порт можно выставить по своему вкусу...

И вот тут самое интересное, накопал в инете, что для того что бы система не закрывала за нами сеанс, следует поправить файлик: sudo gedit /etc/gdm/gdm.conf-custom добавив в него строчку: KillInitClients=falseПо идее эта строчка ключевая и должна решать проблему и с "выкидышами", но почему-то не работает... Есть у кого идеи????
« Последнее редактирование: 17 Декабрь 2008, 16:07:20 от androidoff »

Оффлайн androidoff

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Ну неужели никто не настраивал VNC под убунтой????  :o

Оффлайн Belyaev Nikolay

  • Активист
  • *
  • Сообщений: 733
    • Просмотр профиля
    • моя работа- дробилки, грохота...
смотри в сторону тонких клиентов (nomachine и т.д.), это более грамотное решение. VNC нужен, когда пользователю хочешь показать что делаешь
"Сначала они вас игнорируют, потом смеются над вами, потом борются с вами, а потом вы побеждаете"
Махатма Ганди

Jetta

  • Гость
Ну неужели никто не настраивал VNC под убунтой????  :o
А так всегда врубается только когда логинишся

Оффлайн androidoff

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Решил все средствами NoMachine

Оффлайн 24pm

  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
    • СисадминВики
Как? Дайте хоть ссылки!

 

Страница сгенерирована за 0.067 секунд. Запросов: 22.