Форум русскоязычного сообщества Ubuntu


Автор Тема: Монитор определяется иксами лишь после нескольких перезагрузок оных  (Прочитано 1148 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн slava192

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Проблема состоит в следующем:
Монитор, подсоединен через DVI к видеокарте ATI RX1300 td256e, на компе установлена Ubuntu 8.04.
При загрузке все идет нормально, до того момента, когда должно появиться окно входа в систему.
А оно не появляется.
Монитор говорит "No input signal".
Остальное оборудование определяется правильно - колонки звучат, на клавиатуру комп реагирует.
Решается проблема несколькими перезагрузками иксов (Ctrl+Alt+Backspace), причем определяется
монитор только после третьей - четвертой перезагрузки.
Подскажите, пожалуйста, как сделать, чтобы монитор определялся сразу.

Оффлайн Stiff

  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Монитор определяется в безопасном режиме?
если да, то проблема с настройкой xorg или драйвером видеокарты

Оффлайн slava192

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Монитор в безопасном режиме определяется.
Но за прошедший день появился новый баг.
В систему можно зайти по-нормальному, но не загружаются никакие элементы рабочего стола.
Весь экран становится светлого цвета, примерно как цвет этого форума)
Реагирует только на Ctrl+Alt+Backspace, показывает на секунду фоновый рисунок, и перезапускает иксы.
Думаю, что пора переустановить Ubuntu. Это сообщение пишу из под винды.
Может есть какой-то другой путь решить эти многочисленные проблемы?


Оффлайн fenist

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Такое ощущение что слетели все настройки иксов. После чего началось? Может ты систему обновлял или еще что...

По факту: вывались в консоль (Ctrl+Alt+F1 - F6) и посмотри что есть в /etc/X11/xorg.conf (cat /etc/X11/xorg.conf | grep -v '#') b запость на форум - пригодится.
Еще - посмотри /var/log/Xorg.0.log на предмет error ов, может там чтото тривиальное. Сделай /etc/init.d/./gdm stop ( или kdm stop - если кеды) и запусти иксы руками - просто startx - если загрузится нормально, то все хорошо. Попробуй переставить свой DE (apt-get'ом) - чтобы он восстановил конфиги.

Оффлайн slava192

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Содержимое xorg.conf:
(Нажмите, чтобы показать/скрыть)

Ошибки в файле /var/log/Xorg.0.log - имеется одна-единственная ошибка:
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] disabling DRI
Может, какой-то косяк в драйвере видеокарты?

Иксы руками не запускаются, точнее после остановки gdm при попытке startx
он выдает следующее:

(Нажмите, чтобы показать/скрыть)

Вообще вся ситуация выглядит так, как будто слетели какие-то конфиги в иксах.
В сеанс можно войти по-нормальному, но по прежнему большинство элементов рабочего
стола не отображаются. Хотя некоторые отображаются: resizing (в области панелей), выделение,
кнопка выхода из сеанса (удается выйти из сеанса "вслепую"),
один раз даже нормально заработала Tilda.

Насчет переустановки DE: я тут на форуме читал, что проще переставить систему.

Наверно неприятности начались после того как я установил вот эту тему:
http://www.gnome-look.org/content/show.php/Clear+Night+(Desktop+Panel+Settings)?content=91130

Вот, что там сказано насчет установки:

Extract that directory (.gconf) into your home directory and log out and back in.
Or, from a terminal, in the folder where you downloaded the tar file to:
tar xf 91130-Desktop\ Settings.tar.gz ~

Таким образом я выполнил следующую строчку:
sudo tar xf 91130-Desktop\ Settings.tar.gz ~

Результата желаемого я не достиг (изменилась только нижняя панелька и все) ну и забил на установку темы.
Скорее всего это причина глюков иксов.
Что теперь делать? Систему переустанавливать?
« Последнее редактирование: 04 Января 2009, 13:03:16 от slava192 »

Оффлайн fenist

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
То что при остановленом gdm startx говорит что дисплей занят икс сервером - это странный косяк. Попробуй в ps -A -X поискать икс-сервер. Если что - прибей его и попробуй запустить startx.
Есть мета-пакеты типа xubuntu-desktop, kubuntu-desktop, gnome-desktop-environment. Они потянут за собой все необходимое окружение. Попробуй поставить к примеру кеды (просто apt-get install kubuntu-desktop), из него попробовать чтонть сделать с гномом. У меня ощущение что попытки поставить тему навернули вхлам настройки gtk. (конфиги иксов в порядке, иначе иксы не стартовалибы)

Цитировать
Насчет переустановки DE: я тут на форуме читал, что проще переставить систему.

Ну может быть переустановить и проще чем понять как все починить ручками. А если переустановить и настроить под себя то что годы затачивалось? К тому же - бесценный опыт. Я бы чинил.

Еще - у тебя в xorg.conf не указывается какой драйвер для видюхи загружать. Допиши строчечку
« Последнее редактирование: 30 Декабря 2008, 16:02:46 от fenist »

Оффлайн slava192

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Насчет драйвера видеокарты - проблема решалась очень просто.
Достаточно было просто включить проприетарный драйвер ati  (странно, что он был не включен,
вроде я его включал после установки драйвера с помощью Envy).
Сразу xorg.conf принял следующий вид:
(Нажмите, чтобы показать/скрыть)
Исчезла ошибка в /var/log/Xorg.0.log 
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI
- теперь ее нет,
т.е. DRI заработал и теперь 3д графика просто летает.

Насчет восстановления gnome: все та же ошибка - не загружаются элементы рабочего стола и экран
становится светло-серого цвета подо всеми полльзователями.
Сейчас попробую переставить gnome...

При попытке установить gnome-desktop-environment:
(Нажмите, чтобы показать/скрыть)

Но пакет gnome-keyring-manager доступен тольео для ubuntu 7.10 или меньше, а для Харди нету.
Что делать?

И еще лаг - если комп простоит долго без всякой активности со стороны пользователя, то после
этого он отображает тольку курсор на черном экране, и приходится нажимать Ctrl+Alt+Backspace,
и после перевхода в систему все работает нормально (под Xfce).
« Последнее редактирование: 04 Января 2009, 13:01:53 от slava192 »

 

Страница сгенерирована за 0.045 секунд. Запросов: 23.