Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: не работеат переключение на англ язык  (Прочитано 1007 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн yuri89

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
  • Юрий
    • Просмотр профиля
при входе в систему Ubuntu 8.04 там где нужно ввести имя пользователя и пароль не могу переключиться на английский язык, только на русском пишет, следовательно и войти не получается....что делать?

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: не работеат переключение на англ язык
« Ответ #1 : 15 Январь 2009, 13:28:23 »
Достало уже, в поиск.

Народ, вопрос возникает довольно часто, никто не пытался воспроизвести, после чего слетают настройки?
У себя подобного ни разу не наблюдал.

Соответственно, вопрос к страждущему: что делал перед тем, как настройки слетели?

Оффлайн yuri89

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
  • Юрий
    • Просмотр профиля
Re: не работеат переключение на англ язык
« Ответ #2 : 15 Январь 2009, 13:31:31 »
после команды dpkg-reconfigure xserver-xorg -phigh в сингл моде, монитор не включался в обычном режиме

Villain

  • Гость
Re: не работеат переключение на англ язык
« Ответ #3 : 15 Январь 2009, 13:34:06 »
Нажать
alt+ctrl+f1Ввести
sudo nano /etc/X11/xorg.confПрописать в нем что-то типа этого
Section "InputDevice"
Identifier   "Generic Keyboard"
Driver "kbd"
Option "XkbRules"  "xorg"
Option "XkbModel"  "pc105"
Option "XkbLayout"  "us,ru"
Option "XkbVariant"  ",winkeys"
Option "XkbOptions"  "grp:alt_shift_toggle"
EndSection
Затем ввести
sudo rebootДолжно помочь

Оффлайн Belyaev Nikolay

  • Активист
  • *
  • Сообщений: 734
    • Просмотр профиля
    • моя работа- дробилки, грохота...
Re: не работеат переключение на англ язык
« Ответ #4 : 15 Январь 2009, 14:02:53 »
после команды dpkg-reconfigure xserver-xorg -phigh в сингл моде, монитор не включался в обычном режиме
востанови предыдущий хорг лежит в /etc/X11/
"Сначала они вас игнорируют, потом смеются над вами, потом борются с вами, а потом вы побеждаете"
Махатма Ганди

Оффлайн yuri89

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
  • Юрий
    • Просмотр профиля
Re: не работеат переключение на англ язык
« Ответ #5 : 15 Январь 2009, 14:36:42 »
Нажать
alt+ctrl+f1Ввести
sudo nano /etc/X11/xorg.confПрописать в нем что-то типа этого
Section "InputDevice"
Identifier   "Generic Keyboard"
Driver "kbd"
Option "XkbRules"  "xorg"
Option "XkbModel"  "pc105"
Option "XkbLayout"  "us,ru"
Option "XkbVariant"  ",winkeys"
Option "XkbOptions"  "grp:alt_shift_toggle"
EndSection
Затем ввести
sudo rebootДолжно помочь
дошел до предпоследнего этапа, ввел EndSection, а дальше то что делать?там внизу я видел обозначения, но они на русском и меня половину из этих букв отображается значками разными непонятными, что нажать надо чтобы сохранить это все дело и опять попасть в ком строку?

Villain

  • Гость
Re: не работеат переключение на англ язык
« Ответ #6 : 15 Январь 2009, 14:41:32 »
ctrl+o (английская о) для сохранения (если не ошибаюсь, то в nano именно так)
ctrl+x (английская икс) для выхода

ЗЫ консоль русифицировать надо, чтоб русские буквы показывались

Оффлайн yuri89

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
  • Юрий
    • Просмотр профиля
Re: не работеат переключение на англ язык
« Ответ #7 : 15 Январь 2009, 14:43:14 »
значит получается и то и другое по очереди нажать надо?

 :)а как ее русифицировать?)

Villain

  • Гость
Re: не работеат переключение на англ язык
« Ответ #8 : 15 Январь 2009, 14:45:14 »
Сначала сохранить, а потом выйти из редактора...

ЗЫ. Русификация консоли

Оффлайн yuri89

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
  • Юрий
    • Просмотр профиля
Re: не работеат переключение на англ язык
« Ответ #9 : 15 Январь 2009, 16:23:52 »
ну вообще ничего не получается, чтож такое....русификация не получается потому что я не могу войти даже в систему, а без русифик не могу сохранить там inputdevice..замкнутый круг, как поступить то можно??

Оффлайн Belyaev Nikolay

  • Активист
  • *
  • Сообщений: 734
    • Просмотр профиля
    • моя работа- дробилки, грохота...
Re: не работеат переключение на англ язык
« Ответ #10 : 15 Январь 2009, 16:36:51 »
а в сингл моде? тама же консоль работает и можно руссифицировать в чём трабла?
и нафига тебе русские буквы чтобы конфиги править?
"Сначала они вас игнорируют, потом смеются над вами, потом борются с вами, а потом вы побеждаете"
Махатма Ганди

Оффлайн yuri89

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
  • Юрий
    • Просмотр профиля
Re: не работеат переключение на англ язык
« Ответ #11 : 15 Январь 2009, 16:41:15 »
а я не могу их править, потому что не получается сохранить, жму ctrl+o а он еще чето мне пишет, чет ввести надо, и не видно что....ввожу наугад он пишет что-то про количество строк насколько я понял, и дальше все повторяется..

Оффлайн yuri89

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
  • Юрий
    • Просмотр профиля
Re: не работеат переключение на англ язык
« Ответ #12 : 15 Январь 2009, 16:48:07 »
а как ты говоришь можно восстановить предыдущий xorg??? может так получиться

Оффлайн wl

  • Старожил
  • *
  • Сообщений: 1393
    • Просмотр профиля
Re: не работеат переключение на англ язык
« Ответ #13 : 15 Январь 2009, 17:23:33 »
найти в /etc/X11 файл с именем xorg.conf.что_то_там_еще и переименовать его в xorg.conf
На свете феньки есть такие, брат Горацио, которых лохи просто не секут. (Шекспир, "Гамлет", вольный перевод)

Оффлайн yuri89

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
  • Юрий
    • Просмотр профиля
Re: не работеат переключение на англ язык
« Ответ #14 : 15 Январь 2009, 17:38:56 »
подскажи плиз команды по которым это можно сделать, я не могу войти в систему

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.