Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: apt-get install  (Прочитано 5510 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Toryfavel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
apt-get install
« : 15 Январь 2009, 13:56:37 »
root@web:/cdrom/deb# apt-get install webmin_1.441_all.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package webmin_1.441_all.deb
 

Почему так??? Это Ubuntu server 8.04

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: apt-get install
« Ответ #1 : 15 Январь 2009, 13:58:17 »
Потому что man dpkg

Кстати, у gdebi есть консольный фронт-энд, оно в серверной реинкарнации Ubuntu по умолчанию не стоит, случаем?

Villain

  • Гость
Re: apt-get install
« Ответ #2 : 15 Январь 2009, 13:58:44 »
Потому что
dpkg -i webmin_1.441_all.deb

Оффлайн Toryfavel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: apt-get install
« Ответ #3 : 15 Январь 2009, 14:01:53 »
Потому что
dpkg -i webmin_1.441_all.deb


Сорри но я не такой спец в єтом! Плохо понял вопрос! :-)

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: apt-get install
« Ответ #4 : 15 Январь 2009, 14:06:49 »
dpkg -l gdebi*
Если про мой вопрос ;)

Оффлайн Toryfavel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: apt-get install
« Ответ #5 : 15 Январь 2009, 14:08:09 »
root@web:/cdrom/deb# dpkg -i webmin_1.410_all.deb
Selecting previously deselected package webmin.
(Reading database ... 20655 files and directories currently installed.)
Unpacking webmin (from webmin_1.410_all.deb) ...
dpkg: dependency problems prevent configuration of webmin:
 webmin depends on libnet-ssleay-perl; however:
  Package libnet-ssleay-perl is not installed.
 webmin depends on libauthen-pam-perl; however:
  Package libauthen-pam-perl is not installed.
 webmin depends on libio-pty-perl; however:
  Package libio-pty-perl is not installed.
 webmin depends on libmd5-perl; however:
  Package libmd5-perl is not installed.
dpkg: error processing webmin (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 webmin
Вот ещо проблемка! Єто как я понял не хватает пакетов для установки webmin ?

Villain

  • Гость
Re: apt-get install
« Ответ #6 : 15 Январь 2009, 14:36:24 »
Он даже написал, чего не хватает (libnet-ssleay-perl, libauthen-pam-perl, libio-pty-perl, libmd5-perl)

Оффлайн slaviart

  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: apt-get install
« Ответ #7 : 15 Январь 2009, 14:36:31 »
sudo apt-get install libnet-ssleay-perl,libauthen-pam-perl,libio-pty-perl,libmd5-perl

Villain

  • Гость
Re: apt-get install
« Ответ #8 : 15 Январь 2009, 14:38:33 »
sudo apt-get install libnet-ssleay-perl,libauthen-pam-perl,libio-pty-perl,libmd5-perl
Запятые не нужны - через пробел все пишется

Оффлайн Toryfavel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: apt-get install
« Ответ #9 : 15 Январь 2009, 14:57:42 »
Но ети пакеты тоже нужно скачать да? А если apt-get install update посли єтого они не появляются?

Villain

  • Гость
Re: apt-get install
« Ответ #10 : 15 Январь 2009, 15:01:06 »
Они только так появятся:
sudo apt-get install libnet-ssleay-perl libauthen-pam-perl libio-pty-perl libmd5-perl

Оффлайн Toryfavel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: apt-get install
« Ответ #11 : 15 Январь 2009, 15:16:11 »
Спасибо мужики! :-) Всё установилось. А как теперь єтот webmin в браузере открыть? https://10.177.0.177:1000 так? Что-то не выходит. :(

Оффлайн Toryfavel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: apt-get install
« Ответ #12 : 15 Январь 2009, 15:22:01 »
Спасибо ещо раз! Уже зашёл!  :D

Оффлайн Toryfavel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: apt-get install
« Ответ #13 : 15 Январь 2009, 15:27:34 »
А как webmin на русский перевести?

Villain

  • Гость
Re: apt-get install
« Ответ #14 : 15 Январь 2009, 15:37:26 »
никак :) по-крайней мере на офсайте ничего о локализациях нет


------------------------------------------------------------------------------------------
Добавлено позже
------------------------------------------------------------------------------------------
Ошибся...есть на webmin.com что-то про локализацию... почитай там внимательней
« Последнее редактирование: 15 Январь 2009, 15:45:33 от Villain »

 

Страница сгенерирована за 0.054 секунд. Запросов: 23.