Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Установка FireBird  (Прочитано 5004 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн chef

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Установка FireBird
« : 16 Январь 2009, 14:39:29 »
root@local-server-f:/opt/firebird/bin# sudo aptitude install firebird2.0-super
sudo: cannot get working directory
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Reading extended state information                                     
Initializing package states... Готово
The following packages are BROKEN:
  firebird2.1-common firebird2.1-super
The following NEW packages will be installed:
  firebird2.0-common{a} firebird2.0-server-common{a} firebird2.0-super
The following partially installed packages will be configured:
  firebird2.1-server-common libfbembed2.1
0 packages upgraded, 3 newly installed, 0 to remove and 197 not upgraded.
Need to get 4214kB of archives. After unpacking 10,0MB will be used.
The following packages have unmet dependencies:
  firebird2.1-common: Конфликтует: firebird2.0-common but 2.0.4.13130-1.ds1-2 is to be installed.
  firebird2.1-super: Конфликтует: firebird2.0-super but 2.0.4.13130-1.ds1-2 is to be installed.
The following actions will resolve these dependencies:

Remove the following packages:
firebird2.1-super
libfbembed2.1

Downgrade the following packages:
firebird2.1-common [2.1.1.17910-release.ds1-2ubuntu2 (<NULL>, now) -> 2.1.0.17798-0.ds2-1 (intrepid)]
libfbclient2 [2.1.1.17910-release.ds1-2ubuntu2 (<NULL>, now) -> 2.1.0.17798-0.ds2-1 (intrepid)]

Score is 248

Accept this solution? [Y/n/q/?] y
The following packages will be DOWNGRADED:
  firebird2.1-common libfbclient2
The following NEW packages will be installed:
  firebird2.0-common{a} firebird2.0-server-common{a} firebird2.0-super
The following packages will be REMOVED:
  firebird2.1-server-common{u} firebird2.1-super{a} libfbembed2.1{a}
0 packages upgraded, 3 newly installed, 2 downgraded, 3 to remove and 197 not upgraded.
Need to get 5154kB/5901kB of archives. After unpacking 4764kB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Готово
Get:1 http://ru.archive.ubuntu.com intrepid/universe firebird2.1-common 2.1.0.17798-0.ds2-1 [940kB]
Get:2 http://ru.archive.ubuntu.com intrepid/universe firebird2.0-common 2.0.4.13130-1.ds1-2 [783kB]                                                         
Get:3 http://ru.archive.ubuntu.com intrepid/universe firebird2.0-server-common 2.0.4.13130-1.ds1-2 [511kB]                                                   
Get:4 http://ru.archive.ubuntu.com intrepid/universe firebird2.0-super 2.0.4.13130-1.ds1-2 [2920kB]                                                         
Fetched 5154kB in 3min3s (28,1kB/s)                                                                                                                         
Предварительная настройка пакетов ...
(Чтение базы данных... на данный момент установлено 104458 файлов и каталогов.)
Удаляется пакет libfbembed2.1...
Удаляется пакет firebird2.1-super...
Удаляется пакет firebird2.1-server-common...
Обрабатываются триггеры для libc6 ...
ldconfig deferred processing now taking place
Обрабатываются триггеры для man-db ...
dpkg: предупреждение -- снижение версии libfbclient2 с 2.1.1.17910-release.ds1-2ubuntu2 до 2.1.0.17798-0.ds2-1.
(Чтение базы данных... на данный момент установлено 104384 файлов и каталогов.)
Подготовка к замене пакета libfbclient2 2.1.1.17910-release.ds1-2ubuntu2 (используется файл .../libfbclient2_2.1.0.17798-0.ds2-1_i386.deb)...
Распаковывается замена для пакета libfbclient2 ...
dpkg: предупреждение -- снижение версии firebird2.1-common с 2.1.1.17910-release.ds1-2ubuntu2 до 2.1.0.17798-0.ds2-1.
Подготовка к замене пакета firebird2.1-common 2.1.1.17910-release.ds1-2ubuntu2 (используется файл .../firebird2.1-common_2.1.0.17798-0.ds2-1_i386.deb)...
Распаковывается замена для пакета firebird2.1-common ...
Выбор ранее не выбранного пакета firebird2.0-common.
Распаковывается пакет firebird2.0-common (из файла .../firebird2.0-common_2.0.4.13130-1.ds1-2_i386.deb)...
Выбор ранее не выбранного пакета firebird2.0-server-common.
Распаковывается пакет firebird2.0-server-common (из файла .../firebird2.0-server-common_2.0.4.13130-1.ds1-2_i386.deb)...
Выбор ранее не выбранного пакета firebird2.0-super.
Распаковывается пакет firebird2.0-super (из файла .../firebird2.0-super_2.0.4.13130-1.ds1-2_i386.deb)...
Обрабатываются триггеры для man-db ...
Настраивается пакет firebird2.1-common (2.1.0.17798-0.ds2-1) ...
Устанавливается новая версия файла конфигурации /etc/firebird/2.1/firebird.conf ...
Настраивается пакет libfbclient2 (2.1.0.17798-0.ds2-1) ...

Настраивается пакет firebird2.0-common (2.0.4.13130-1.ds1-2) ...
Настраивается пакет firebird2.0-server-common (2.0.4.13130-1.ds1-2) ...
dpkg: не удалось обработать параметр firebird2.0-server-common (--configure):
 подпроцесс post-installation script возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет firebird2.0-super:
 firebird2.0-super зависит от firebird2.0-server-common (= 2.0.4.13130-1.ds1-2), однако:
  Пакет firebird2.0-server-common пока не настроен.
dpkg: не удалось обработать параметр firebird2.0-super (--configure):
 проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для libc6 ...
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          ldconfig deferred processing now taking place
При обработке следующих пакетов произошли ошибки:
 firebird2.0-server-common
 firebird2.0-super
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Настраивается пакет firebird2.0-server-common (2.0.4.13130-1.ds1-2) ...
dpkg: не удалось обработать параметр firebird2.0-server-common (--configure):
 подпроцесс post-installation script возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет firebird2.0-super:
 firebird2.0-super зависит от firebird2.0-server-common (= 2.0.4.13130-1.ds1-2), однако:
  Пакет firebird2.0-server-common пока не настроен.
dpkg: не удалось обработать параметр firebird2.0-super (--configure):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 firebird2.0-server-common
 firebird2.0-super
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Reading extended state information                                     
Initializing package states... Готово
Writing extended state information... Готово

Вот лог установки.... что скажете по этому поводу.. Стоит Ubuntu 8.10
Тут был не помогло http://kubuntu.ru/node/2882

Оффлайн vadim-nsk

  • LoCo команда
  • Старожил
  • *
  • Сообщений: 1318
  • Жить надо так, как горит пламя!
    • Просмотр профиля
    • Linux в Новосибирске
Re: Установка FireBird
« Ответ #1 : 18 Январь 2009, 17:40:09 »
ну так зачем firebird2.0-super ставить, а не firebird2.1-super

Оффлайн chef

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Установка FireBird
« Ответ #2 : 18 Январь 2009, 22:08:00 »
Поверь пробовал уже все и 2.1 и все покеты по отдельности и все связи проверил все есть а на это машине ни в какую.
Есть вопрос а ни че если там стоит Веб сервер (Апач + ПХП + Мускул) ?????

Потому что на другой машине стало с первого раза.


Оффлайн vadim-nsk

  • LoCo команда
  • Старожил
  • *
  • Сообщений: 1318
  • Жить надо так, как горит пламя!
    • Просмотр профиля
    • Linux в Новосибирске
Re: Установка FireBird
« Ответ #3 : 18 Январь 2009, 22:17:41 »
давай так попробуем:

aptitude install firebird2.0-super firebird2.0-common libeditline0 libfbclient2

Оффлайн chef

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Установка FireBird
« Ответ #4 : 19 Январь 2009, 17:19:17 »
давай так попробуем:

aptitude install firebird2.0-super firebird2.0-common libeditline0 libfbclient2

Он их в логах устанавливает, и говорит после установки что такие пакеты есть.... Серв подымалься только ради FireBird. Ничего на нем еще не было пому я снес его, поставил заново и о чудо ! Все заработало.... я так думаю что это системы косяк был.

Оффлайн HappyCaspeR

  • Новичок
  • *
  • Сообщений: 6
  • Изнасилую мозг, но установлю!
    • Просмотр профиля
Re: Установка FireBird
« Ответ #5 : 15 Сентябрь 2009, 15:26:42 »
Простите, что сорю в Вашей теме, но подскажите в какую сторону копать: установил firebird2.1-super, с винды через IB Expert могу подключиться к базе, а вот IB console не хочет проводить прямое подключение, когда тесты все проходят на ура, да и в режиме SQL-запросов подключение происходит посредствами того же IB Console.

Под виндой работала FireBird, используя 2 дополнительных файла: fbintl2 & ush_udf.
кинул их в /etc/firebird/2.1/ изменил права доступа на root...      (кинул те, которые сказали что будут в линуксе работать, а не с винды  :coolsmiley:)

Как их правильно привентить в СУБД... Подскажите пожалуйста! :-\
« Последнее редактирование: 15 Сентябрь 2009, 15:32:08 от HappyCaspeR »
И каждый раз кидая камень в воду мы попадаем точно в центр круга...

 

Страница сгенерирована за 0.055 секунд. Запросов: 22.