Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Помогите установить pbeagent**.rpm  (Прочитано 3166 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dmsergei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Помогите установить pbeagent**.rpm
« : 16 Январь 2009, 15:48:27 »
Собственно управление ИБП АРС - вышла новая версия.
Хотя и старую тоже не получаеться установить
Вот собственно что получаеться:

sudo rpm -i  /home/dmsergei/PBSE801/Linux/pbeagent-8.0.1-609.i386.rpm

ошибка: Неудовлетворенные зависимости:
/bin/sh нужен для pbeagent   8.0.1   609.i386
ld   linux.so.2 нужен для pbeagent   8.0.1   609.i386
libc.so.6 нужен для pbeagent   8.0.1   609.i386
libc.so.6(GLIBC_2.0) нужен для pbeagent   8.0.1   609.i386
libc.so.6(GLIBC_2.1) нужен для pbeagent   8.0.1   609.i386
libc.so.6(GLIBC_2.1.3) нужен для pbeagent   8.0.1   609.i386

Хотя все библиотеки и файлы ЕСТЬ ?! :-[

Оффлайн timur73_73

  • Активист
  • *
  • Сообщений: 634
  • йа
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #1 : 16 Январь 2009, 16:05:07 »
а разве rpm -i в ubuntu работает? А что если попробовать alien-ом из rpm сделать deb?
Runtu 14.04.2 LTS х64, XFCE 4, 2x Intel(R) Core(TM)2 Duo CPU E6550 2.33GHz, RAM 4Gb, GeForce 210/PCIe/SSE2 512Mb

Оффлайн dmsergei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #2 : 16 Январь 2009, 16:29:19 »
а разве rpm -i в ubuntu работает? А что если попробовать alien-ом из rpm сделать deb?

sudo alien -d /home/dmsergei/PBSE801/pbeagent-8.0.1-609.i386.rpm --scripts
pbeagent_8.0.1-610_i386.deb generated

Конвертится без ошибок
Но при установке зависает-- на настройка пакета !

Оффлайн timur73_73

  • Активист
  • *
  • Сообщений: 634
  • йа
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #3 : 16 Январь 2009, 17:13:33 »
А в окне "подробно" (или в коносоле) что пишет в этот момент?
Runtu 14.04.2 LTS х64, XFCE 4, 2x Intel(R) Core(TM)2 Duo CPU E6550 2.33GHz, RAM 4Gb, GeForce 210/PCIe/SSE2 512Mb

Оффлайн Andrew Addams

  • Активист
  • *
  • Сообщений: 314
  • Да, да... Это я на аватарке.
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #4 : 16 Январь 2009, 17:35:06 »
Так написано же:

ошибка: Неудовлетворенные зависимости:
Ясен перец, что переделанный rpm практически всегда выдаёт подобные проблемы, т.к. это костыль по сути своей. ???
Либо deb ищи, либо собирай из исходников.
Мы с удовольствием пожираем тех, кто пытается нас поработить...

Оффлайн dmsergei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #5 : 16 Январь 2009, 17:38:03 »
А в окне "подробно" (или в коносоле) что пишет в этот момент?


sudo dpkg    i /home/dmsergei/pbeagent_8.0.1   610_i386.deb
(Чтение базы данных... на данный момент установлено 159214 файлов и каталогов.)
Подготовка к замене пакета pbeagent 8.0.1   610 (используется файл .../pbeagent_8.0.1   610_i386.Распаковывается замена для пакета pbeagent ...
Настраивается пакет pbeagent (8.0.1   610) ...

И всё ПОВИСОН --CTRl-C:

dpkg: не удалось обработать параметр pbeagent (      install):
подпроцесс post   installation script убит по сигналу (Interrupt)
При обработке следующих пакетов произошли ошибки:
pbeagent
dmsergei@dmsergei   desktop:~$

Оффлайн dmsergei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #6 : 16 Январь 2009, 17:43:12 »
Так написано же:

ошибка: Неудовлетворенные зависимости:
Ясен перец, что переделанный rpm практически всегда выдаёт подобные проблемы, т.к. это костыль по сути своей. ???
Либо deb ищи, либо собирай из исходников.

Исходников НЕт !!!
Есть этот RPM и ещё BIN для SOLARIS !
Есть BIN предыдущей версии -- ставиться почти без проблемм , а вот RPM предыдущей версии тоже не ставиться !

Оффлайн timur73_73

  • Активист
  • *
  • Сообщений: 634
  • йа
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #7 : 16 Январь 2009, 19:51:32 »
Вообще-то была какая-то прога под кеды типа синаптика, которая ставила напрямую rpm-пакеты без конвертации alien-ом, тока не помню какая
Runtu 14.04.2 LTS х64, XFCE 4, 2x Intel(R) Core(TM)2 Duo CPU E6550 2.33GHz, RAM 4Gb, GeForce 210/PCIe/SSE2 512Mb

Оффлайн dmsergei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #8 : 17 Январь 2009, 09:47:20 »
Вообще-то была какая-то прога под кеды типа синаптика, которая ставила напрямую rpm-пакеты без конвертации alien-ом, тока не помню какая

Было бы интересно попробовать  8)

Оффлайн dmsergei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #9 : 21 Январь 2009, 16:01:28 »
Ну как ЖЕ всётаки это дело установить ?
Прошу помощи !!!

Оффлайн timur73_73

  • Активист
  • *
  • Сообщений: 634
  • йа
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #10 : 21 Январь 2009, 16:34:04 »
а если просмотреть rpm пакет менеджером архивов, мне казалось что они похожи по структуре на tar.gz, распаковать в директорию (если там есть файлы make) и попробовать собрать как из исходников. Может я написал глупость и где-то не прав, но помочь хочется, а проверить сейчас свою идею не могу, т.к.. комп с убунтой на ремонте :(
Runtu 14.04.2 LTS х64, XFCE 4, 2x Intel(R) Core(TM)2 Duo CPU E6550 2.33GHz, RAM 4Gb, GeForce 210/PCIe/SSE2 512Mb

Оффлайн dmsergei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #11 : 21 Январь 2009, 18:34:35 »
А вот ответ APC по поводу предоставить в другом формате или исходники :

К сожалению, указанные форматы новой версией PowerChute Business edition не поддерживаются. Вы можете использовать сторонние программы для конвертирования пакетов. На форумах есть информация о пакете под названием Alien, который может решить данную проблему. Дополнительной информацией о нем, к сожалению, мы не располагаем.
Спасибо!

С уважением,
Специалист центра поддержки клиентов
Павел Менахин.

 :(
Хотя предыдущую версию они выкладывали в ***.BIN - и она ставиться  :-\

Оффлайн dmsergei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #12 : 22 Январь 2009, 00:32:53 »
а если просмотреть rpm пакет менеджером архивов, мне казалось что они похожи по структуре на tar.gz, распаковать в директорию (если там есть файлы make) и попробовать собрать как из исходников. Может я написал глупость и где-то не прав, но помочь хочется, а проверить сейчас свою идею не могу, т.к.. комп с убунтой на ремонте :(

Распокавал !!!
Много маленьких файлов и большой BIN ? :idiot2:
Как быть дальше ?

Оффлайн timur73_73

  • Активист
  • *
  • Сообщений: 634
  • йа
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #13 : 22 Январь 2009, 12:10:30 »
а фалов с названием config и make нету? Если есть, то по-идее, как обычно компилируются config затем   make и затем make-install (имхо)
Runtu 14.04.2 LTS х64, XFCE 4, 2x Intel(R) Core(TM)2 Duo CPU E6550 2.33GHz, RAM 4Gb, GeForce 210/PCIe/SSE2 512Mb

Оффлайн dmsergei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Помогите установить pbeagent**.rpm
« Ответ #14 : 22 Январь 2009, 14:41:29 »
а фалов с названием config и make нету? Если есть, то по-идее, как обычно компилируются config затем   make и затем make-install (имхо)

Ни тех ни других файлов НЕТ  :-\

Может в "сборку пакетов" обратиться . :'(

 

Страница сгенерирована за 0.06 секунд. Запросов: 22.