Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Интеграция qt4 и eclipse [Решено!]  (Прочитано 2361 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Stiff

  • Автор темы
  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Интеграция qt4 и eclipse [Решено!]
« : 16 Январь 2009, 17:35:55 »
Подскажите, кто использует связку qt4 + eclipse, какие версии используете?
Установил eclipse и пакет интеграции по след. ссылкам
http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/ganymede/SR1/eclipse-cpp-ganymede-SR1-linux-gtk.tar.gz
http://www.qtsoftware.com/developer/eclipse-integration
Но интеграция работает как-то криво, нельзя использовать дизайнер форм, пуст qt widget toolbox (см. скриншот)
версия qt 4.4.3, установлен отсюда deb http://ppa.launchpad.net/mscore-ubuntu/ubuntu hardy main
« Последнее редактирование: 20 Январь 2009, 01:51:55 от Stiff »

Оффлайн Stiff

  • Автор темы
  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Re: Интеграция qt4 и eclipse
« Ответ #1 : 16 Январь 2009, 17:36:29 »
скриншот

Оффлайн EuroElessar

  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Интеграция qt4 и eclipse
« Ответ #2 : 19 Январь 2009, 15:43:46 »
может стоит попробовать QtCreator для программирования на Qt?.. я у eclipse часто замечал глюки при работе с Qt, и так же часто он у меня падал..
Gentoo ~x86
qutIM Core/Jabber Developer

Aceler

  • Гость
Re: Интеграция qt4 и eclipse
« Ответ #3 : 19 Январь 2009, 23:14:07 »
Ты путь к библиотекам Qt-то указал?

Оффлайн Stiff

  • Автор темы
  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Re: Интеграция qt4 и eclipse
« Ответ #4 : 20 Январь 2009, 00:31:03 »
В eclipse указал /usr/share/qt4/bin и /usr/share/qt4/include, таам где версия qt указывается (4.4.3)
Так же пробовал версию с репозатория, она глючит немного по-другому, но тоже что-то не в порядке.

Оффлайн Stiff

  • Автор темы
  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Re: Интеграция qt4 и eclipse
« Ответ #5 : 20 Январь 2009, 00:31:30 »
Самое обидное то, что под виндой та же связка работает хорошо

Оффлайн Stiff

  • Автор темы
  • Активист
  • *
  • Сообщений: 677
    • Просмотр профиля
Re: Интеграция qt4 и eclipse
« Ответ #6 : 20 Январь 2009, 01:51:40 »
УРА! :D Решение найдено!
Решил попробовать собрать пакет интеграции с исходников. В readme к нему был следующий текст:
Цитировать
FAQ
---
Q) Building and installing the Qt Eclipse Integration worked,
   but when I open e.g. a ".ui" file or a ".pro" file in an editor
   all I see is an empty tab where the editor should show.
A) This happens if Qt is configured without glib support. Make sure that
   glib support is compiled into your Qt installation (if you build
   Qt yourself, install the glib development headers before configuring
   Qt).
Тут я вспомнил, что для нормальной работы qutim я вносил переменную QT_NO_GLIB в /etc/profile.
После того, как я её убрал, всё стало нормально.

 

Страница сгенерирована за 0.052 секунд. Запросов: 24.