Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Ручная настройка (через файлы) прокси в Ubuntu 8.10  (Прочитано 88353 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hogofogo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Подскажите, в каких файлах хранятся настройки proxy.
Сам знаю только /etc/apt/apt.conf

У меня настройка параметров в synaptic виснет, там указать не могу, а в системе где-то засели настройки прокси с работы, которые берет apt-get update.

В-общем, как руками найти и убить настройки прокси.
« Последнее редактирование: 23 Январь 2009, 15:02:42 от hogofogo »

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: Настройка прокси в Ubuntu 8.10
« Ответ #1 : 23 Январь 2009, 13:18:30 »
Система - Параметры - Сервис прокси

Оффлайн hogofogo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: Настройка прокси в Ubuntu 8.10
« Ответ #2 : 23 Январь 2009, 13:27:21 »
Конечно же, там я пробовал тоже. Проблема в том, что synaptic и установка приложений эти параметры не читают. У меня где-то в системе засели настройки от старых прокси и не хотят выковыриваться.
Вот что выдает apt-get update:
root@hogofogo:~# apt-get update
0% [Соединение с 192.168.1.1 (192.168.1.1)] [Соединение с 192.168.1.1 (192.168.1.1)]

При этом в настройках у меня нет прокси, и по смыслу его быть не должно.
« Последнее редактирование: 23 Январь 2009, 14:23:24 от hogofogo »

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
А если перед этим сделать
env | grep proxy

Оффлайн hogofogo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Вот что дала система:
root@hogofogo:~# env | grep proxy
http_proxy=http://192.168.1.1:3128/

Именно к нему он и пытается достучаться. Где поменять этот параметр?
« Последнее редактирование: 23 Январь 2009, 14:49:54 от hogofogo »

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
В текущем сеансе: unset http_proxy

Вообще - искать по конфигурационным файлам и настройкам, в том числе и для учётной записи суперпользователя (отдельно специально активирована?)

Оффлайн hogofogo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Сделал unset http_proxy, теперь сразу выдает

root@hogofogo:~# unset http_proxy
root@hogofogo:~# env | grep proxy
root@hogofogo:~# apt-get update
Ош  http://ru.archive.ubuntu.com intrepid Release.gpg
  Не удалось найти IP адрес для proxy
Ош  http://ru.archive.ubuntu.com intrepid/main Translation-ru
  Не удалось найти IP адрес для.....

Мне нужно, чтобы он к прокси не лез совсем. Есть параметр "прямое соединение"? И как его установить? set?

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
gnome-network-preferences
sudo gnome-network-preferences

В учётной записи root: /root/.bashrc /root/.profile
В /etc/profile /etc/bash.bashrc
В настройках apt: /etc/apt/apt.conf.d/*

Вроде всё.

Оффлайн hogofogo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
А есть параметр, который отвечает за само подключение, который можно установить командой типа set?

Оффлайн hogofogo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Создал пароль для root, разрешил локальный вход для root, зашел под ним.
Настроил "без прокси" в synaptic (так сложно потому, что еще настройки не сохранялись). Все равно лезет к проки.

В указанных файлах
Цитировать
gnome-network-preferences
sudo gnome-network-preferences

В учётной записи root: /root/.bashrc /root/.profile
В /etc/profile /etc/bash.bashrc
В настройках apt: /etc/apt/apt.conf.d/*
пусто.

Проверил под рутом прокси:
(Нажмите, чтобы показать/скрыть)

Он запомнил параметр прокси для всей системы. unset делать боюсь.

Вопрос такой - есть ли параметр "прямое соединение с сетью", который можно установить в true?
Похоже, в этом проблема.

« Последнее редактирование: 25 Январь 2009, 18:38:47 от hogofogo »

Оффлайн lampo4ka

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
у меня такая же проблема..

Оффлайн hogofogo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
у меня такая же проблема..
Если найдешь решение - напиши, плз. Очень надо.

Оффлайн drvc

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Ручная настройка (через файлы) прокси в Ubuntu 8.10
« Ответ #12 : 11 Февраль 2009, 12:25:51 »
У меня подвисал синаптик при попытке изменить сетевые настройки - решилось ручной правкой в файле /root/.synaptic/synaptic.conf необходимых параметром(у меня логин пароль на прокси менялся)

Оффлайн irkvlad

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Была такая же проблема. на ноуте стоит Ubuntu, четыре офиса с серваками в каждом свой прокси адрес, настроил на один из них, перед этим много мучился пока получилось , настраивал и через .bashrc и через apt.conf и через proxy. на остпвлял кучу пробных файлов переименовывая их , путем добавления цифр.
Потом дома попытался установить прогу апт стал просить прокси, я в эих фалх все закомментировал - так же , удалил строчки-так же ....!
исправилось только тогда когда я перенес все версии файлов с цифрами в другую папку. апт_у видимо все равно как файл называется если он лежит в каталоге его настроек и в нем содержится корректная команда то он ее исполняет

poabor

  • Гость
окружение
export http_proxy="' - убрать прокси
export http_proxy="user:pass@proxy:port/" - установить прокси

 

Страница сгенерирована за 0.053 секунд. Запросов: 22.