Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Проблема с dpkg  (Прочитано 491 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ypeskov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Проблема с dpkg
« : 30 Январь 2009, 19:13:06 »
dpkg: ../../src/packages.c:221: process_queue: Assertion `dependtry <= 4' failed.

вот такая надпись вылетает при попытках установки любых пакетов.
ни синаптик ни apt-get не работают.

появилась после очередного обновления ядра(вроде бы).

при запуске синаптика вылетает следующая ошибка:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.


куда копать?
« Последнее редактирование: 30 Январь 2009, 19:15:30 от ypeskov »

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: Проблема с dpkg
« Ответ #1 : 30 Январь 2009, 19:21:30 »
https://bugs.launchpad.net/ubuntu/intrepid/+source/dpkg/+bug/262451

Говорят, что умирает всё на gxine, помогает
sudo dpkg --remove gxine
sudo dpkg --configure -a
sudo apt-get install gxine

Если нет gxine — нужно копать дальше.

Оффлайн ypeskov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Проблема с dpkg
« Ответ #2 : 30 Январь 2009, 19:31:37 »
https://bugs.launchpad.net/ubuntu/intrepid/+source/dpkg/+bug/262451

Говорят, что умирает всё на gxine, помогает
sudo dpkg --remove gxine
sudo dpkg --configure -a
sudo apt-get install gxine

Если нет gxine — нужно копать дальше.
не, судя по логам таки на xine. сейчас попробую

Оффлайн ypeskov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Проблема с dpkg
« Ответ #3 : 30 Январь 2009, 19:32:34 »
Спасибо, помогло. усе поправил.
ну почти все :) gxine не хочет устанавливаться :)

теперь вылетает следующая ошибка везде:

dpkg: error processing libgtk2.0-doc (--configure):
 package libgtk2.0-doc is not ready for configuration
 cannot configure (current status `triggers-awaited')
Errors were encountered while processing:
 libgtk2.0-doc
E: Sub-process /usr/bin/dpkg returned an error code (1)

в общем
sudo apt-get remove libgtk2.0-doc
sudo apt-get install libgtk2.0-doc

вроде бы помогли. посмотрю что будет дальше :)
« Последнее редактирование: 30 Январь 2009, 19:41:56 от ypeskov »

 

Страница сгенерирована за 0.055 секунд. Запросов: 22.