Форум русскоязычного сообщества Ubuntu


Автор Тема: Проблема с обновлением [РЕШЕНО]  (Прочитано 454 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bod-ik

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
Проблема с обновлением [РЕШЕНО]
« : 05 Февраль 2009, 16:36:38 »
У меня возникла проблема при обновление Ubuntu 8.10 c помощью Synaptic Package Manager. После загрузки всех нужних пакетов на ПК, идет попытка обновление, в результете которой получаю оконное сообщение следующего содержания:
"E: /var/cache/apt/archives/dpkg_1.14.20ubuntu6.1_amd64.deb: subprocess dpkg-deb --control returned error exit status 2"
Помогите, пожалуйста)
« Последнее редактирование: 09 Февраль 2009, 04:28:53 от bod-ik »

Оффлайн magnolia

  • Участник
  • *
  • Сообщений: 126
    • Просмотр профиля
Re: Проблема с обновлением
« Ответ #1 : 05 Февраль 2009, 16:44:22 »
# dpkg --configure -aили
# apt-get -f install

Оффлайн bod-ik

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
Re: Проблема с обновлением
« Ответ #2 : 05 Февраль 2009, 16:59:04 »
root@bb-laptop:/home/bb# apt-get -f install
Чтение перечней пакетов... Выполнено
Построение дерева зависимостей
Reading state information... Выполнено
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 329 пакетов не обновлено

Оффлайн bod-ik

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
Re: Проблема с обновлением [РЕШЕНО]
« Ответ #3 : 09 Февраль 2009, 04:31:01 »
все, я разобрался в чем проблема! Дело в том, что deb-пакеты(в часности и те, которые нужны для обновления) не хотели инсталироваться по причине отсутсвия tar в системе. Скомпилил и установил tar - и все заработало)

 

Страница сгенерирована за 0.053 секунд. Запросов: 22.