Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Нужна помощь с монодевелоп  (Прочитано 1919 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AeroCore

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Нужна помощь с монодевелоп
« : 07 Февраль 2009, 03:38:15 »
Мне уже как то плевать какая версия будет 1 или 2.
Никак не получается установить её.
Пробовал по ламерски через установку удаление
Цитировать
(еще все равно пришлось коче что докачивать
gtk-engines
потом поставил gmcs
monodevelop-nunit)
То при такой установке в нейспейсах System не все классы устанавливаются и нет конкретно класса Drawing.

Нашел другой способ установки
http://pilot34.com/search/label/mono
Но в этом случае уже после запуска монодевелоп вылазит постоянно ошибка
Цитировать
System.FormatException: Unknown char: .
at System.Double.Parse (System.String s, NumberStyles style, IFormatProvider provider) [0x00000]
at System.Single.Parse (System.String s, IFormatProvider provider) [0x00000]
at System.Convert.ToSingle (System.String value, IFormatProvider provider) [0x00000]
at System.String.System.IConvertible.ToSingle (IFormatProvider provider) [0x00000]
at System.Convert.ToType (System.Object value, System.Type conversionType, IFormatProvider provider) [0x00000]
at System.Convert.ChangeType (System.Object value, System.Type conversionType) [0x00000]
at Stetic.PropertyDescriptor.StringToValue (System.String value) [0x00000]
at Stetic.PropertyDescriptor.Load (System.Xml.XmlElement elem) [0x00000]
at Stetic.TypedPropertyDescriptor..ctor (System.Xml.XmlElement elem, Stetic.ItemGroup group, Stetic.TypedClassDescriptor klass) [0x00000]
at Stetic.TypedClassDescriptor.CreateItemDescriptor (System.Xml.XmlElement elem, Stetic.ItemGroup group) [0x00000]
at Stetic.ItemGroup..ctor (System.Xml.XmlElement elem, Stetic.ClassDescriptor klass) [0x00000]
at Stetic.ClassDescriptor.Load (System.Xml.XmlElement elem) [0x00000]
at Stetic.TypedClassDescriptor..ctor (System.Reflection.Assembly assembly, System.Xml.XmlElement elem) [0x00000]
at Stetic.AssemblyWidgetLibrary.LoadClassDescriptor (System.Xml.XmlElement element) [0x00000]
at Stetic.WidgetLibrary.Load (System.Xml.XmlDocument objects) [0x00000]
at Stetic.AssemblyWidgetLibrary.Load () [0x00000]
at Stetic.Registry.RegisterWidgetLibrary (Stetic.WidgetLibrary library) [0x00000]

А после перезагрузки компа ось вообще сдохла(начала вставать при загрузке какого то MTA)
пришлось через рековери зайти  а потом все таки зашло только теперь звук пропал и наверное еще что нить.

А вот теперь вопрос;
1.Как мне установить МоноДевелоп?
2.Как можно востановить систему после удаления  нужных её пакетов?(ксати ща пытаюсь все востановить через историю синаптика ,но пока без успешно).

Оффлайн ZigBee

  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Нужна помощь с монодевелоп
« Ответ #1 : 07 Февраль 2009, 11:20:14 »
Monodevelop2 сырой. определенные вкусности там конечно есть, но пока лучше не расстраиваться.
В 8.10 есть и mono и mono2, настоящая версия последнего - 1.9.1, это же версия Monodevelop2 beta2.

Попробуй:
1) Удали все, что ставил касательно mono. Совсем удали, то есть sudo apt-get purge ...
2) Убери левые репозитории.
2) Поставь monodevelop. У меня из стандартных репозиториев установлены следующие пакеты:
zigbee@zigbee:~$ dpkg --get-selections | grep mono
libapache2-mod-mono install
libmono-accessibility2.0-cil install
libmono-addins-gui0.2-cil install
libmono-addins0.2-cil install
libmono-cairo1.0-cil install
libmono-cairo2.0-cil install
libmono-corlib1.0-cil install
libmono-corlib2.0-cil install
libmono-data-tds1.0-cil install
libmono-data-tds2.0-cil install
libmono-dev install
libmono-i18n1.0-cil install
libmono-i18n2.0-cil install
libmono-mozilla0.2-cil install
libmono-npgsql2.0-cil install
libmono-peapi2.0-cil install
libmono-security1.0-cil install
libmono-security2.0-cil install
libmono-sharpzip0.84-cil install
libmono-sharpzip2.84-cil install
libmono-sqlite1.0-cil install
libmono-sqlite2.0-cil install
libmono-system-data1.0-cil install
libmono-system-data2.0-cil install
libmono-system-runtime2.0-cil install
libmono-system-web1.0-cil install
libmono-system-web2.0-cil install
libmono-system1.0-cil install
libmono-system2.0-cil install
libmono-winforms2.0-cil install
libmono-zeroconf1.0-cil install
libmono0 install
libmono1.0-cil install
libmono2.0-cil install
mono-2.0-devel install
mono-apache-server2 install
mono-common install
mono-gac install
mono-gmcs install
mono-jit install
mono-runtime install
mono-xsp2 install
mono-xsp2-base install
monodevelop install
monodevelop-database install
monodoc-base install
monodoc-manual install

System.Drawing есть и все работает.
Я в Monodevelop пишу XmlRpc.Net веб-сервайсы и клиенты к ним, в том числе с использованием Gtk# под Linux и WinForms под оффтопик.

На счет восстановления систему - надо знать, что ты удалил. Можно попытаться переустановить мета-пакет (x|k)ubuntu-desktop.
"Встает при загрузке какого-то MTA"- это значит ты попортил sendmail/exim4/postfix.
Пропавший звук, если ты не трогал ядро означает, что ты грохнул либо alsa, либо pulse. Еще вариант - HAL.

Удачи!
« Последнее редактирование: 07 Февраль 2009, 14:01:57 от ZigBee »
«Programming is like sex: one mistake and you have to support it for the rest of your life». (Michael Sinz)

Оффлайн AeroCore

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Нужна помощь с монодевелоп
« Ответ #2 : 09 Февраль 2009, 03:08:57 »
Спасибо что откликнулся
Кссати помимо звука тогда еще дисски не хотели монтироваться
А недавно начал идти по историе и востанавливать удаленные пакеты вроде все восстановил
после ребута МТА не ругалось но теперь гном слетел то есть после залогинивания нет ничего кроме обоев рабочего тола
Здается мне что это изза того что послушал одного мудака и подключил репозитории jaunty.


Оффлайн AeroCore

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Нужна помощь с монодевелоп
« Ответ #3 : 17 Февраль 2009, 02:39:30 »
че делать ?
Пробежался по твоему списку пакетов и как ни старался не нашел два пакета
libmono-mozilla0.2-cil
monodevelop-database
Потом защел на http://packages.ubuntu.com/
Так вот для харди пакета monodevelop-database нет а для интерпида они есть  :P ???
вооот?!
 

Lidlencom

  • Гость
Re: Нужна помощь с монодевелоп
« Ответ #4 : 09 Сентябрь 2009, 11:59:57 »
Цитировать
"Встает при загрузке какого-то MTA"- это значит ты попортил sendmail/exim4/postfix.

У самого такая проблема на домашнем и на ноуте. Никуда не лазил, как поставил систему так и пользовался.  Может какие-то зависимые пакеты поставил? Помогите, а то очень напрягает ждать загрузку MTA. Т.е. вопрос в том, как убрать эту загрузку?

Оффлайн alexander.pronin

  • Старожил
  • *
  • Сообщений: 2540
    • Просмотр профиля
Re: Нужна помощь с монодевелоп
« Ответ #5 : 15 Сентябрь 2009, 16:15:54 »
Может поможет. У с меня 8.10 работают 32 и 64 битная версии. Все cil у меня.
al@ubuntu-desktop1:~$ dpkg --get-selections | grep "\-cil"
libart2.0-cil               install
libflickrnet2.1.5-cil            install
libgconf2.0-cil               install
libglade2.0-cil               install
libglib2.0-cil               install
libgmime2.2-cil               install
libgnome-keyring1.0-cil            install
libgnome-vfs2.0-cil            install
libgnome2.0-cil               install
libgtk2.0-cil               install
libgtkhtml3.16-cil            install
libgtksourceview2.0-cil            install
libmono-accessibility2.0-cil         install
libmono-addins-gui0.2-cil         install
libmono-addins0.2-cil            install
libmono-cairo1.0-cil            install
libmono-cairo2.0-cil            install
libmono-cecil0.5-cil            install
libmono-corlib1.0-cil            install
libmono-corlib2.0-cil            install
libmono-data-tds1.0-cil            install
libmono-data-tds2.0-cil            install
libmono-i18n1.0-cil            install
libmono-i18n2.0-cil            install
libmono-mozilla0.2-cil            install
libmono-peapi2.0-cil            install
libmono-security1.0-cil            install
libmono-security2.0-cil            install
libmono-sharpzip0.84-cil         install
libmono-sharpzip2.84-cil         install
libmono-sqlite2.0-cil            install
libmono-system-data1.0-cil         install
libmono-system-data2.0-cil         install
libmono-system-runtime2.0-cil         install
libmono-system-web1.0-cil         install
libmono-system-web2.0-cil         install
libmono-system1.0-cil            install
libmono-system2.0-cil            install
libmono-winforms2.0-cil            install
libmono1.0-cil               install
libmono2.0-cil               install
libmysql5.0-cil               install
libndesk-dbus-glib1.0-cil         install
libndesk-dbus1.0-cil            install
al@ubuntu-desktop1:~$

 

Страница сгенерирована за 0.057 секунд. Запросов: 24.