Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Конфликт зависимосте пакетов  (Прочитано 397 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн margadon_13

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • __---0000
    • Просмотр профиля
Конфликт зависимосте пакетов
« : 08 Февраль 2009, 16:36:19 »
У важаемые убунтовцы!
В чем моя ошибка? не могу установить новый и вернуть установкой бывший Pidgin . Ругается.

margadon@MGD-1362:~$ sudo apt-get install pidgin
[sudo] password for margadon:
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.

Так как вы просили выполнить только одну операцию, то вероятнее всего, что
пакет просто не может быть установлен из-за ошибок в самом пакете.
Необходимо послать отчёт об этой ошибке.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
pidgin: Зависит: pidgin-data (< 1:2.5.2-z) но 1:2.5.4-1~getdeb1 будет установлен
Зависит: libpurple0 (>= 1:2.5.2-0ubuntu1) но он не будет установлен
E: Сломанные пакеты
Как быть, парни?
« Последнее редактирование: 08 Февраль 2009, 17:28:02 от nett00n »
Лесничий

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: Конфликт зависимосте пакетов
« Ответ #1 : 08 Февраль 2009, 18:44:02 »
sudo apt-get install -f

Оффлайн margadon_13

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • __---0000
    • Просмотр профиля
Re: Конфликт зависимосте пакетов
« Ответ #2 : 08 Февраль 2009, 19:15:54 »
Выполнил! При попытке установить - ответ такойже!
Лесничий

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: Конфликт зависимосте пакетов
« Ответ #3 : 08 Февраль 2009, 19:19:09 »
А, getdeb... Нужно скачать оттуда все пакеты:
pidgin,  pidgin-data ,  libpurple0,  libpurple-bin
Сложить их в один каталог, потом в этом каталоге выполнить команду
sudo dpgk -i *.deb
Кстати, вот ещё, там же на getdeb-е написано:
Цитировать
Note:Please remove your current version before installing the new version.
« Последнее редактирование: 08 Февраль 2009, 19:23:04 от Kwah »

Оффлайн margadon_13

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • __---0000
    • Просмотр профиля
Re: Конфликт зависимосте пакетов
« Ответ #4 : 08 Февраль 2009, 19:55:57 »
Спасибо Всем!
Вопрос решился удалением пакетов всех зависимостей и повторной установкой! :angel:
Лесничий

 

Страница сгенерирована за 0.055 секунд. Запросов: 22.