Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: перстала запускаться Ubuntu  (Прочитано 5651 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Defender

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
перстала запускаться Ubuntu
« : 09 Февраль 2009, 12:47:25 »
собственно что выдает:
Boot from (hd0,5) ext3
Starting up...
19+0 record in
19+0 record out
Kinit : name_to_dev_t(/dev/disk/by-uuid/куча букв и цифр) =dev(8,17)
Kinit : trying to resume from /dev/disk/ by uuid/куча букв и цифр
Kinit : No resume image,doing normal boot
mount : mounting /dev/disk/ by uuid on /root
failed : invalid argument
mount : mounting /root/dev on /dev/.static/dev failed : No such file or derectory
mount : mounting /sys on /root/sys failed : No such file or derectory
mount : mounting /proc on /root/proc failed : No such file or derectory
Target file system doesn't have /sbin/init
No init found/Try passing init= bootarg
BusyBox v1.10.2(Ubuntu 1:1.10.2-1ubuntu6)
build-in shele (ash)
Enter 'Help' бла бла бла
(initramfs)

Оффлайн axe

  • Старожил
  • *
  • Сообщений: 1203
    • Просмотр профиля
Re: перстала запускаться Ubuntu
« Ответ #1 : 09 Февраль 2009, 14:07:06 »
показывай содержимое /boot/grub/menu.lst, /etc/fstab, а также вывод
sudo fdisk -lи
sudo blkid(видимо, придется для всего этого загрузиться с LiveCD)

Oni-chan

  • Гость
Re: перстала запускаться Ubuntu
« Ответ #2 : 09 Февраль 2009, 14:17:01 »
Скорее всего, пути монтирования прописаны неправильные. С fstab кто-то жестоко поигрался

Оффлайн AkC

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: перстала запускаться Ubuntu
« Ответ #3 : 30 Апрель 2009, 21:32:05 »
Не буду создавать новую тему, напишу в этой.
Была Ubuntu 8,10 обновил до 9,04. Все было норм. Перевел раздел / и home на ext4. Три дня проработало хорошо, даже загружаться на 15 сек быстрее стала.
А сегодня стал включать:
Error 24: Attemp to access block iutside partitionЭто на новом ядре. На старом выводит сообщение, по типу как в первом посту.
Вывод fdisk - l, blkid:
ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc3ffc3ff

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         127     1020096   83  Linux
/dev/sda2            3825       19457   125572072+   5  Extended
/dev/sda5            3825        6256    19535008+  83  Linux
/dev/sda6            6257        6499     1951866   82  Linux swap / Solaris
/dev/sda7            6500       12578    48829536   83  Linux
/dev/sda8           12579       17526    39744778+   b  W95 FAT32
/dev/sda9           17527       19457    15510726   83  Linux
ubuntu@ubuntu:~$ sudo blkid
/dev/loop0: TYPE="squashfs"
/dev/sda1: UUID="e478c9d3-5ff1-4425-aa4b-b7a7913f2396" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda5: UUID="9cb3bcd4-70b6-47ad-90d4-8399061a12a1" TYPE="ext4"
/dev/sda6: TYPE="swap"
/dev/sda7: UUID="db1d9b20-4c98-4440-8d52-f885810eb73e" TYPE="ext4"
/dev/sda8: UUID="6D1C-44DF" TYPE="vfat"
/dev/sda9: UUID="b2d6371f-f4cc-4ee3-940e-84361a8dd1ee" SEC_TYPE="ext2" TYPE="ext3"
ubuntu@ubuntu:~$

Мой fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda5
UUID=9cb3bcd4-70b6-47ad-90d4-8399061a12a1 /               ext4 relatime,errors=remount-ro 0       1
# /dev/sda7
UUID=db1d9b20-4c98-4440-8d52-f885810eb73e /home           ext4    relatime        0       2
# /dev/sda6
UUID=14bbea91-df45-4ba5-c12e-bafc1895c0c0 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

На винте также стоит debian.
Проводил проверку разделов, результатов нет.
Что можете посоветовать?

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net
Re: перстала запускаться Ubuntu
« Ответ #4 : 30 Апрель 2009, 21:56:05 »
AkC, одна из проблем, что сразу просается в граза -- отсутствие uuid для swap-раздела.
За подробностями см.
man mkswap

Оффлайн AkC

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: перстала запускаться Ubuntu
« Ответ #5 : 30 Апрель 2009, 22:04:32 »
AkC, одна из проблем, что сразу просается в граза -- отсутствие uuid для swap-раздела.
За подробностями см.
man mkswap
man mkswap результатов не дал. Свап один для debian и Ubnuntu. При этом дебиан работает хорошо. sda5 на котором стоит корень убунты, хорошо читается с LiveCD. А вот под дебиан не монтируется, не распознает ext4

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net
Re: перстала запускаться Ubuntu
« Ответ #6 : 30 Апрель 2009, 22:14:30 »
man mkswap результатов не дал.
sudo mkswap -U 14bbea91-df45-4ba5-c12e-bafc1895c0c0 /dev/sda6Соответственно, в fstab дебиана прописать этот же uuid.

sda5 на котором стоит корень убунты, хорошо читается с LiveCD. А вот под дебиан не монтируется, не распознает ext4
Ядро старое на дебиане, или может патчи требуемые не наложены?

Оффлайн AkC

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: перстала запускаться Ubuntu
« Ответ #7 : 30 Апрель 2009, 22:48:40 »
fstab debian вообще без UUID-ов, прописал свапу уид, результат тот же.
Target file system doesn't have /sbin/init
No init found/Try passing init= bootarg
BusyBox v1.10.2(Ubuntu 1:1.10.2-1ubuntu6)
Ума не приложу что делать. Кста, если устанавливать grub на раздел с убунтой, он не устанавливается. После установки появляется приглашение граб и все. Поэтому граб стоит на hd0,8. Может дело в grub ?

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net
Re: перстала запускаться Ubuntu
« Ответ #8 : 30 Апрель 2009, 23:02:46 »
Target file system doesn't have /sbin/init
No init found/Try passing init= bootarg
Так, это уже вторая проблема.

Пользователь решил продолжить мысль 30 Апрель 2009, 21:07:28:
Кста, если устанавливать grub на раздел с убунтой, он не устанавливается. После установки появляется приглашение граб и все. Поэтому граб стоит на hd0,8. Может дело в grub ?
Может и в grub, а может в ext4.
« Последнее редактирование: 30 Апрель 2009, 23:08:10 от ArcFi »

Оффлайн AkC

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: перстала запускаться Ubuntu
« Ответ #9 : 30 Апрель 2009, 23:14:19 »
Спасибо за советы. Еще поковыряюсь, если не получится, то заново установлю, а home прежний отсавлю.
P.S. какие патчи нужны для дебиан, чтоб ext4 монтировать.
P.S.2 обновил дебиан, новое ядро 27 - X не стартует. сижу на 26

Оффлайн staleo

  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: перстала запускаться Ubuntu
« Ответ #10 : 18 Сентябрь 2009, 22:57:09 »
Господа, не открываю новую тему, отписываюсь в этой.

Мои симптомы совпадают с тем, что написал автор топика. Следую вот этому совету:

показывай содержимое /boot/grub/menu.lst, /etc/fstab, а также вывод
sudo fdisk -lи
sudo blkid(видимо, придется для всего этого загрузиться с LiveCD)


Итак, вот пара скринов, все должно быть понятно.





(Вообще-то фабула такая: я поставил своей девушке на бук Ubuntu 9.04 и отправил учиться в Милан. Девушка с компами на Вы с большой буквы, если не сказать больше. Проходит две недели и Ubuntu у нее благополучно отказывается грузиться. Шок, ужас, обвинения и проклятья в адрес Марка Шаттлворда - сами понимаете. И координироваться удаленно по скайпу - сущий ад. "Дорогая, нажми F12 при загрузке компьютера" - "Что, вот прямо именно сейчас?" - "ДА, ИМЕННО СЕЙЧАС, скорее... Таааак. Вот эта синенькая фигнюшка - это биос...")

Прошу помощи, в общем.
« Последнее редактирование: 18 Сентябрь 2009, 23:00:15 от 127.0.0.1 »

Оффлайн staleo

  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: перстала запускаться Ubuntu
« Ответ #11 : 21 Сентябрь 2009, 12:00:45 »
Господа, ну ап же.
Не дайте замарать честное имя Шаттлворда в Миланском университете!  :coolsmiley:

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net
Re: перстала запускаться Ubuntu
« Ответ #12 : 21 Сентябрь 2009, 12:10:57 »
127.0.0.1, fstab открыли не на том разделе.

ps
Вывод команд скриншотами читать неудобно.

Оффлайн Daglonn

  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
Re: перстала запускаться Ubuntu
« Ответ #13 : 21 Сентябрь 2009, 12:23:53 »
Автор, сделай reboot
если после этого будут ошибки - выкладывай

Оффлайн Sir Ruf

  • Активист
  • *
  • Сообщений: 326
    • Просмотр профиля
Re: перстала запускаться Ubuntu
« Ответ #14 : 21 Сентябрь 2009, 16:46:59 »
127.0.0.1, fstab открыли не на том разделе.
+100500
и grep -v -e '#' -e ^$ /точка_монтирования_раздела_с_Ubuntu/boot/grub/menu.lst сразу выложи

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.