Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: После перезагрузки не работает Bluetooth клавиатура.  (Прочитано 2742 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Volniy_Strelok

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Люди помогите решить проблему с Bluetooth клавой.
Руководствовался этим http://www.openkazan.info/bluetooth-keyboard-mouse-ubuntu-linux#comment-7769.

Но после перезагрузки клавиатура не работает если залогинится с обычной клавы и повторить команду 
sudo hidd --search

То рабатает.

Где что дописать подправить нужно помогите !! :-[

Оффлайн Volniy_Strelok

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Что совсем нет идей?

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
а описывать проблему не пробовал?

какой DE используешь?
Пробовал ли поставить Blueman?
Прописывал ли HIDD_OPTIONS="--connect 00:11:22:33:44:55" ?
« Последнее редактирование: 20 Февраль 2009, 02:43:25 от sht0rm »

Оффлайн Volniy_Strelok

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Цитировать
какой DE используешь?
Гном у меня
Цитировать
Пробовал ли поставить Blueman?
Нет не ставил проблема то в том что клава не работает при загрузке не думаю что Blueman поможет както

Цитировать
Прописывал ли HIDD_OPTIONS="--connect 00:11:22:33:44:55" ?
А вот тут поподробнее чуток можно? Это где прописать нужно?

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
у меня это находится в /etc/conf.d/bluetooth
как в убунте 8.10 не знаю.

Через gnome-blueooth - Input - добавлял клавиатуру?
Мануал по которому ты подключал клаву довольно старый.

Оффлайн Volniy_Strelok

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
У меня есть каталог /etc/bluetooth  в нем несколько файлов и файл hcid.conf где я прописывал пораметры клавиатуры
Вот его содержимое :


#
# HCI daemon configuration file.
#

# HCId options
options {
   # Automatically initialize new devices
   autoinit yes;

   # Security Manager mode
   #   none - Security manager disabled
   #   auto - Use local PIN for incoming connections
   #   user - Always ask user for a PIN
   #
   security user;

   # Pairing mode
   #   none  - Pairing disabled
   #   multi - Allow pairing with already paired devices
   #   once  - Pair once and deny successive attempts
   pairing multi;

   # Default PIN code for incoming connections
   passkey "1234";
}

# Default settings for HCI devices
device {
   # Local device name
   #   %d - device id
   #   %h - host name
   name "%h-%d";

   # Local device class
   class 0x000100;

   # Default packet type
   #pkt_type DH1,DM1,HV1;

   # Inquiry and Page scan
   iscan enable; pscan enable;
   discovto 0;

   # Default link mode
   #   none   - no specific policy
   #   accept - always accept incoming connections
   #   master - become master on incoming connections,
   #            deny role switch on outgoing connections
   lm accept;

   # Default link policy
   #   none    - no specific policy
   #   rswitch - allow role switch
   #   hold    - allow hold mode
   #   sniff   - allow sniff mode
   #   park    - allow park mode
   lp rswitch,hold,sniff,park;
}

device KEYBOARD_ADDR {
   name “Logitech diNovo Edge”;
   auth enable;
   encrypt enable;
}

KEYBOARD_ADDR 00:07:61:B4:F4:91

в этом файле нужно прописать или где?

Оффлайн Volniy_Strelok

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
есть еще файл /etc/default/bluetooth
Вот его содержимое

# Defaults for bluez

# start bluetooth on boot?
# compatibility note: If this variable is not found bluetooth will
# start
BLUETOOTH_ENABLED=1

# This setting will switch HID devices (e.g mouse/keyboad) to HCI mode, that is
# you will have bluetooth functionality from your dongle instead of only HID.
# Note that not every bluetooth dongle is capable of switching back to HID
# mode, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355497
HIDD_ENABLED=1
HID2HCI_ENABLED=1
HID2HCI_UNDO=1
HIDD_OPTIONS="--connect 00:07:61:B4:F4:91"

Люди помогите !!!!
Надоело писать уже  sudo hidd --search
Только после этой команды хочет работать
Версия менеджера Bluetooth 1.8

Вообще у меня после настройки клавы по мануалу все работало прекрасно это после апгрейда такая бяка случилась.


Пользователь решил продолжить мысль: 26 Март 2009, 21:01:56
Люди не ужели нельзя нечего с этим поделать? :-[
« Последнее редактирование: 26 Март 2009, 21:01:56 от Volniy_Strelok »

Оффлайн Volniy_Strelok

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Нашел такое решение в файле /etc/rc.local
прописал hidd --connect 00:07:61:B4:F4:91
и при старте компа нажимаю на клавиатуре  клавишу коннект.
Изврат конечно но работает.
Буду рад если кто нибудь подскажет правильное решение.   

 

Страница сгенерирована за 0.058 секунд. Запросов: 22.