Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Доэкпериментировался  (Прочитано 601 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gtnheirby

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Доэкпериментировался
« : 25 Март 2009, 13:54:05 »
Вот здесь открывал тему. Может кто нибудь подскажет что то дельное?

http://zeroed.ru/ubuntu/forum/viewtopic.php?f=34&t=449

Скпоировал.
Начало:
Убил иксы (по моему). Эксперементировал с пхп, мускул и апач. В итоге:

Удалил в /etc все упоминания об apache, mysql, php
То же самое проделал с /etc/init.d
Там же удалил и все начинающееся с host*
Перезагрузился, нормально загрузился Гном, но ни один ярлычок не срабатывал при активации (просто ничего не происходило). Загрузился в recovery mode, выполнил xfix (dpkg не отработало, т. к. связи нет). Опять загружаюсь, дохожу до ввода логина - раскладка не переключается, только русский.

Вообщем в итоге неработоспособная система. Но которая грузится с Live CD или на моменте авторизации (при предложении ввести пароль) не переключается в другую раскладку (кстати нормально переключается в tty...).

Ответили:
ты, по ходу, удалив host* удалил файл хостов.
создай в /etc
файл hosts и закинь туда строчку:

127.0.0.1  localhost

и перезагрузи машину

скорее всего не работает именно по этой причине, ибо существование этого интерфейса в системе ОБЯЗАТЕЛЬНО и БЕЗОГОВОРОЧНО. иксы у тебя не при чем.

Далее:
Файлик hosts создал. Нашел решение проблемы непереключения раскладки клавиатуры http://silverghost.org.ua/2008/05/01/pe ... buntu-804/
В итоге иксы стартуют, но невозможно запустить ни одно приложение. Хотя при первой загрузке после редактированя языка и раскладки терминал запускался. При последующей все перестало запускаться.
Интернет есть, из консоли пинг идет.

Итак продолжаю эксперименты. Опытным путем выяснилось что при загрузке с сетью (wi-fi) ни одно приложение из Гнома не запускается. Без сети же все работает. Кстати консоль вместо user@user:~$ выглядит user@(none):~$.
Ну может все-таки кто нибудь подскажет куда копать?
Я так понимаю, мне еще нужен файлик hosts.conf. Гуглю пока как он должен выглядеть
« Последнее редактирование: 25 Март 2009, 14:25:40 от Gtnheirby »

Оффлайн Alsvartr

  • Активист
  • *
  • Сообщений: 779
  • The secret of the secret
    • Просмотр профиля
Re: Доэкпериментировался
« Ответ #1 : 25 Март 2009, 14:03:20 »
Скопируйте текст оттуда в эту тему в свое предыдущее сообщение.

Оффлайн smiftee

  • Участник
  • *
  • Сообщений: 217
    • Просмотр профиля
Re: Доэкпериментировался
« Ответ #2 : 25 Март 2009, 15:53:58 »
Цитировать
Удалил в /etc все упоминания об apache, mysql, php
То же самое проделал с /etc/init.d
Там же удалил и все начинающееся с host*
Однако...
Тут как раз поможет цитата с баша:
(Нажмите, чтобы показать/скрыть)

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Доэкпериментировался
« Ответ #3 : 25 Март 2009, 16:16:25 »
Gtnheirby, готовьте live-cd/usb, бэкапьте файло, переставляйте систему.
Это самое быстрое решение вашей проблемы.

Оффлайн Gtnheirby

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Доэкпериментировался
« Ответ #4 : 25 Март 2009, 21:44:31 »
На зероеде ответили, после того как запостил здесь.
Цитировать
Должен быть файлик /etc/hostname с указанием имени твоей машины:
sudo vim /etc/hostname
пишешь например ubuntu и сохраняеш :wq
Огромное спасибо, все работает. Теперь буду думать о бекапе, прежде чем что то удалять.

 

Страница сгенерирована за 0.181 секунд. Запросов: 22.