Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: МФУ Canon i-sensys mf4018  (Прочитано 1624 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nikon2k

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
МФУ Canon i-sensys mf4018
« : 30 Март 2009, 23:03:11 »
Кто нибудь ставил? дрова с сайта производителя не фурычат...

Оффлайн cheburashka

  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
Re: МФУ Canon i-sensys mf4018
« Ответ #1 : 01 Апрель 2009, 00:27:33 »
Принтер запустился , а вот сканер надо колдовать .

Оффлайн ddpobox

  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: МФУ Canon i-sensys mf4018
« Ответ #2 : 18 Октябрь 2009, 17:35:34 »
Здравствуйте!
Установил МФУ Canon i-Sensys MF4018, драйвер для принтера скачал с http://software.canon-europe.com
Не получается запустить сканер, при попытки запуска xsane 0.996 появляется окно с сообщением "Невозможно открыть устройство 'v4l:/dev/video0': Неверный аргумент."
Что нужно подправить?
В Linux'e чайник.
Спасибо.

Использую следующее оборудование и ПО:
1. МФУ Canon i-Sensys MF4018
2. Ubuntu 9.04 Remix
3. Netbook Asus Eee PC 1000H
4. Результаты выполнения команд:
- uname -a
  Linux Eee 2.6.28-15-generic #52-Ubuntu SMP Wed Sep 9 10:49:34 UTC 2009 i686 GNU/Linux

- lsusb
  Bus 001 Device 007: ID 04a9:26b4 Canon, Inc. MF4010 Series
  Bus 001 Device 006: ID 04f2:b071 Chicony Electronics Co., Ltd
  Bus 001 Device 004: ID 058f:6335 Alcor Micro Corp.
  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  Bus 005 Device 002: ID 0b05:b700 ASUSTek Computer, Inc.
  Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Bus 003 Device 002: ID 046d:c045 Logitech, Inc. Optical Mouse
  Bus 003 Device 003: ID 0458:0063 KYE Systems Corp. (Mouse Systems)
  Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

 - dmesg | tail
  [  259.218052] ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_.EBTS] (Node  f6c14df8), AE_TIME
  [  259.218262] ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_.UBCS] (Node         f6c17420), AE_TIME
  [  259.218453] ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.PCI0.CBST] (Node f6c175a0), AE_TIME
  [  259.218639] ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.PCI0.BAT0._BST] (Node f6c174e0), AE_TIME
  [  259.218838] ACPI Exception (battery-0359): AE_TIME, Evaluating _BST [20080926]
  [ 1895.832148] usb 1-2: new high speed USB device using ehci_hcd and address 7
  [ 1895.976984] usb 1-2: configuration #1 chosen from 1 choice
  [ 1896.052927] usblp0: USB Bidirectional printer dev 7 if 1 alt 0 proto 2 vid 0x04A9 pid 0x26B4
  [ 1896.052981] usbcore: registered new interface driver usblp
  [ 1896.158813] usblp0: nonzero read bulk status received: -71


Оффлайн fwhr

  • Старожил
  • *
  • Сообщений: 2104
    • Просмотр профиля
Re: МФУ Canon i-sensys mf4018
« Ответ #3 : 18 Октябрь 2009, 18:54:27 »
Отсюда видно, что принтер работает, но
Цитировать
Scanning is supported by last Sane CVS snapshots.
Последняя на данный момент времени версия sane 1.0.20, а в убунтовских репозиториях sane-utils 1.0.19-23ubuntu7.
Вывод: пробовать устанавливать sane ручками: может быть, и взаправду, сканер заработает...

Upd:
Хотя, вполне вероятно, что твой сканер заработает из коробки на 9.10 (там sane-utils 1.0.20-4ubuntu3) - если инет позволяет, скачай отсюда последний билд LiveCD и попробуй подключить девайс да проверить...
« Последнее редактирование: 18 Октябрь 2009, 19:06:44 от fwhr »
Обычно люди получают не то, что заслуживают, а то, что получилось... © Доктор Хауз

 

Страница сгенерирована за 0.08 секунд. Запросов: 24.