Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не поднимается wi-fi интерфейс atheros на ноутбуке HP Pavilion dv5-164er  (Прочитано 1400 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн aleks19216901

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Есть ноут со следующим оборудованием:

lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 5)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 11h HyperTransport Configuration (rev 40)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 11h Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 11h DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 11h Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 11h Link Control
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series
01:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]
08:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
0a:00.0 FireWire (IEEE 1394): JMicron Technologies, Inc. IEEE 1394 Host Controller
0a:00.1 System peripheral: JMicron Technologies, Inc. SD/MMC Host Controller
0a:00.2 SD Host controller: JMicron Technologies, Inc. Standard SD Host Controller
0a:00.3 System peripheral: JMicron Technologies, Inc. MS Host Controller
0a:00.4 System peripheral: JMicron Technologies, Inc. xD Host Controller

установил Ubuntu 8.10 - всё устраиваеот кроме отсутствия wi-fi. Перекомпилировал ядро 2.6.27.11 с существующим конфигом (взял из /boot) с поддержкой atheros 5x. Пару дней не мог нарадоваться - работал и достаточно шустро. Потом нажал кнопку выключения wifi адаптера и больше не смог его включить :(.
Вылетает ошибка SIOCSIFFLAGS: Resource temporarily unavailable. Покопал - все советуют подправить настройки в BIOS, которых у меня нету (BIOS вообще куцый какой то).
Мои действия:

root@HP:/tmp/madwifi-0.9.4# iwconfig
lo        no wireless extensions.
eth0      no wireless extensions.
pan0      no wireless extensions.
wmaster0  no wireless extensions.

Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

wlan0     IEEE 802.11bg  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:00:00:00:00:00
          Tx-Power=0 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root@HP:/tmp/madwifi-0.9.4# ifconfig wlan0 up
SIOCSIFFLAGS: Resource temporarily unavailable
root@HP:/tmp/madwifi-0.9.4# iwconfig wlan0 power on
root@HP:/tmp/madwifi-0.9.4# ifconfig wlan0 up
SIOCSIFFLAGS: Resource temporarily unavailable
root@HP:/tmp/madwifi-0.9.4# iwlist wlan0 scan
Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

wlan0     Interface doesn't support scanning : Network is down
root@HP:/tmp/madwifi-0.9.4#

КТО НИБУДЬ СТАЛКИВАЛСЯ?

Пользователь решил продолжить мысль 03 Апрель 2009, 01:09:18:
Кстати на ядре 2.6.29 wifi поднялся, но графика не пашет :(

Оффлайн Аndreich

  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
Я сталкивался с проблемами на Atheros с таким же ципсетом. О том что и как вот здесь: https://forum.ubuntu.ru/index.php?topic=52677.0

Оффлайн aleks19216901

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Ядро надо пересобирать с поддержкой ath 5xxx или просто hal установить?

Оффлайн dorad9

  • Участник
  • *
  • Сообщений: 149
  • так, балуемся
    • Просмотр профиля
 я на таком чипе поднял вай-фай установкой модуля, какого счас не помню тут полно постов на эту тему. шукай.

вот смотри https://forum.ubuntu.ru/index.php?topic=52677.0
https://forum.ubuntu.ru/index.php?topic=39289.0
« Последнее редактирование: 07 Апрель 2009, 12:14:03 от dorad9 »
Samsung R510 (AK), Ubuntu 10.04 x64

Оффлайн aleks19216901

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
в общем, как и говорилось выше, раньше у wi-fi получилось пару дней проработать и он умер (заработало только после перекомпиляции ядра 6.27.7 с включением модуля ath5k).
После того как wifi слетел - проделал следующее:
1. По совету Аndreich'a поставил hal - не помогло;
2. Перекомпилил ядро 6.27.11 - работает (пока ;))
Вывод: без hal'a работал до первого выключения.
Всем спасибо :)

 

Страница сгенерирована за 0.087 секунд. Запросов: 22.