Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Принтер Canon i-SENSYS LBP2900 не подключается  (Прочитано 53579 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн don_rover

  • Автор темы
  • Новичок
  • *
  • Сообщений: 30
    • Просмотр профиля
Версия системы Ubuntu 9.04

Извините за сотую тему по этому вопросу...
Незаводится не в какую, перепробывал все методы которые нашол на форуме, тот что предлагается с драйвером, всё без полезно. До этого нормально работал в 8,04,2...
И еще момент... куда бы в ручную не вешал принтер, система сама после перезагрузки создаёт LBP29002 на порту usb://Canon/LBP2900. Видит все состояния принтера... но не печатает... может это допилять?
В какую сторону нужно копать...?
« Последнее редактирование: 13 Июнь 2016, 16:43:25 от Пользователь »
msi wind u90. ubuntu 9.10

Оффлайн mityi

  • Участник
  • *
  • Сообщений: 103
  • Kubuntu 16.04
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #1 : 28 Апрель 2009, 15:40:00 »
Ситуация аналогичная, и как я почитал не только с Кэнонами, что-то они радикально поломали...

Оффлайн Grommit

  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #2 : 28 Апрель 2009, 17:39:59 »
Может быть так-же решается, раз симптомы те-же?
https://forum.ubuntu.ru/index.php?topic=54136.0

Оффлайн mityi

  • Участник
  • *
  • Сообщений: 103
  • Kubuntu 16.04
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #3 : 28 Апрель 2009, 17:50:13 »
Нет, это не проходит.

Оффлайн K_E_S_T

  • Участник
  • *
  • Сообщений: 198
  • пси][опат
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #4 : 28 Апрель 2009, 18:01:58 »
Может быть так-же решается, раз симптомы те-же?
https://forum.ubuntu.ru/index.php?topic=54136.0

не прокатило. задания повисают в очереди на обработке

Оффлайн uncle dima

  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #5 : 29 Апрель 2009, 00:44:40 »
Была такая фигня на 8.10, вылечил так:
http://ubuntologia.ru/forum/viewtopic.php?f=34&t=233&p=3611&hilit=2900#p3611

Оффлайн genrich

  • Участник
  • *
  • Сообщений: 179
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #6 : 01 Май 2009, 22:26:35 »
Ни одно из вышеперечисленных решений не работают в 9.04. Ну, хоть кто-нибудь запустил его в новой Ubuntu???

Оффлайн alec

  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #7 : 02 Май 2009, 16:35:54 »
принтер Canon LBP 3010 висит и не печатает в 8.04\8.10\9.04  :(

Оффлайн Lucky

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #8 : 02 Май 2009, 18:04:33 »
Присоединяюсь к вышенаписанному - ни одно решение не работает, гугл пока показывает кукишь, если у кого получится - отпишитесь плиз.

Оффлайн klop

  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #9 : 05 Май 2009, 08:51:27 »
У меня такой же принтер и он замечательно работает во всех версиях ubuntu начиная с 7.10.

Ставлю следующим образом:

1. Качаем дрова с официального сайта canon http://software.canon-europe.com/
2. Устанавливаем два пакета из скачанного архива.
3. Регистрируем в системе новый принтер через gui cups там вешаем его на ccp:/var/ccpd/fifo0
4. Редактируем файл /etc/ccpd.conf секцию [PRINTER]
5. Запускаем демон печати canon sudo   /etc/init.d/ccpd start
6. Печатаем

Единственный найденный глюк, если выключить принтер, а потом включить приходится рестартовать демон ccpd, а так все замечательно

p.s. Покупайте PostScript принтеры и не парьтесь с дровами...
« Последнее редактирование: 05 Май 2009, 08:54:49 от klop »

Оффлайн ReVN

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #10 : 05 Май 2009, 12:12:50 »
Как очень начинающий пользователь....попробовал выше написанное руководство применить для принтера LBP-810 (так как писали в других постах, что и для 2900, и для 810 подходит драйвер и решение).
По п.1 - не нашел драйвера по ссылке. Но скачал с других ссылок cndrvcups-capt_1.60-1_i386.deb и cndrvcups-common_1.60-1_i386.deb, а так же драйвер Canon-LBP-810-capt.ppd
По п2 - при установке первых двух пакетов ругался на не выполнение зависимостей и попросил установить libcupsys2. После установки libcupssys2 два пакета встали нормально.
По п.3 ни чего не понял. А пошел устанавливать Система-Администрирование-Печать  Настройка принтера -localhost: Создать-Принтер. Далее программа сама нашла принтер Canon LBP-810 и определила, что подключен к USB порту. При поиске драйвера, доступных драйверов программа не нашла. Перешел на Использовать PPD -файлы. Вот тут и подсунул ему драйвер Canon-LBP-810-capt.ppd. Все встало, но пробную страницу не напечатал. Сообщил о ошибке.
По п.4. Посмотрел файл /etc/ccpd.conf . Там записан принтер LBP3200. Что и как править?
Печать не работает.

Оффлайн K_E_S_T

  • Участник
  • *
  • Сообщений: 198
  • пси][опат
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #11 : 05 Май 2009, 16:32:58 »
У меня такой же принтер и он замечательно работает во всех версиях ubuntu начиная с 7.10.

Ставлю следующим образом:

1. Качаем дрова с официального сайта canon http://software.canon-europe.com/
2. Устанавливаем два пакета из скачанного архива.
3. Регистрируем в системе новый принтер через gui cups там вешаем его на ccp:/var/ccpd/fifo0
4. Редактируем файл /etc/ccpd.conf секцию [PRINTER]
5. Запускаем демон печати canon sudo   /etc/init.d/ccpd start
6. Печатаем

Единственный найденный глюк, если выключить принтер, а потом включить приходится рестартовать демон ccpd, а так все замечательно

p.s. Покупайте PostScript принтеры и не парьтесь с дровами...

вообщето написано про 904.

в 804 работало, 810 незнаю т.к. не мог найти х64 драйвера
в 904 никак пока

Оффлайн RD

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #12 : 05 Май 2009, 18:56:40 »
У меня работает если настроить по этой ссылке: https://forum.ubuntu.ru/index.php?topic=39137.0
Правда, после каждого включения надо рестартовать ccpd. Но это фигня.

Оффлайн K_E_S_T

  • Участник
  • *
  • Сообщений: 198
  • пси][опат
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #13 : 05 Май 2009, 19:04:59 »
У меня работает если настроить по этой ссылке: https://forum.ubuntu.ru/index.php?topic=39137.0
Правда, после каждого включения надо рестартовать ccpd. Но это фигня.

в девятке?

Оффлайн Gaz-Gaz

  • Любитель
  • *
  • Сообщений: 57
    • Просмотр профиля
Re: принтер Canon LBP2900 + 9.04
« Ответ #14 : 07 Май 2009, 03:00:13 »
У меня работает если настроить по этой ссылке: https://forum.ubuntu.ru/index.php?topic=39137.0
Правда, после каждого включения надо рестартовать ccpd. Но это фигня.

в девятке?

есть комп, на котором принтер был настроен ещё в 7.10, и ubuntu на нём только обновлялась. ТАК ТАМ ВСЁ РАБОТАЕТ!!!
а на машинах со свежеустановленным - не работает.



Пользователь решил продолжить мысль 07 Май 2009, 03:05:24:
из мануала по дровам 1.80:

===============================================================

4. Auto startup setting procedure for ccpd daemon -------------------------------
When setting the Status Monitor to start automatically, ccpd daemon must be set
to start automatically as well.
Set ccpd daemon to start automatically in the following procedure.

<For a distribution with a /etc/rc.local file>
Log in as 'root' and add the '/etc/init.d/ccpd start' command to the
/etc/rc.local file.

<For a distribution with a /sbin/insserv command>
Log in as 'root', add the following comments to the third line in
/etc/init.d/ccpd, and execute the 'insserv ccpd' command.

### BEGIN INIT INFO
# Provides:          ccpd
# Required-Start:    $local_fs $remote_fs $syslog $network $named
# Should-Start:      $ALL
# Required-Stop:     $syslog $remote_fs
# Default-Start:     3 5
# Default-Stop:      0 1 2 6
# Description:       Start Canon Printer Daemon for CUPS

### END INIT INFO


====================================================
помогите осилить иноязычную абракадабру
« Последнее редактирование: 07 Май 2009, 03:05:24 от Gaz-Gaz »
Ubuntu 14.04

 

Страница сгенерирована за 0.065 секунд. Запросов: 25.