Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Xlib: extension "XFree86-DRI" missing on display ":0.0".  (Прочитано 2589 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gwern

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • блог
Xlib: extension "XFree86-DRI" missing on display ":0.0".
« : 09 Декабрь 2006, 01:55:37 »
Не одно так другое..  теперь другой сабж.  Что с этим делать?

root@kappa:/home/gwern# fglrxinfo
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

root@kappa:/home/gwern# glxinfo
name of display: :0.0
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x2a 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x3e 32 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None

root@kappa:/home/gwern# lsmod | grep fglrx
fglrx                 406988  0
agpgart                34888  2 fglrx,nvidia_agp

 :-\

Оффлайн Yoda

  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #1 : 09 Декабрь 2006, 20:29:49 »
Полистай форум. Это всегда трудно для НТИ если еще нет опыта. И посмотри какие пакеты ты ставишь)))
E=mc^2

Оффлайн Yoda

  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #2 : 09 Декабрь 2006, 20:34:35 »
Xorg.conf в студиЮ)))
E=mc^2

Оффлайн gwern

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • блог
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #3 : 09 Декабрь 2006, 23:06:31 »
Xorg.conf в студиЮ)))

прикрепил

[вложение удалено Администратором]

Оффлайн gwern

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • блог
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #4 : 09 Декабрь 2006, 23:07:42 »
Полистай форум. Это всегда трудно для НТИ если еще нет опыта. И посмотри какие пакеты ты ставишь)))

Спасибо на добром слове. (8

Оффлайн Yoda

  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #5 : 11 Декабрь 2006, 19:30:25 »
У тебс видео PCI-EX?

"PCI:3:0:0"  --- это проверь | :~$ lspci

добавь в секцию device:

Option "UseInternalAGPGART" "no"

*если ставишь бинарные пакеты (*.deb), то могут быть и ошибки. Для НТИ лучшее пользоваться их  установкой.


E=mc^2

Оффлайн gwern

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • блог
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #6 : 11 Декабрь 2006, 20:10:09 »
У тебс видео PCI-EX?

"PCI:3:0:0"  --- это проверь | :~$ lspci

добавь в секцию device:

Option "UseInternalAGPGART" "no"

*если ставишь бинарные пакеты (*.deb), то могут быть и ошибки. Для НТИ лучшее пользоваться их  установкой.

Нет, у меня AGP 4x ATI Sapphire 8500pro
PCI:3:0:0  -верно

Пользуюсь *.deb    Никаких ошибок в dmesg и в X11.0.log    Только варнинг что DRI не запущен, хотя в начале писалось что XFree86-DRI loaded..  или это разное \-8

Также при выключении композита в X11.config, подвешиваются иксы намертво.

Оффлайн Yoda

  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #7 : 12 Декабрь 2006, 00:03:13 »
Надо лог посмотреть)
Какие-то странные у тебс симптомы.....
/var/log/Xorg.0.log.....
E=mc^2

Оффлайн gwern

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • блог
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #8 : 12 Декабрь 2006, 01:49:34 »
Надо лог посмотреть)
Какие-то странные у тебс симптомы.....
/var/log/Xorg.0.log.....

Там ни одного егога.   

P.S.:: Спасибо за участие в решении траблы. Я забил до лучших времен на fglrx и скатился на xorg-driver-ati  (8
Часик поковырсл и чудо
gwern@kappa:~$ glxinfo
        name of display: :0.0
        display: :0 screen: 0
        direct rendering: Yes
       
        gwern@kappa:~$ glxgears -printfps
        8747 frames in 5.0 seconds = 1749.292 FPS
        9819 frames in 5.0 seconds = 1963.628 FPS
        9833 frames in 5.0 seconds = 1966.469 FPS
        9831 frames in 5.0 seconds = 1966.133 FPS
        9655 frames in 5.0 seconds = 1930.844 FPS
       
        Мос старушка еще что-то может. Я счастлив. (8

Оффлайн Yoda

  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #9 : 12 Декабрь 2006, 20:46:31 »
Дело не в еррорах, а в поддержке твоего чипа этим пакетом драйверов.
Ну раз решил проблему, то удачи)
E=mc^2

Оффлайн kinesis

  • Любитель
  • *
  • Сообщений: 57
    • Просмотр профиля
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #10 : 15 Декабрь 2006, 16:20:14 »
P.S.:: Спасибо за участие в решении траблы. Я забил до лучших времен на fglrx и скатился на xorg-driver-ati  (8
Часик поковырсл и чудо
gwern@kappa:~$ glxinfo
        name of display: :0.0
        display: :0 screen: 0
        direct rendering: Yes
а что конкретно поковырсл не вспомнишь? есть примерно такас же ситуацис.

Оффлайн Mr.Cherry

  • Участник
  • *
  • Сообщений: 102
    • Просмотр профиля
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #11 : 15 Декабрь 2006, 18:14:29 »
У мнс  radeon 9600, такас же проблема.
а где xorg-driver-ati откопать? с ним опенгл работает?

Оффлайн Mr.Cherry

  • Участник
  • *
  • Сообщений: 102
    • Просмотр профиля
Re: Xlib: extension "XFree86-DRI" missing on display ":0.0".
« Ответ #12 : 18 Декабрь 2006, 22:14:37 »
А с всё таки поставил...  :D ::) 8)
Под седегой в Call of Duty сыграл...
Скорей всего сказалось полное удаление всех пакетов дров из системы.. или sudo aticonfig --force --initial

 

Страница сгенерирована за 0.059 секунд. Запросов: 22.