Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Помогите настроить звук в XFCE  (Прочитано 29996 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sinij

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Помогите настроить звук в XFCE
« : 20 Май 2009, 22:43:13 »
Неработает звук в XFCE подскажите куда копать. В Гноме все нормально.

Оффлайн Yuko

  • Участник
  • *
  • Сообщений: 207
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #1 : 21 Май 2009, 01:38:32 »
эээ... информации б побольше. как подсказывает сидящий рядом экстрасенс, в убунте два DE - гном и крыса, причем звук работает только в гноме..
хорошо, начнем с простейшего, попробуйте нажать в крысе Alt+F2 и сказать
xfce4-mixerможет включить чего надо
./configure --not-war --love; make

Оффлайн aliftin

  • Старожил
  • *
  • Сообщений: 1398
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #2 : 21 Май 2009, 16:36:19 »
С таким же успехом можно и alsamixer запустить и там поиграться.
Если мы не можем до чего то дотянуться, мы виним в этом не свой рост, не отсутствие табуретки, а свою цель.

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #3 : 21 Май 2009, 16:47:11 »
а xfmedia проигрывает звук?

Оффлайн fuss

  • Старожил
  • *
  • Сообщений: 2049
    • Просмотр профиля
    • Screenshoter
Re: Помогите настроить звук в XFCE
« Ответ #4 : 21 Май 2009, 16:57:43 »
Посмотри в alsa-mixer случайно не стоит mute (было похожее, весь день потратил, а оказалось почему-то звук просто был вкл.)

Оффлайн OldWiseJoe

  • Новичок
  • *
  • Сообщений: 30
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #5 : 22 Май 2009, 17:41:47 »
 У меня похожая беда, в гноме было все норм. Потом я снес Ubuntu и поставил с нуля ксUbuntu, при включении системы звука нет приходиться заходить в регулировщик громкости выключать mute и выставлять нормальный уровень громкости, тогда звук появляется :D. Но вот в чем подвох, при перезагрузке системы история повторяется: система самовольно врубает mute и скидывает громкость  :'(

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #6 : 22 Май 2009, 17:46:25 »
OldWiseJoe
sudo alsactl store

Оффлайн OldWiseJoe

  • Новичок
  • *
  • Сообщений: 30
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #7 : 23 Май 2009, 07:34:08 »
 Беда с правами :
joe@joe:~/Рабочий стол$ sudo alsactl store
E: core-util.c: Home directory /home/joe not ours.
joe@joe:~/Рабочий стол$ alsactl store
alsactl: save_state:1541: Cannot open /var/lib/alsa/asound.state for writing: Permission denied
joe@joe:~/Рабочий стол$


Оффлайн aliftin

  • Старожил
  • *
  • Сообщений: 1398
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #8 : 23 Май 2009, 10:08:51 »
Добавте себя в группу audio (29 кажется) и наверно проблема решится.
Если мы не можем до чего то дотянуться, мы виним в этом не свой рост, не отсутствие табуретки, а свою цель.

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #9 : 23 Май 2009, 11:32:09 »
Добавте себя в группу audio (29 кажется) и наверно проблема решится.
>Home directory /home/joe not ours.

тут дело не в аудио.

OldWiseJoe
Игрались с правами?

Оффлайн Astropoezd

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #10 : 23 Май 2009, 13:33:53 »
У меня та же проблема ( система Xubuntu 9.04 64 bit).

После перезагрузки звук стабильно устанавливается на 0.

Заметил, что пока стоит чистый XUbuntu, всё в порядке со звуком, а вот как только поставишь пакет "xubuntu-restricted-extras", а вместе с ним устанавливается и pulseaudio, вот после этого звук всегда после перезагрузки устанавливается в 0.

Причём, если открывать xfce4-mixer то на 0 стоит именно ползунок под названием "уровень" при выборе в поле "звуковая карта" OSS Mixer, а при выборе ALSA - "общий"

Настройка всех остальных ползунков вроде бы запоминается.

С правами не игрался....

Побывал в aumix (не знаю зачем, но он устанавливается по умолчанию) сохранять настройки, и всё равно, после перезагрузки звук на нуле...

вот....
« Последнее редактирование: 23 Май 2009, 13:42:09 от Astropoezd »

Оффлайн OldWiseJoe

  • Новичок
  • *
  • Сообщений: 30
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #11 : 23 Май 2009, 14:27:54 »
OldWiseJoe
Игрались с правами?

Даже и не думал, с правами у меня проблема и при запуске игрушек с примонтированного ntfs диска :-[ В привилегиях пробовал разрешить доступ всем, но тчетно

Пользователь решил продолжить мысль 23 Май 2009, 14:29:16:
У меня та же проблема ( система Xubuntu 9.04 64 bit).

После перезагрузки звук стабильно устанавливается на 0.

Заметил, что пока стоит чистый XUbuntu, всё в порядке со звуком, а вот как только поставишь пакет "xubuntu-restricted-extras", а вместе с ним устанавливается и pulseaudio, вот после этого звук всегда после перезагрузки устанавливается в 0.

Причём, если открывать xfce4-mixer то на 0 стоит именно ползунок под названием "уровень" при выборе в поле "звуковая карта" OSS Mixer, а при выборе ALSA - "общий"

Настройка всех остальных ползунков вроде бы запоминается.

С правами не игрался....

Побывал в aumix (не знаю зачем, но он устанавливается по умолчанию) сохранять настройки, и всё равно, после перезагрузки звук на нуле...

вот....
Один в один такая же проблема, и система причем тоже 64 бит

Оффлайн amuse.ter

  • Любитель
  • *
  • Сообщений: 90
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #12 : 22 Июнь 2009, 00:12:02 »
За не имением лучшего решения я решил так эту проблему:

создал скрипт:
#! /bin/sh

sleep 15

exec
amixer set Master playback unmute
amixer set Master playback 100%

и добавил его в автозапуск "Сеансы и Запуск" > "Автозапуск приложений"

Сподвижником идеи был:
http://ubuntuforums.org/archive/index.php/t-1150976.html

"Google + man = решение проблем"  :coolsmiley:

Оффлайн фирэфохэ

  • Старожил
  • *
  • Сообщений: 2169
  • straightedge
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #13 : 24 Июнь 2009, 01:44:20 »
может кто-нибудь сталкивался со следующей проблемой: если над регулятором громкости на панели покрутить мышью, максимальный уровень получается 90%. Во всяких xfce-mixer, aumix можно ставить 100%
http://i18.ЗАПРЕЩЁННЫЙ РЕСУРС/big/2011/0325/6d/19eaa72dd24048a6fb0587832c4b096d.gif КДЕ - УГ. Дебиан - недоось.

Оффлайн amuse.ter

  • Любитель
  • *
  • Сообщений: 90
    • Просмотр профиля
Re: Помогите настроить звук в XFCE
« Ответ #14 : 24 Июнь 2009, 08:37:05 »
Это у всех :D

 

Страница сгенерирована за 0.066 секунд. Запросов: 24.