Форум русскоязычного сообщества Ubuntu


Автор Тема: Проблема с кодировкой  (Прочитано 2520 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн VaLeRa2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Проблема с кодировкой
« : 22 Май 2009, 19:12:13 »
После обовления с 8.10 на 9.04 появилась така я проблема: У меня лежали некоторые текстовые файлы в кодировке windows 1251. После обновления я открыл эти файлы, а там фиг знает что. Я пытался через редактор текста сохранить файл в другой кодиревки, он не дает, ругается мол кадировка не UTF-8 и не windows 1251. Также пытался отрыть текст через FireFox, чтобы там поменять кодировку и посмотреть в какой кодировке файл, но тоже без успешно. iconv тоже не дал некаких результатов. Самое странное, что файлы лежащие в .ISO образе тоже поменяли кадировку, при переносе файлов в виндовс, кодировка тоже никак не определяется.

Оффлайн Malamut

  • Ubuntu Member
  • Администратор
  • Старожил
  • *
  • Сообщений: 3353
  • Я добрый, честно!
    • Просмотр профиля
    • Моя страница на Launchpad
Re: Проблема с кодировкой
« Ответ #1 : 22 Май 2009, 19:39:17 »
Плохо понял что и как делалось, но могу сказать вот что:
1. Файлы можно перекодировать в utf-8 с помощью консольной программы enca:
enca -c file.txt2. Можно открывать в gedit в любой кодировке. Для этого нужно открыть gedit (Приложения->Стандартные->Текстовый редактор), убедиться что в нём не открыт ни один файл, если открыт - закрыть, потом выбрать меню Файл-Открыть, найти там искомый файл, выбрать из списка нужную кодировку и нажать на кнопочку открыть. Если файл действительно в такой кодировке, то он откроется нормально.
"Носителем суверенитета и единственным источником власти в Российской Федерации является ее многонациональный народ" Конституция РФ

Оффлайн VaLeRa2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Проблема с кодировкой
« Ответ #2 : 22 Май 2009, 20:00:41 »
Цитировать
Плохо понял что и как делалось, но могу сказать вот что:
1. Файлы можно перекодировать в utf-8 с помощью консольной программы enca:
Код:

enca -c file.txt

2. Можно открывать в gedit в любой кодировке. Для этого нужно открыть gedit (Приложения->Стандартные->Текстовый редактор), убедиться что в нём не открыт ни один файл, если открыт - закрыть, потом выбрать меню Файл-Открыть, найти там искомый файл, выбрать из списка нужную кодировку и нажать на кнопочку открыть. Если файл действительно в такой кодировке, то он откроется нормально.

Не один из способов не помог. И я не как не могу поянть в какой кодировки сейчас файлы.

Оффлайн timerlan2006

  • Новичок
  • *
  • Сообщений: 4
  • Рождённые в СССР
    • Просмотр профиля
Re: Проблема с кодировкой
« Ответ #3 : 24 Май 2009, 14:51:06 »
присоединяюсь к вопросу! как добавить в систему кодировки? а то накроется переписка с людьми которые вод виндой сидят, и сам же недавно перешёл на линукс. :-[
Жопа-есть универсальный интерфейс, ибо через неё можно сделать всё что угодно....

Оффлайн smiftee

  • Участник
  • *
  • Сообщений: 217
    • Просмотр профиля
Re: Проблема с кодировкой
« Ответ #4 : 24 Май 2009, 15:46:43 »
присоединяюсь к вопросу! как добавить в систему кодировки? а то накроется переписка с людьми которые вод виндой сидят, и сам же недавно перешёл на линукс. :-[
Цитировать
locale -a
Показать сюда вывод.
(Нажмите, чтобы показать/скрыть)

Оффлайн Malamut

  • Ubuntu Member
  • Администратор
  • Старожил
  • *
  • Сообщений: 3353
  • Я добрый, честно!
    • Просмотр профиля
    • Моя страница на Launchpad
Re: Проблема с кодировкой
« Ответ #5 : 24 Май 2009, 16:25:30 »
Вы немного не понимаете: в системе есть все кодировки. И gedit умеет открывать файлы в любой русской кодировке (1251, koi8-r, cp866). Если файл не открывается в gedit при явном указании кодировки, значит, он не в этой кодировке и всё тут. Так что вопрос не понятен. enca так же без проблем перекодирует файлы из 1251 в utf-8, если файлы действительно в 1251, кроме того можно явно указать откуда и куда конвертировать в опциях.
"Носителем суверенитета и единственным источником власти в Российской Федерации является ее многонациональный народ" Конституция РФ

Оффлайн Nebulosa

  • Активист
  • *
  • Сообщений: 397
    • Просмотр профиля
Re: Проблема с кодировкой
« Ответ #6 : 24 Май 2009, 17:00:28 »
$ locale -a
C
POSIX
en_US.utf8
ru_RU.utf8
Однако проблемы с кодировками файлов не имею. Намек на то, что локали тут не причем, нужно просто настроить Gedit, или поставить ему плагин для работы с кодировками.

Pidgin тоже работает нормально с аськами, флешки и CD монтируются нормально без проблем с русскими именами файлов. Все настраивается.

Оффлайн VaLeRa2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Проблема с кодировкой
« Ответ #7 : 24 Май 2009, 20:18:48 »
Вобщем мне не получилось обьяснить суть проблемы.  :(
Вобщем так: до обновленя до 9.04 некоторые файлы TXT а также как сейчас выяснелось и PHP лежали в cp1251 кодировке. После обновленя, появилась неразбериха. Какой бы я кодировкой файлы не открывал, как бы я их не перекодирывал. Результат остается один и тот же, непонятные символы в тексте. Ну вот вроде изложил суть как смог.

Оффлайн CigaretteBurn

  • Любитель
  • *
  • Сообщений: 82
    • Просмотр профиля
Re: Проблема с кодировкой
« Ответ #8 : 25 Май 2009, 02:03:13 »
запускаем gconf-editor, идем в apps -> gedit-2 -> preferences -> encodings
изменяем ключ auto_detected   , добавляем в него новую кодировку - WINDOWS-1251 и ставим ее ПОД!!! UTF-8
вот и все теперь gedit будет все норм распозновать.

Оффлайн VaLeRa2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Проблема с кодировкой
« Ответ #9 : 25 Май 2009, 19:29:36 »
CigaretteBurn У меня стоят такие настройки

Оффлайн Dima-simfer

  • Новичок
  • *
  • Сообщений: 11
  • Редкостный охламон
    • Просмотр профиля
Re: Проблема с кодировкой
« Ответ #10 : 03 Июль 2009, 17:00:47 »
Или так : gedit, "открыть", внизу "автоопределение" , в самом низу "добавить или удалить". Не получается с автоопределением, попробуй по очереди каждую, их там много. :)

 

Страница сгенерирована за 0.093 секунд. Запросов: 23.