Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: 9.04 LTSP kernel panic при загрузке одного клиента  (Прочитано 3955 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Xepec

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
    • Просмотр профиля
После обновления до 9.04 один из клиентов начал выдавать при загрузке kernel panic. (До этого на 7.10 все работало нормально.)

Грузится до появления логотипа убунты и виснет мигая капсом и скрол локом. Однажды удалось выскочить в первый экран, где было написанно что-то вроде Unkowin device: eth0 и что-то про то, что неполучается смонтировать рутовый раздел. В логах пусто. Сетевуха в клиенте rtl 8139.

Что с ним делать?

Оффлайн jel

  • Активист
  • *
  • Сообщений: 828
    • Просмотр профиля
Проверить почему перестал монтироваться корневой раздел и куда делся eth0.

Это если вкратце. А если подробно - грузиться с LiveCD, проверять корневой раздел, проверять какое ядро грузится и что передается в качестве корневой файловой системы ядру в /boot/grub/menu.lst. Когда удастся загрузить систему - найти eth0 будет уже проще.

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
войти в меню grub, выбрать нужный пункт меню, нажать e, выбрать строку kernel, ещё раз e, в конце строки удалить quiet и splash, после чего enter, затем b

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
никакого grub'а там вроде и нету, а вот что следовало бы сделать - так это пересобрать клиент (sudo ltsp-build-client)

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
сетевая загрузка?
не помешало бы отключить splash и quiet, чтобы увидеть причину, но как быть в таком случае -- не знаю

Оффлайн Xepec

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
    • Просмотр профиля
В том то и дело, что это LTSP, ни груба ни даже локального диска нету, отсюда нет и логов.

Единственное, что успеваю сделать перед паником, после загрузки img если понажимать разные клавиши появляется строчка:
"boot:"
Если нажать ентер, то грузится дальше до кернел паника.

Может быть туда можно какие-нибудь параметры ввести?

Такое ощущение, что ему драйверов от этой карточки не хватает, но как это можно проверить?

ЗЫ ltsp-update-image ltsp-update-kernels уже делал.   

Пользователь решил продолжить мысль 02 Июнь 2009, 12:30:51:
... продолжение ...

Если на запрос "boot: " пишем vmlinuz .
Начинается загрузка пишет несколько экранов (прочитать невозможно очень быстро (Break не работает))
В конце :
VFS: Cannot open root device "<NULL>" or unknown-block(104,1)
Please append a correct "root=" boot option: here are available partitions:
Kernel panic not syncing: VFS unable to mount root fs on unknown-block(104,1)

Что делать?
« Последнее редактирование: 02 Июнь 2009, 12:30:51 от Xepec »

Оффлайн Xepec

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
    • Просмотр профиля
Повторюсь, что делать или куда копать???
Народ помогите, на работе мозги каждый день дрюкают из-за этого компа...

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
поставь другую сетевухку, риалтек или интел например

Оффлайн Xepec

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
    • Просмотр профиля
RTL 8139 это и есть риалтек. Надо попробывать конечно интелевскую, но боюсь, что я ее не найду...

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
кстати, этот баг не похож? https://bugs.launchpad.net/ubuntu/+source/ltsp/+bug/365380

ещё, если я правильно понял последовательность действий, в /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default надо будет убрать "quiet splash", затем ltsp-update-...
после этого должен отключиться splash и вывестись полный лог загрузки.

либо попробовать ввести в boot: то что в этом файле написано (после DEFAULT)

Оффлайн Xepec

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
    • Просмотр профиля
Re: 9.04 LTSP kernel panic при загрузке одного клиента
« Ответ #10 : 04 Июнь 2009, 17:58:03 »
Похож, но причина похоже не та.

Вот что мне выдало, после того как отключил splash и quiet

Begin: Loading essential drivers
...
8139too: Fast Ethernet driver 0.9.28
8139cp: 10/100 PCI Ethernet Driver v 1.3 (Mar 22,2004)
...
...............
ipconfig: eth0: SIOCGIFINDEX: No such device
ipconfig: no devices to configure
/init: .: line 1: can't open /tmp/net-eth0.conf
kernel panic - not syncing: Attempted to kill init!

Т.е. карточку он увидел, драйвера подгрузил, но почему-то не видит ее в девайсах под именем eth0.

В предложенном баге у человека было несколько сетевух. Я грузанулся с LiveCD (правда 7.10) lshw нашел только одну сетевуху причем написал:
Description: Ethernet interface
...
Logical name: eth0
...
driver=8139too module=8139too...


Т.е. с лайва сетевуха видна как eth0.

Как-нибудь можно в процессе загрузки остановиться и запустить консоль, чтоб можно было по-внимательнее изучить в чем может быть проблема?

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
Re: 9.04 LTSP kernel panic при загрузке одного клиента
« Ответ #11 : 04 Июнь 2009, 18:03:44 »
а попробуй загрузиться с лайва 9.04?

Оффлайн Xepec

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
    • Просмотр профиля
Re: 9.04 LTSP kernel panic при загрузке одного клиента
« Ответ #12 : 04 Июнь 2009, 18:13:18 »
уже поставил его качаться :).

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
Re: 9.04 LTSP kernel panic при загрузке одного клиента
« Ответ #13 : 04 Июнь 2009, 18:23:18 »
ipconfig: eth0: SIOCGIFINDEX: No such device
ipconfig: no devices to configure

Похоже, что это не та сетевая, в которую воткнут кабель. Попробуй воткнуть кабель в другую.

Оффлайн Xepec

  • Автор темы
  • Участник
  • *
  • Сообщений: 156
    • Просмотр профиля
Re: 9.04 LTSP kernel panic при загрузке одного клиента
« Ответ #14 : 04 Июнь 2009, 18:39:27 »
Гы, там одна сетевуха...
И из под лайва она видна.
Да и через нее качается ядро линуха, которое потом её и не находит :). (Да вот такие вот дела :) )

ЗЫ Как из под лайва запустить только консоль, а то у меня там мозгов всего 256 и пока гном грузится шибко тормозит ?

 

Страница сгенерирована за 0.056 секунд. Запросов: 22.