Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: проблема с пакетами  (Прочитано 1624 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sanek22

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
проблема с пакетами
« : 05 Июнь 2009, 18:53:25 »
добрый день,HELP,  не устанавлиывается ни одни пакет пишет E: ttf-dejavu-extra: подпроцесс post-installation script возвратил код ошибки 1
такое выдает в терминале E: Не удалось открыть файл блокировки /var/lib/apt/lists/lock - open (13 Permission denied)
E: Невозможно заблокировать каталог со списками пакетов
все случилось после попытки удалить KDE. :-[

Оффлайн the.geka

  • Участник
  • *
  • Сообщений: 205
  • Остановился на UNR 9.10 для нетбука.
    • Просмотр профиля
Re: проблема с пакетами
« Ответ #1 : 05 Июнь 2009, 18:54:40 »
кто там в кащенка?  :2funny:
Вільній країні - вільний софт! UA- Українці Афігенні.
На нетбуке unr, на ноуте 7.

Оффлайн Holly

  • Активист
  • *
  • Сообщений: 810
  • Ubuntu - одна система на компе.
    • Просмотр профиля
    • Medibuntu
Re: проблема с пакетами
« Ответ #2 : 05 Июнь 2009, 19:23:24 »
Ну на счет блокировки все понятно, надо выполнять команду с sudoесли делал с sudo, то тогда был открыт сенаптик или установка/удаление программ.
выполни:sudo aptitude update && sudo aptitude upgradeа KDE как удалял?

Оффлайн sanek22

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: проблема с пакетами
« Ответ #3 : 06 Июнь 2009, 00:20:23 »
http://psychocats.net/ubuntu/puregnome вот так
удалял

Пользователь решил продолжить мысль 06 Июнь 2009, 00:37:54:
Вот что выдал после того как прописал sudo aptitude update && sudo aptitude upgrade


Запись информации расширенных состояний... Готово
Из кеша: http://ru.archive.ubuntu.com jaunty Release.gpg
Получить:1 http://ru.archive.ubuntu.com jaunty/main Translation-ru [268kB]     
Получить:2 http://ru.archive.ubuntu.com jaunty/restricted Translation-ru [5108B]
Получить:3 http://ru.archive.ubuntu.com jaunty/universe Translation-ru [264kB] 
Получить:4 http://ppa.launchpad.net intrepid Release.gpg [307B]                 
Игн http://ppa.launchpad.net intrepid/main Translation-ru                       
Из кеша: http://archive.canonical.com jaunty Release.gpg                       
Игн http://archive.canonical.com jaunty/partner Translation-ru                 
Из кеша: http://packages.medibuntu.org jaunty Release.gpg                       
Игн http://packages.medibuntu.org jaunty/free Translation-ru                   
Игн http://packages.medibuntu.org jaunty/non-free Translation-ru               
Получить:5 http://ru.archive.ubuntu.com jaunty/multiverse Translation-ru [13,2kB]
Из кеша: http://ru.archive.ubuntu.com jaunty-updates Release.gpg               
Из кеша: http://security.ubuntu.com jaunty-security Release.gpg                 
Игн http://security.ubuntu.com jaunty-security/main Translation-ru             
Получить:6 http://ppa.launchpad.net intrepid Release [65,9kB]                   
Игн http://ru.archive.ubuntu.com jaunty-updates/main Translation-ru             
Игн http://ru.archive.ubuntu.com jaunty-updates/restricted Translation-ru       
Игн http://ru.archive.ubuntu.com jaunty-updates/universe Translation-ru         
Игн http://ru.archive.ubuntu.com jaunty-updates/multiverse Translation-ru       
Из кеша: http://ru.archive.ubuntu.com jaunty Release                           
Из кеша: http://archive.canonical.com jaunty Release                           
Игн http://security.ubuntu.com jaunty-security/restricted Translation-ru       
Из кеша: http://packages.medibuntu.org jaunty Release                           
Из кеша: http://ru.archive.ubuntu.com jaunty-updates Release                   
Игн http://security.ubuntu.com jaunty-security/universe Translation-ru         
Игн http://security.ubuntu.com jaunty-security/multiverse Translation-ru       
Игн http://ppa.launchpad.net intrepid Release                                   
Из кеша: http://security.ubuntu.com jaunty-security Release                     
Из кеша: http://ru.archive.ubuntu.com jaunty/main Packages                     
Из кеша: http://ru.archive.ubuntu.com jaunty/restricted Packages               
Из кеша: http://ru.archive.ubuntu.com jaunty/main Sources                       
Из кеша: http://ppa.launchpad.net intrepid/main Packages                       
Из кеша: http://ru.archive.ubuntu.com jaunty/restricted Sources                 
Игн http://archive.canonical.com jaunty/partner Packages                       
Из кеша: http://ru.archive.ubuntu.com jaunty/universe Packages                 
Из кеша: http://security.ubuntu.com jaunty-security/main Packages               
Из кеша: http://packages.medibuntu.org jaunty/free Packages                     
Из кеша: http://ru.archive.ubuntu.com jaunty/universe Sources                   
Из кеша: http://ru.archive.ubuntu.com jaunty/multiverse Packages               
Игн http://archive.canonical.com jaunty/partner Sources                         
Из кеша: http://ru.archive.ubuntu.com jaunty/multiverse Sources                 
Из кеша: http://security.ubuntu.com jaunty-security/restricted Packages         
Из кеша: http://security.ubuntu.com jaunty-security/main Sources               
Из кеша: http://security.ubuntu.com jaunty-security/restricted Sources         
Из кеша: http://security.ubuntu.com jaunty-security/universe Packages           
Из кеша: http://ru.archive.ubuntu.com jaunty-updates/main Packages             
Из кеша: http://packages.medibuntu.org jaunty/non-free Packages                 
Получить:7 http://apt.wicd.net hardy Release.gpg [197B]                         
Из кеша: http://ru.archive.ubuntu.com jaunty-updates/restricted Packages       
Игн http://apt.wicd.net hardy/extras Translation-ru                             
Из кеша: http://ru.archive.ubuntu.com jaunty-updates/main Sources               
Из кеша: http://archive.canonical.com jaunty/partner Packages                   
Из кеша: http://security.ubuntu.com jaunty-security/universe Sources           
Из кеша: http://security.ubuntu.com jaunty-security/multiverse Packages         
Из кеша: http://security.ubuntu.com jaunty-security/multiverse Sources         
Из кеша: http://ru.archive.ubuntu.com jaunty-updates/restricted Sources         
Из кеша: http://ru.archive.ubuntu.com jaunty-updates/universe Packages         
Из кеша: http://ru.archive.ubuntu.com jaunty-updates/universe Sources           
Из кеша: http://ru.archive.ubuntu.com jaunty-updates/multiverse Packages       
Из кеша: http://ru.archive.ubuntu.com jaunty-updates/multiverse Sources         
Из кеша: http://archive.canonical.com jaunty/partner Sources                   
Получить:8 http://apt.wicd.net hardy Release [17,2kB]                           
Игн http://apt.wicd.net hardy Release     
Игн http://apt.wicd.net hardy/extras Packages
Из кеша: http://apt.wicd.net hardy/extras Packages
Получено 550kБ в 1s (480kБ/с)
Чтение списков пакетов... Готово                                       
W: Ошибка: http://ppa.launchpad.net intrepid Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 60487016493B3065
W: Ошибка: http://apt.wicd.net hardy Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY FEC820F4B8C0755A
W: Вы можете запустить 'apt-get update' для исправления этих ошибок

W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Следующие пакеты будут УДАЛЕНЫ:
  ttf-dejavu-extra{u}
0 пакетов обновлено, 0 установлено новых, 1 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0Б архивов. После распаковки освободится 5898kБ.
Хотите продолжить? [Y/n/?] Y
(Чтение базы данных... на данный момент установлено 148262 файлов и каталогов.)
Удаляется пакет ttf-dejavu-extra...
E: /var/lib/defoma/locked exists.
E: Another defoma process seems running, or you aren't root.
E: If you are root and defoma process isn't running undoubtedly,
E: it is possible that defoma might have aborted.
E: Please run defoma-reconfigure -f to fix its broken status.
dpkg: не удалось обработать параметр ttf-dejavu-extra (--remove):
 подпроцесс pre-removal script возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 ttf-dejavu-extra
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет.  Попытка восстановить:
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях       
Инициализация состояний пакетов... Готово         

« Последнее редактирование: 06 Июнь 2009, 00:37:54 от sanek22 »

Оффлайн gantellus

  • Старожил
  • *
  • Сообщений: 1276
    • Просмотр профиля
Re: проблема с пакетами
« Ответ #4 : 06 Июнь 2009, 03:06:48 »
омг, Hardy, Intrepid и Jaunty  в одном месте  :o автор, разберись с репозитариями, оставь только те, которые актуальны для твоей версии системы
Придумайте ещё более дружественный интерфейс, и мир породит ещё более тупого юзера (с)
С2Duo 2.4 Ghz, Geforce 8800, Maya 44 PCI

Оффлайн sanek22

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: проблема с пакетами
« Ответ #5 : 06 Июнь 2009, 10:54:05 »
это как ??? я не могу нгичего поставить не удалить :-\

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
Re: проблема с пакетами
« Ответ #6 : 06 Июнь 2009, 10:56:51 »
Ещё одному надо словарик прислать :)
Цитировать
Please run defoma-reconfigure -f to fix its broken status.
Переведёшь сам может?

Оффлайн sanek22

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: проблема с пакетами
« Ответ #7 : 07 Июнь 2009, 01:44:00 »
невозможно удалить `/var/lib/defoma/locked': Permission denied ???

Пользователь решил продолжить мысль 07 Июнь 2009, 01:48:31:
Чтение списков пакетов... Готово                                       
W: Ошибка: http://ppa.launchpad.net intrepid Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 60487016493B3065
W: Ошибка: http://apt.wicd.net hardy Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY FEC820F4B8C0755A
W: Вы можете запустить 'apt-get update' для исправления этих ошибок

Current status: 1 update [+1].
W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Следующие пакеты будут УДАЛЕНЫ:
  ttf-dejavu-extra{u}
Следующие пакеты будут обновлены:
  libtrackerclient0
Следующие не до конца установленные пакеты будут настроены:
  irda-utils
1 пакетов обновлено, 0 установлено новых, 1 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 192kБ архивов. После распаковки освободится 5898kБ.
Хотите продолжить? [Y/n/?] Y
Запись информации расширенных состояний... Готово
Получить:1 http://ru.archive.ubuntu.com jaunty-updates/main libtrackerclient0 0.6.93-0ubuntu3 [192kB]
Получено 192kБ в 0s (2034kБ/с)     
(Чтение базы данных... на данный момент установлено 148316 файлов и каталогов.)
Удаляется пакет ttf-dejavu-extra...
E: /var/lib/defoma/locked exists.
E: Another defoma process seems running, or you aren't root.
E: If you are root and defoma process isn't running undoubtedly,
E: it is possible that defoma might have aborted.
E: Please run defoma-reconfigure -f to fix its broken status.
dpkg: не удалось обработать параметр ttf-dejavu-extra (--remove):
 подпроцесс pre-removal script возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 ttf-dejavu-extra
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет.  Попытка восстановить:
Настраивается пакет irda-utils (0.9.18-8.1ubuntu1) ...
/var/lib/dpkg/info/irda-utils.postinst: line 184: ./MAKEDEV: No such file or directory
/var/lib/dpkg/info/irda-utils.postinst: line 92: update-modules: команда не найдена
dpkg: не удалось обработать параметр irda-utils (--configure):
 подпроцесс post-installation script возвратил код ошибки 127
При обработке следующих пакетов произошли ошибки:
 irda-utils
Чтение списков пакетов... Готово                                       
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Го не поимогло :-\
« Последнее редактирование: 07 Июнь 2009, 01:48:31 от sanek22 »

ры

  • Гость
Re: проблема с пакетами
« Ответ #8 : 07 Июнь 2009, 01:50:14 »
sudo gedit /path/to/sources.list

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: проблема с пакетами
« Ответ #9 : 07 Июнь 2009, 01:54:25 »
sanek22, у вас в сорц-листах каша, репы не подписаны, процессы конфигурирования повисли и, вполне вероятно, бардак с зависимостями.

Это всё можно разгрести, но... меня одолевают сомнения, вероятно, чистая переустановка в вашем случае будет быстрее.

Оффлайн sanek22

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: проблема с пакетами
« Ответ #10 : 07 Июнь 2009, 16:25:33 »
точто переустановка помогла)

 

Страница сгенерирована за 0.089 секунд. Запросов: 23.