Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Индикатор раскладки клавиатуры замёрз  (Прочитано 4179 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Gr33nGroove

  • Автор темы
  • Гость
Индикатор раскладки клавиатуры замёрз на "США", я нажимаю альт шифт и ничё не меняется (не переводится на "Русский") хотя сама раскладка меняется!

Оффлайн alexander.pronin

  • Старожил
  • *
  • Сообщений: 2540
    • Просмотр профиля
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #1 : 18 Июнь 2009, 16:06:40 »
Попробуйте.
Правая мышь на панели - правая кнопка мыши - добавить на панель - индикатор раскладки клавиатуры.

Gr33nGroove

  • Автор темы
  • Гость
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #2 : 19 Июнь 2009, 12:22:31 »
Да, забыл сказать - после ребута - добавляеш на панель етот индикатор и всё нормально. Но я чё то не хочу постоянно его туда добавлять )))

Оффлайн alexander.pronin

  • Старожил
  • *
  • Сообщений: 2540
    • Просмотр профиля
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #3 : 19 Июнь 2009, 12:46:01 »
Попробуйте другую комбинацию переключения клавиатур (с ctrl).

Gr33nGroove

  • Автор темы
  • Гость
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #4 : 20 Июнь 2009, 11:30:18 »
Вроде помогло, посмотрю чё будет после ребута. Заранее спс  :)

Оффлайн Lian

  • Участник
  • *
  • Сообщений: 139
    • Просмотр профиля
    • Новый проект для начинающих
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #5 : 20 Июнь 2009, 11:51:06 »
Проблема точно такая же. Тока я на одном сайте прочитал что можно надписи заменить значками флагов. Поначалу всё работало но потом зависло на английском. Убрал флаги - всё вернул как было. Всё работало 1 день потом зависло. Короче у меня один в один таже проблема, я подозреваю что это началось после очередного обновления.
Хитрости типа убрать с панели и снова поставить, или задать другие клавиши переключения работают только до перезагрузки. :(.
Похоже что проблема серьёзная.

Оффлайн Hellbeaver

  • Новичок
  • *
  • Сообщений: 30
    • Просмотр профиля
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #6 : 21 Июнь 2009, 22:46:42 »
Тоже столкнулся с этой проблемой нашел решение ее в гугле. Мне помогло. Делаем все по порядку.
1) Сносим содержимое каталога .gconf/desktop/gnome/peripherals/
2) Перезагружаемся
3) Ставим раскладку по умолчанию США. В keys to change ставим  ctr+shift.
4) Перезагружаемся
5) Ставим раскладку опять на alt+shift. Перезагружаемся и видим нормально работающий индикатор.


Оффлайн Ksertoo

  • Активист
  • *
  • Сообщений: 314
  • храм фирэфохэ
    • Просмотр профиля
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #7 : 22 Июнь 2009, 21:47:57 »
Тоже столкнулся с этой проблемой нашел решение ее в гугле. Мне помогло. Делаем все по порядку.
1) Сносим содержимое каталога .gconf/desktop/gnome/peripherals/
2) Перезагружаемся
3) Ставим раскладку по умолчанию США. В keys to change ставим  ctr+shift.
4) Перезагружаемся
5) Ставим раскладку опять на alt+shift. Перезагружаемся и видим нормально работающий индикатор.

спасибо что выложил,но морочно больно...
Kubuntu 10.04 LTS   Linux kernel 2.6.32   KDE 4.4.5

Мой Живой Журнал-Дневник

Оффлайн Lian

  • Участник
  • *
  • Сообщений: 139
    • Просмотр профиля
    • Новый проект для начинающих
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #8 : 27 Июнь 2009, 12:52:06 »
Да это чрезвычайно грубая недоделка.

Оффлайн ShamanAlRamal

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #9 : 08 Июль 2009, 19:03:46 »
Похожая ерунда:

При переключении РУС -> США все ок.
Обратно (т.е. США -> РУС) приходится жать ALT+Shift 2 раза.

Ubuntu 9.04, Gnome

Пользователь решил продолжить мысль 08 Июль 2009, 22:38:30:
Нашел решение, если это можно назвать решением: так происходит (см.выше) при включении пункта "enable extra typographic characters" в диалоге Параметры раскладки -> Разные параметры совместимости. Как сохранить возможность ввода длинного тире, елочек и т.п. русской пунктуации без глюков с раскладкой - пока не придумал.
« Последнее редактирование: 09 Июль 2009, 00:39:18 от ShamanAlRamal »

Оффлайн Norske

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #10 : 27 Июль 2009, 01:41:42 »
Нашел решение, если это можно назвать решением: так происходит (см.выше) при включении пункта "enable extra typographic characters" в диалоге Параметры раскладки -> Разные параметры совместимости. Как сохранить возможность ввода длинного тире, елочек и т.п. русской пунктуации без глюков с раскладкой - пока не придумал.
Аналогичная проблема (появляется лишняя «неопознанная» раскладка), решения тоже не нашел. Баг-рипорт видел здесь.

Тем не менее, опцию можно безболезненно отключить: с типографикой отлично справляется клавиша Сompose, настраивается в том же диалоговом окне.
« Последнее редактирование: 27 Июль 2009, 01:44:34 от Norske »

Оффлайн ShamanAlRamal

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #11 : 27 Июль 2009, 03:35:29 »
2 Norske
Большое спасибо, вы меня здорово выручили. Настроил, пользуюсь. Жаль только что приходится переключаться на латиницу ради «лапок» и т.п. - но это вполне терпимо.

Оффлайн trizer

  • Новичок
  • *
  • Сообщений: 6
  • Ubuntu 10.04 LTS - Lucid Lynx ASUS eee PC 1005p
    • Просмотр профиля
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #12 : 29 Июль 2009, 22:07:58 »
В Ubuntu 8.4 были такие же проблемы, в 9.4 все идиально работает :)

Оффлайн ShamanAlRamal

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #13 : 01 Август 2009, 21:38:05 »
В том то и дело, что работает — но не совсем так идеально, как хотелось бы.

Drak

  • Автор темы
  • Гость
Re: Индикатор раскладки клавиатуры замёрз
« Ответ #14 : 07 Август 2009, 13:03:10 »
Тоже столкнулся с этой проблемой нашел решение ее в гугле. Мне помогло. Делаем все по порядку.
1) Сносим содержимое каталога .gconf/desktop/gnome/peripherals/
2) Перезагружаемся
3) Ставим раскладку по умолчанию США. В keys to change ставим  ctr+shift.
4) Перезагружаемся
5) Ставим раскладку опять на alt+shift. Перезагружаемся и видим нормально работающий индикатор.

Спасибо, вроде помогло!

 

Страница сгенерирована за 0.057 секунд. Запросов: 23.