Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: HowTo: поддержка языков Восточной Азии на примере японского языка [Wiki]  (Прочитано 5878 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн theZest

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1624
  • Я И ДИОД
    • Просмотр профиля
Итак, по умолчанию свободный ввод символов CJK*-языков доступен только в китайской/японской/корейской версиях Ubuntu/Kubuntu. Поэтому нам нужно кое-что установить: sudo apt-get install ibus ibus-anthy im-switchВсяческие scim, uim и прочее теперь не модно, поэтому нам они не понадобятся, тем более что ibus их с успехом заменит. Для поддержки ввода китайских иероглифов или корейских символов нужно ставить ibus-pinyn и ibus-hangul соответственно.
После установки ibus нужно выполнить следующую команду: im-switch -cВам будет предложен выбор метода ввода для текущей локали. Пользователи Gnome выбирают ibus, KDE – ibus-kde. В принципе, этого можно не делать, работать должно и без этого шага, но мало ли, подстраховаться не помешает.
Не знаю, нужно ли прописывать загрузку ibus в автозапуск в Gnome. Попробуйте просто стартануть ibus, может, и запустится при следующем входе в систему автоматически. Через значок в трее можно получить доступ к настройкам этой программы.
Для проверки установите курсор в любом текстовом поле и нажмите Ctrl+Space. Должна появиться небольшая панель с выбором метода ввода и прочими кнопочками (Help и т.д.).
Вот, собственно, и все (для пользователей Gnome).

Пользователям KDE4 придется немного попотеть. По непонятным причинам ibus должным образом не сконфигурирован для корректной работы в Plasma Desktop. По умолчанию есть плазмоид kimpanel, от которого ни холодно, ни жарко. Что же нужно сделать? После установки ibus и выбора ibus-kde в im-switсh необходимо создать скрипт автозапуска ibus при входе в сеанс KDE. Делается это так:
cat > ~/.kde/Autostart/reload-ibus-daemon <<EOF#!/bin/sh
ibus-daemon --replace --xim --panel=/usr/lib/ibus/ibus-ui-kde
EOF
chmod +x ~/.kde/Autostart/reload-ibus-daemonТеперь не забудьте добавить плазмоид kimpanel на панель (в русском переводе плазмоид называется «Панель метода ввода»). На этом наши мытарства окончены.
После следующего логина в системе вы увидите kimpanel с кучей значков. Жмякаете  Ctrl+Space и работаете.
Должно получиться что-то типа этого:


*CJK – это китайский, японский и корейский языки (с англ.)
« Последнее редактирование: 07 Май 2010, 02:51:10 от openmindead »
Ubuntu 7.04-10.10 --> OS X 10.9-10.13 --> Windows 10 Pro + Manjaro KDE

Оффлайн SeaJey

  • Активист
  • *
  • Сообщений: 770
  • Electronic Knight
    • Просмотр профиля
Ссылку на PPA имхо лучше давать не конкретно на индекс репозитория, а на страничку на ланчпаде - так будет проще ключ импортировать и ознакомиться со списком пакетов.

Оффлайн Robotex

  • Любитель
  • *
  • Сообщений: 85
    • Просмотр профиля
Т.к. изучаю восточные языки, приходится пользоваться китайским вводом. В венде это все реализуется нажатием одной галочки, после чего можно вводить латинницей звучание иероглифа и цифрой интонацию. Все удобно - если умеешь говорить, то ввод освоишь с легкостью.
В Убунте поставил SCIM. И все бы хорошо, но в нем реализован не путунхуа (мандариновый диалект), а тайваньский, в котором интонации расположены в другом порядке и соответственно цифры надо нажимать другие. В принципе привыкнуть можно, но нужно пользоватся и венждой и пингвином и постоянно вспоминать, какую клавишу нажать не очень удобно.
Можно как-нибудь перенастроить SCIM?

Оффлайн theZest

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1624
  • Я И ДИОД
    • Просмотр профиля
Скорее всего можно. С настройкой китайского не сталкивался, попробуй порыться в параметрах SCIM, заодно лучше узнаешь, как оно работает.
Ubuntu 7.04-10.10 --> OS X 10.9-10.13 --> Windows 10 Pro + Manjaro KDE

Оффлайн theZest

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1624
  • Я И ДИОД
    • Просмотр профиля
Первый пост был откорректирован в соответствии с последними веяниями моды и политикой LTS-релиза.
+ есть вкусности для кдешников 8)
Ubuntu 7.04-10.10 --> OS X 10.9-10.13 --> Windows 10 Pro + Manjaro KDE

Оффлайн areskz

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Кто-нибудь сталкивался с проблемой автозапуска ibus в gnome?
Что ни делаю, ничего не помогает.

Пробовал создавать ~/.autoexec, и там прописывать запуск (как советуют на оф. сайте), но тоже не сработало.

Приходится постоянно запускать iBus Preferences вручную.

Оффлайн theZest

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1624
  • Я И ДИОД
    • Просмотр профиля
Там чуть выше человек отписывался, что у него в Debian нет ibus.conf, но есть просто ibus. Ты не пробовал проверить этот момент? Второе: не в курсе, что там в последних версиях гнома, но где-то год назад автозапуск программ настраивался через Система-Параметры-Сеансы. Тоже можно попробовать.
Ubuntu 7.04-10.10 --> OS X 10.9-10.13 --> Windows 10 Pro + Manjaro KDE

Оффлайн areskz

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Там чуть выше человек отписывался, что у него в Debian нет ibus.conf, но есть просто ibus. Ты не пробовал проверить этот момент? Второе: не в курсе, что там в последних версиях гнома, но где-то год назад автозапуск программ настраивался через Система-Параметры-Сеансы. Тоже можно попробовать.

Я не очень понял, что ему на это ответили. Написано, мол, надо такие-то строки заменить. А где их нужно менять, я не понял.

Оффлайн theZest

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1624
  • Я И ДИОД
    • Просмотр профиля
Ну, вот он, скрипт для автозапуска ibus в любом DE/WM (от автора ibus, скрипт 100% работает в Fedora):
(Нажмите, чтобы показать/скрыть)

"Если у вас нет /etc/X11/xinit/xinput.d/ibus.conf, то используйте следующую строку" (в скрипте, см. начало скрипта):
# input framework launch
ibus-daemon --xim -d

Если же ibus.conf нет, но есть файл ibus, то тогда приведи скрипт в следующий вид:
# input framework launch
XIM_PROF=ibus
XIM=ibus
XIM_PROGRAM="/usr/bin/ibus-daemon"
ICON="/usr/share/ibus/icons/ibus.svg"
XIM_ARGS="--xim"
PREFERENCE_PROGRAM=/usr/bin/ibus-setup
SHORT_DESC="IBus"
GTK_IM_MODULE=ibus
# QT_IM_MODULE=ibus

if [ -z "$IBUS_SESSION_ID" ]; then
  export IBUS_SESSION_ID=`mktemp -u XXXXXXXX`
fi

echo "XIM_PROGRAM=${XIM_PROGRAM}"
${XIM_PROGRAM} ${XIM_ARGS} &

И да, перед всеми этими шаманствами послушайся совета разработчика, сходи в "Система-Параметры-Сеансы" и отключи автозапуск ibus средствами Gnome.
« Последнее редактирование: 29 Июнь 2010, 03:22:55 от openmindead »
Ubuntu 7.04-10.10 --> OS X 10.9-10.13 --> Windows 10 Pro + Manjaro KDE

Оффлайн areskz

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
openmindead, ibus.conf нет, есть ibus. отредактировал его, как вы написали. в startup applications галочка с ibus снята. не помогло :(

Оффлайн theZest

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1624
  • Я И ДИОД
    • Просмотр профиля
Цитировать
есть ibus. отредактировал его, как вы написали.

Погодите секундочку. Я написал следующее:

Если же ibus.conf нет, но есть файл ibus, то тогда приведи скрипт в следующий вид:
# input framework launch
XIM_PROF=ibus
XIM=ibus
XIM_PROGRAM="/usr/bin/ibus-daemon"
ICON="/usr/share/ibus/icons/ibus.svg"
XIM_ARGS="--xim"
PREFERENCE_PROGRAM=/usr/bin/ibus-setup
SHORT_DESC="IBus"
GTK_IM_MODULE=ibus
# QT_IM_MODULE=ibus

if [ -z "$IBUS_SESSION_ID" ]; then
  export IBUS_SESSION_ID=`mktemp -u XXXXXXXX`
fi

echo "XIM_PROGRAM=${XIM_PROGRAM}"
${XIM_PROGRAM} ${XIM_ARGS} &


Т.е. нужно было редактировать не файл ibus, а скрипт.

Давайте-ка по порядку.
Насколько я понял авторские комментарии, создатель ibus советует отредактировать 45-autoexec.sh:
# sudo gedit /etc/X11/xinit/xinitrc.d/45-autoexec.shСодержимое этого файла должно выглядеть примерно так:
#!/bin/bash
if [ -x "$HOME/.autoexec" ]; then
       . $HOME/.autoexec

Теперь настало время сделать файл .autoexec в домашней директории:
# gedit ~/.autoexecИ вот его содержимое и должно быть следующего содержания:
# input framework launch
XIM_PROF=ibus
XIM=ibus
XIM_PROGRAM="/usr/bin/ibus-daemon"
ICON="/usr/share/ibus/icons/ibus.svg"
XIM_ARGS="--xim"
PREFERENCE_PROGRAM=/usr/bin/ibus-setup
SHORT_DESC="IBus"
GTK_IM_MODULE=ibus
# QT_IM_MODULE=ibus

if [ -z "$IBUS_SESSION_ID" ]; then
  export IBUS_SESSION_ID=`mktemp -u XXXXXXXX`
fi

echo "XIM_PROGRAM=${XIM_PROGRAM}"
${XIM_PROGRAM} ${XIM_ARGS} &


И еще: не забудьте присвоить скрипту (.autoexec) право на выполнение:
chmod +x ~/.autoexec
Теперь -- что нужно сделать в первую очередь.
Восстановить исходное содержимое файла /etc/X11/xinit/xinput.d/ibus из резервной копии (вы же делали резервную копию перед редактированием? Если нет, то удалите и переустановите ibus:
# sudo apt-get purge ibus && sudo apt-get install ibus Это (по идее) должно восстановить файл /etc/X11/xinit/xinput.d/ibus в первозданном виде.

Вроде все. При описании этой процедуры я исходил из того, что вы неправильно поняли автора ibus (судя по тому, что вы пытались редактировать файл ibus вместо скрипта запуска, моя догадка верна ;)). Однако, все может быть -- я в последнее время не высыпаюсь и, возможно, сам что-то перепутал. Короче говоря, пробуйте :D

Да, и прошу заметить, что я таким методом автозапуска ibus не пользуюсь, поэтому сам до конца не понимаю, как работает этот скрипт :2funny:
« Последнее редактирование: 30 Июнь 2010, 03:02:59 от openmindead »
Ubuntu 7.04-10.10 --> OS X 10.9-10.13 --> Windows 10 Pro + Manjaro KDE

Оффлайн areskz

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Не помогло.
К сожалению, бэкап файла ibus я не сделал  :idiot2: , но переустановил ibus. Возможно, этот файл не восстановился. Вы могли бы заглянуть в свой файл, и показать, как он выглядит? (Вы вдь не вносили туда изменений, если я правильно понял?).

Оффлайн theZest

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1624
  • Я И ДИОД
    • Просмотр профиля
У меня так:
(Нажмите, чтобы показать/скрыть)



Честно говоря, все это очень странно. В Gnome таких шаманств не должно быть -- ibus всегда запускался без каких-либо проблем.
Ubuntu 7.04-10.10 --> OS X 10.9-10.13 --> Windows 10 Pro + Manjaro KDE

 

Страница сгенерирована за 0.062 секунд. Запросов: 24.