Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: How-To звук в Asus K40IJ или Intel 82801I (ICH9 Family) HD Audio  (Прочитано 3845 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн k77

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
1)  sudo apt-get install build-essential

2) sudo -s
wget ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/misc/hda-verb/hda-verb-0.3.tar.gz
tar xf hda-verb-0.3.tar.gz
cd hda-verb-0.3
make
cp hda-verb /usr/bin
hda-verb /dev/snd/hwC0D0 0x1c SET_EAPD_BTLENABLE PCM

3) sudo -s
wget ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-driver-unstable-snapshot.tar.gz
tar xf alsa-driver-unstable-snapshot.tar.gz
cd alsa-driver-unstable
./configure --with-cards=hda-intel
make
make install
reboot

Nokman

  • Гость
Re: How-To звук в Asus K40IJ или Intel 82801I (ICH9 Family) HD Audio
« Ответ #1 : 11 Сентябрь 2009, 00:29:22 »
Цитировать
cp hda-verb /usr/bin
hda-verb /dev/snd/hwC0D0 0x1c SET_EAPD_BTLENABLE PCM
У меня пишет "open: No such file or directory"... В чем проблема?

Оффлайн mma

  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: How-To звук в Asus K40IJ или Intel 82801I (ICH9 Family) HD Audio
« Ответ #2 : 13 Сентябрь 2009, 15:54:44 »
Цитата: Nokman

У меня пишет "open: No such file or directory"... В чем проблема?
[/quote

Тоже самое. Если игнорировать, звук заработает, но до следующей перезагрузки.

Оффлайн Veritatis_Exquisitor

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: How-To звук в Asus K40IJ или Intel 82801I (ICH9 Family) HD Audio
« Ответ #3 : 18 Сентябрь 2009, 00:24:10 »
Для того, чтобы всё работало нужно в конфиге ядра (у меня /boot/config-2.6.28-15-generic) найти строчку содержащуюю

CONFIG_SND_HDA_HWDEP

Если она закомментирована, то раскомментить её и прописать:

CONFIG_SND_HDA_HWDEP=y

Вычитал из этой статьи (как я понимаю, на основе сей и построено решение проблемы): http://www.kernel.org/pub/linux/kernel/people/tiwai/docs/HD-Audio.html

У меня так же писало "open: No such file or directory", но после второй перезагрузки звук продолжал работать.
Ещё была такая фишка: при появлении окна входа в систему бубен брынчал, а потом звук не работал. Оказалось, что просто в настройках звука надо было поставить автоопределение.

P.S. Карточка та же самая, ноутбук Compaq (но это, как я понимаю не суть важно).
Простота, не прошедшая стадию сложности, является примитивом.

Оффлайн NikolajII

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: How-To звук в Asus K40IJ или Intel 82801I (ICH9 Family) HD Audio
« Ответ #4 : 30 Сентябрь 2009, 18:36:29 »
Подниму тему:
испробовал все что нашел на форуме...нифига не поет :( по данной инструкции так же не находит папку. Раскоментаривание строчки никчему не привело.

На форуме есть предложение поставить два разных патча: один не дает только удлинение зогрузки до 10 минут :(, второй дает два вариант - либо заикаистый звук либо просто звуковуха теряется :(
Дописывание различных строчек в alsa-base.conf ничего не дало :(
з.ы. все обновленно, все самое последнее по версии....вообщем ХЕЛП

Немного Upd: Снес все что накручивал, и:
1. По данной инструкции я поставил драйвера не unstable, а уже стабле. Не помогло. Выполнить первый пункт данной инструкции так и не удалось.
2. Дописывал в modules и alsa-base.conf различного типа строчки (те что тут по форуму советуются). Результат нулевой.
3. Поставил патчик/пакет alsa-driver-linuxant_1.0.20.3_k2.6.28_15_generic_ubuntu_i386.deb, он перезагружает мне регулятор громкости (это из видимого) и отключает звук. После включения и выкручивания всех ползунков вверх происходит чудо (для меня), появляется звук, НО!!!! этот звук заикающийся и ни фига в общем не может считаться звуком. После перезагрузки все снова пропадает и ни фига не поет :(

з.ы.
lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

ядро 2.6.28-15-generic


ubp: обновил альсу до 1.0.21 по инструкции http://monespaceperso.org/blog-en/2009/08/31/upgrade-alsa-1-0-21-on-ubuntu-jaunty-9-04/
После чего получилось выполнить все пункты первого поста. Звука нет :(


на данный момент проблема решилась установкой Убунты 9.10...но т.к. может понадобиться все таки откатиться на 9.04, если есть какие идеи, пишите.
« Последнее редактирование: 01 Октябрь 2009, 18:09:08 от NikolajII »

Оффлайн mma

  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: How-To звук в Asus K40IJ или Intel 82801I (ICH9 Family) HD Audio
« Ответ #5 : 03 Октябрь 2009, 09:02:27 »
после всех манипуляций помогает только
sudo hda-verb /dev/snd/hwC0D0 0x1c SET_EAPD_BTLENABLE PCMДо следующей перезагрузки, конечно :)
(9.04)

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad

Оффлайн gagarin

  • Любитель
  • *
  • Сообщений: 66
  • whereismymind?
    • Просмотр профиля
Re: How-To звук в Asus K40IJ или Intel 82801I (ICH9 Family) HD Audio
« Ответ #7 : 03 Ноябрь 2009, 01:55:28 »
так всё прекрасно. но обновились. звук есть. В skype приходит сообщение останавливается проигрывание музыки в amarok.  в skype галочка управление звуком убрана.  как быть? сносил pulse ставил алса не помогло :(
asus k40ij + ubuntu 10.04

Оффлайн mma

  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: How-To звук в Asus K40IJ или Intel 82801I (ICH9 Family) HD Audio
« Ответ #8 : 11 Ноябрь 2009, 09:57:15 »
на 9.10 кто из владельцев этого бука перешел? как дела?

 

Страница сгенерирована за 0.064 секунд. Запросов: 24.